summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-13 13:35:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-13 13:35:27 +0000
commit1db4f1a31079034e922357989a8cdfd03003ab8b (patch)
tree3572c4d2817ca22d3608f110b0edd2100ead726b /app-admin/syslog-ng
parentDepend on a more recent libmtp version; Amarok won't compile with <media-libs... (diff)
downloadgentoo-2-1db4f1a31079034e922357989a8cdfd03003ab8b.tar.gz
gentoo-2-1db4f1a31079034e922357989a8cdfd03003ab8b.tar.bz2
gentoo-2-1db4f1a31079034e922357989a8cdfd03003ab8b.zip
Version bump because I want the suppress-repeats functionality for infra.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc6-00521-gcdbf87e x86_64)
Diffstat (limited to 'app-admin/syslog-ng')
-rw-r--r--app-admin/syslog-ng/ChangeLog8
-rw-r--r--app-admin/syslog-ng/syslog-ng-2.1.1.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/app-admin/syslog-ng/ChangeLog b/app-admin/syslog-ng/ChangeLog
index 09a6dfe70ed1..4d66958c67de 100644
--- a/app-admin/syslog-ng/ChangeLog
+++ b/app-admin/syslog-ng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/syslog-ng
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.186 2008/07/17 21:34:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.187 2008/10/13 13:35:27 robbat2 Exp $
+
+*syslog-ng-2.1.1 (13 Oct 2008)
+
+ 13 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +syslog-ng-2.1.1.ebuild:
+ Version bump because I want the suppress-repeats functionality for infra.
17 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-admin/syslog-ng/syslog-ng-2.1.1.ebuild b/app-admin/syslog-ng/syslog-ng-2.1.1.ebuild
new file mode 100644
index 000000000000..0395bc8a4fab
--- /dev/null
+++ b/app-admin/syslog-ng/syslog-ng-2.1.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-2.1.1.ebuild,v 1.1 2008/10/13 13:35:27 robbat2 Exp $
+
+inherit fixheadtails
+
+MY_PV=${PV/_/}
+DESCRIPTION="syslog replacement with advanced filtering features"
+HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
+SRC_URI="http://www.balabit.com/downloads/files/syslog-ng/sources/2.1/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hardened ipv6 selinux spoof-source static tcpd"
+
+RDEPEND=">=dev-libs/eventlog-0.2
+ spoof-source? ( net-libs/libnet )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=dev-libs/glib-2.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex"
+PROVIDE="virtual/logger"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file configure
+ cd "${S}/doc/reference"
+ tar xzf syslog-ng.html.tar.gz || die "tar failed"
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/syslog-ng \
+ --disable-dependency-tracking \
+ $(use_enable ipv6) \
+ $(use_enable !static dynamic-linking) \
+ $(use_enable static static-linking) \
+ $(use_enable spoof-source) \
+ $(use_enable tcpd tcp-wrapper) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README \
+ doc/examples/{syslog-ng.conf.sample,syslog-ng.conf.solaris} \
+ contrib/syslog-ng.conf* \
+ doc/reference/syslog-ng.txt \
+ contrib/syslog2ng "${FILESDIR}/syslog-ng.conf."*
+ dohtml doc/reference/syslog-ng.html/*
+
+ # Install default configuration
+ insinto /etc/syslog-ng
+ if use hardened || use selinux ; then
+ newins "${FILESDIR}/syslog-ng.conf.gentoo.hardened" syslog-ng.conf
+ elif use userland_BSD ; then
+ newins "${FILESDIR}/syslog-ng.conf.gentoo.fbsd" syslog-ng.conf
+ else
+ newins "${FILESDIR}/syslog-ng.conf.gentoo" syslog-ng.conf
+ fi
+
+ insinto /etc/logrotate.d
+ # Install snippet for logrotate, which may or may not be installed
+ if use hardened || use selinux ; then
+ newins "${FILESDIR}/syslog-ng.logrotate.hardened" syslog-ng
+ else
+ newins "${FILESDIR}/syslog-ng.logrotate" syslog-ng
+ fi
+
+ newinitd "${FILESDIR}/syslog-ng.rc6-r1" syslog-ng
+ newconfd "${FILESDIR}/syslog-ng.confd" syslog-ng
+}
+
+pkg_postinst() {
+ echo
+ elog "It is highly recommended that app-admin/logrotate be emerged to"
+ elog "manage the log files. ${PN} installs a file in /etc/logrotate.d"
+ elog "for logrotate to use."
+ echo
+}