summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-10-12 07:27:18 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-10-12 07:27:18 +0000
commitc24d45269de1cf86f424389770fc4fc4325dff4b (patch)
tree6cdf52032ef099bb1208ac3b6c92c2fceeac8348 /app-admin/syslog-ng
parentversion bump for security fix and bugs #7996 and #7951 (diff)
downloadgentoo-2-c24d45269de1cf86f424389770fc4fc4325dff4b.tar.gz
gentoo-2-c24d45269de1cf86f424389770fc4fc4325dff4b.tar.bz2
gentoo-2-c24d45269de1cf86f424389770fc4fc4325dff4b.zip
committing the actual ebuild and digest
Diffstat (limited to 'app-admin/syslog-ng')
-rw-r--r--app-admin/syslog-ng/files/digest-syslog-ng-1.5.211
-rw-r--r--app-admin/syslog-ng/syslog-ng-1.5.21.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/syslog-ng/files/digest-syslog-ng-1.5.21 b/app-admin/syslog-ng/files/digest-syslog-ng-1.5.21
new file mode 100644
index 000000000000..e954cc4d0524
--- /dev/null
+++ b/app-admin/syslog-ng/files/digest-syslog-ng-1.5.21
@@ -0,0 +1 @@
+MD5 1e49bb7f5a8deec6127e9af6b74e2d6f syslog-ng-1.5.21.tar.gz 277526
diff --git a/app-admin/syslog-ng/syslog-ng-1.5.21.ebuild b/app-admin/syslog-ng/syslog-ng-1.5.21.ebuild
new file mode 100644
index 000000000000..7915308e5cf6
--- /dev/null
+++ b/app-admin/syslog-ng/syslog-ng-1.5.21.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-1.5.21.ebuild,v 1.1 2002/10/12 07:27:18 blocke Exp $
+
+IUSE="tcpd"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Syslog-ng is a syslog replacement with advanced filtering features"
+SRC_URI="http://www.balabit.hu/downloads/syslog-ng/1.5/${P}.tar.gz"
+HOMEPAGE="http://www.balabit.hu/en/products/syslog-ng/"
+DEPEND="virtual/glibc
+ >=dev-libs/libol-0.3.3
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc ~sparc64"
+SLOT="0"
+
+src_compile() {
+
+ local myconf
+
+ use tcpd && myconf="--enable-tcp-wrapper"
+
+ econf ${myconf} || die
+
+ # configure script braindamage?
+# cd ${S}/src
+# mv Makefile Makefile.orig
+
+# use tcpd && ( sed -e "s|-lnsl|-lwrap|" Makefile.orig > Makefile || die "sed failure" )
+# use tcpd || ( sed -e "s|-lnsl||" Makefile.orig > Makefile || die "sed failure" )
+
+ emake prefix=${D}/usr all || die "compile problem"
+}
+
+src_install() {
+
+ einstall || die
+ rm -rf ${D}/usr/share/man
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS PORTS README
+ dodoc doc/{syslog-ng.conf.sample,syslog-ng.conf.demo,stresstest.sh}
+ doman doc/{syslog-ng.8,syslog-ng.conf.5}
+ dodoc doc/sgml/{syslog-ng.dvi,syslog-ng.html.tar.gz,syslog-ng.ps,syslog-ng.sgml,syslog-ng.txt}
+
+ dodir /etc/syslog-ng
+ insinto /etc/syslog-ng
+ doins ${FILESDIR}/syslog-ng.conf.sample
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/syslog-ng.rc6 syslog-ng
+}
+
+pkg_postinst() {
+ einfo "A sample configuration file can be found in /etc/syslog-ng."
+ einfo "To convert your existing syslog.conf for use with syslog-ng,"
+ einfo "use the syslog2ng script in /usr/share/doc/${PF}."
+}
+