summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-10-14 13:21:23 +0000
committerJonathan Callen <abcd@gentoo.org>2009-10-14 13:21:23 +0000
commit4b961958ae4bef67970ec4d556f86316aff31cc8 (patch)
treec5cd5d85b0073c9b59c45da3f6fe9d789ed8c868 /app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild
parentVersion bump to 2.1.1. (diff)
downloadgentoo-2-4b961958ae4bef67970ec4d556f86316aff31cc8.tar.gz
gentoo-2-4b961958ae4bef67970ec4d556f86316aff31cc8.tar.bz2
gentoo-2-4b961958ae4bef67970ec4d556f86316aff31cc8.zip
Version bump
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild')
-rw-r--r--app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild b/app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild
new file mode 100644
index 000000000000..4d30fbeeee21
--- /dev/null
+++ b/app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.1.13.ebuild,v 1.1 2009/10/14 13:21:23 abcd Exp $
+
+EAPI="2"
+inherit python autotools
+
+MY_P="${PN%-common}-${PV}"
+
+DESCRIPTION="Common modules of Red Hat's printer administration tool"
+HOMEPAGE="http://cyberelk.net/tim/software/system-config-printer/"
+SRC_URI="http://cyberelk.net/tim/data/system-config-printer/1.1/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+SLOT="0"
+IUSE="doc"
+
+# system-config-printer split since 1.1.3
+RDEPEND="
+ !app-admin/system-config-printer:0
+ dev-libs/libxml2[python]
+ dev-python/dbus-python
+ dev-python/pycups
+ dev-python/pygobject
+ net-print/cups[dbus]
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-split.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-nls
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+}