summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-19 17:50:22 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-19 17:50:22 +0000
commit868d2aed0f9c1f3ac6d14102a0897fe6b1a2f028 (patch)
treeb92ec363141156a68e2044f709729f8bcfe3e19b /app-admin/systemrescuecd-x86
parentx86 stable wrt bug #553724 (diff)
downloadgentoo-2-868d2aed0f9c1f3ac6d14102a0897fe6b1a2f028.tar.gz
gentoo-2-868d2aed0f9c1f3ac6d14102a0897fe6b1a2f028.tar.bz2
gentoo-2-868d2aed0f9c1f3ac6d14102a0897fe6b1a2f028.zip
Bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-admin/systemrescuecd-x86')
-rw-r--r--app-admin/systemrescuecd-x86/ChangeLog9
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.3.ebuild55
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.4.ebuild55
3 files changed, 118 insertions, 1 deletions
diff --git a/app-admin/systemrescuecd-x86/ChangeLog b/app-admin/systemrescuecd-x86/ChangeLog
index 2c2a08ae9202..810a7b0eca80 100644
--- a/app-admin/systemrescuecd-x86/ChangeLog
+++ b/app-admin/systemrescuecd-x86/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/systemrescuecd-x86
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/systemrescuecd-x86/ChangeLog,v 1.7 2015/06/09 08:45:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/systemrescuecd-x86/ChangeLog,v 1.8 2015/07/19 17:50:22 mgorny Exp $
+
+*systemrescuecd-x86-4.5.3 (19 Jul 2015)
+*systemrescuecd-x86-4.5.4 (19 Jul 2015)
+
+ 19 Jul 2015; Michał Górny <mgorny@gentoo.org>
+ +systemrescuecd-x86-4.5.3.ebuild, +systemrescuecd-x86-4.5.4.ebuild:
+ Bump.
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.3.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.3.ebuild
new file mode 100644
index 000000000000..5cd5a832ccee
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.3.ebuild,v 1.1 2015/07/19 17:50:22 mgorny Exp $
+
+EAPI=5
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+RESTRICT="mirror"
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.4.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.4.ebuild
new file mode 100644
index 000000000000..77baa45b811b
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.4.ebuild,v 1.1 2015/07/19 17:50:22 mgorny Exp $
+
+EAPI=5
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+RESTRICT="mirror"
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}