summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-23 15:36:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-23 15:36:37 +0000
commitae9c54d1d0c949d62bfd498971c780f3271306c7 (patch)
tree96e6d5d14d061040e1eda7089eee353f79cc7bf5 /app-admin/watchdog
parentmasked dev-db/mysqlcc (diff)
downloadgentoo-2-ae9c54d1d0c949d62bfd498971c780f3271306c7.tar.gz
gentoo-2-ae9c54d1d0c949d62bfd498971c780f3271306c7.tar.bz2
gentoo-2-ae9c54d1d0c949d62bfd498971c780f3271306c7.zip
uclibc lovin
Diffstat (limited to 'app-admin/watchdog')
-rw-r--r--app-admin/watchdog/files/5.2.4-uclibc.patch11
-rw-r--r--app-admin/watchdog/watchdog-5.2.4.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/app-admin/watchdog/files/5.2.4-uclibc.patch b/app-admin/watchdog/files/5.2.4-uclibc.patch
new file mode 100644
index 000000000000..1986ed88774a
--- /dev/null
+++ b/app-admin/watchdog/files/5.2.4-uclibc.patch
@@ -0,0 +1,11 @@
+--- src/fstab.c.orig 2004-08-23 15:32:22 +0000
++++ src/fstab.c 2004-08-23 15:32:36 +0000
+@@ -237,7 +237,7 @@
+ /* Ensure that the lock is released if we are interrupted. */
+ static void
+ handler (int sig) {
+- die (EX_USER, "%s", sys_siglist[sig]);
++ die (EX_USER, "%s", strsignal(sig));
+ }
+
+ static void
diff --git a/app-admin/watchdog/watchdog-5.2.4.ebuild b/app-admin/watchdog/watchdog-5.2.4.ebuild
index d1fba3e00a85..4f6a35a97f35 100644
--- a/app-admin/watchdog/watchdog-5.2.4.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.2 2004/08/17 18:13:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.3 2004/08/23 15:36:37 vapier Exp $
inherit eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-sundries.patch
+ [ "${PORTAGE_LIBC}" == "uclibc" ] && epatch ${FILESDIR}/${PV}-uclibc.patch
}
src_compile() {