summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-13 15:02:31 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-13 15:02:31 +0000
commit7f2957ae1d2335c0c73e525c8e45d6e1dda1683c (patch)
tree38559e625b0fe72dd5664d5a9acc72d101c9ba60 /app-admin/webmin
parentVersion bumped. Lots of changes in webmin. (diff)
downloadgentoo-2-7f2957ae1d2335c0c73e525c8e45d6e1dda1683c.tar.gz
gentoo-2-7f2957ae1d2335c0c73e525c8e45d6e1dda1683c.tar.bz2
gentoo-2-7f2957ae1d2335c0c73e525c8e45d6e1dda1683c.zip
Version bumped. Lots of changes in webmin.
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog8
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.0801
-rw-r--r--app-admin/webmin/webmin-1.080.ebuild72
4 files changed, 82 insertions, 3 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 59a9aa32573e..8c9bd77abc9b 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/webmin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.17 2003/03/28 10:21:19 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.18 2003/04/13 15:02:11 mholzer Exp $
+
+*webmin-1.080 (13 Apr 2003)
+
+ 13 Apr 2003; Martin Holzer <mholzer@gentoo.org> Manifest,
+ webmin-1.080.ebuild:
+ Version bumped. Lots of changes in webmin.
*webmin-1.070 (21 Feb 2003)
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 0dede8d55079..20984f936a2c 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,6 +1,6 @@
-MD5 704936bb4aa471393c5ab4141e64eb6b ChangeLog 3231
+MD5 c4f4b196e38adc8325cd5e662776a01d ChangeLog 3388
MD5 6452e8ed1e611034cade4e97c5a10c04 webmin-1.070.ebuild 1764
-MD5 6452e8ed1e611034cade4e97c5a10c04 webmin-1.080.ebuild 1764
+MD5 35394441f81a8321971fa6056d0737ea webmin-1.080.ebuild 1763
MD5 35dc51d35fceeed5440486949eb268fe files/digest-webmin-1.070 65
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
diff --git a/app-admin/webmin/files/digest-webmin-1.080 b/app-admin/webmin/files/digest-webmin-1.080
new file mode 100644
index 000000000000..cd222fe82ba7
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.080
@@ -0,0 +1 @@
+MD5 6bb3422a3f9dadc299d0ee0c5f8bb1a6 webmin-1.080.tar.gz 6294611
diff --git a/app-admin/webmin/webmin-1.080.ebuild b/app-admin/webmin/webmin-1.080.ebuild
new file mode 100644
index 000000000000..115eb0dbd37f
--- /dev/null
+++ b/app-admin/webmin/webmin-1.080.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.080.ebuild,v 1.1 2003/04/13 15:02:11 mholzer Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}