summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-19 17:35:58 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-19 17:35:58 +0000
commit2c789697ca234c70280ee83b144e3fea163bb315 (patch)
tree924c3979ee9906a4905a22545a6f7b7f5a0d7278 /app-admin/xstow
parentRemove old. (diff)
downloadgentoo-2-2c789697ca234c70280ee83b144e3fea163bb315.tar.gz
gentoo-2-2c789697ca234c70280ee83b144e3fea163bb315.tar.bz2
gentoo-2-2c789697ca234c70280ee83b144e3fea163bb315.zip
Revision bump. Clean ebuild a little and fix messages. Thanks to Erik Falor
(Portage version: 2.1.10.40/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/xstow')
-rw-r--r--app-admin/xstow/ChangeLog7
-rw-r--r--app-admin/xstow/xstow-1.0.0-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-admin/xstow/ChangeLog b/app-admin/xstow/ChangeLog
index 041ab2c5abd1..941ec929b27b 100644
--- a/app-admin/xstow/ChangeLog
+++ b/app-admin/xstow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/xstow
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/ChangeLog,v 1.11 2011/12/10 15:14:22 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/ChangeLog,v 1.12 2011/12/19 17:35:58 maksbotan Exp $
+
+*xstow-1.0.0-r1 (19 Dec 2011)
+
+ 19 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +xstow-1.0.0-r1.ebuild:
+ Revision bump. Clean ebuild a little and fix messages. Thanks to Erik Falor
*xstow-1.0.0 (10 Dec 2011)
diff --git a/app-admin/xstow/xstow-1.0.0-r1.ebuild b/app-admin/xstow/xstow-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..ee2021eeb97e
--- /dev/null
+++ b/app-admin/xstow/xstow-1.0.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/xstow-1.0.0-r1.ebuild,v 1.1 2011/12/19 17:35:58 maksbotan Exp $
+
+inherit eutils
+
+DESCRIPTION="replacement for GNU stow with extensions"
+HOMEPAGE="http://xstow.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses static"
+
+DEPEND="ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ econf --disable-dependency-tracking\
+ $(use_with ncurses curses)\
+ $(use_enable static)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" \
+ install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ # create new STOWDIR
+ dodir /var/lib/xstow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd ${FILESDIR}/99xstow || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 "
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}
+