summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJodok Batlogg <batlogg@gentoo.org>2004-07-13 23:48:58 +0000
committerJodok Batlogg <batlogg@gentoo.org>2004-07-13 23:48:58 +0000
commit1dfe39e011853b3f631064672f0bd2db87cd3274 (patch)
tree844b430351991396c83f44e87e65ed55901a2836 /app-admin/zope-config/zope-config-0.4.ebuild
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-1dfe39e011853b3f631064672f0bd2db87cd3274.tar.gz
gentoo-2-1dfe39e011853b3f631064672f0bd2db87cd3274.tar.bz2
gentoo-2-1dfe39e011853b3f631064672f0bd2db87cd3274.zip
version bump, lots of changes from #41508
Diffstat (limited to 'app-admin/zope-config/zope-config-0.4.ebuild')
-rw-r--r--app-admin/zope-config/zope-config-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/zope-config/zope-config-0.4.ebuild b/app-admin/zope-config/zope-config-0.4.ebuild
new file mode 100644
index 000000000000..fe2ee0f53f82
--- /dev/null
+++ b/app-admin/zope-config/zope-config-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/zope-config/zope-config-0.4.ebuild,v 1.1 2004/07/13 23:48:57 batlogg Exp $
+
+DESCRIPTION="A Gentoo Zope multi-Instance configure tool"
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-util/dialog-0.7
+ sys-apps/grep
+ sys-apps/sed
+ sys-apps/shadow
+ dev-lang/python
+ sys-apps/coreutils"
+
+PDEPEND=">=net-zope/zope-2.7.1"
+
+src_install() {
+ # the script
+ dosbin ${FILESDIR}/${PV}/zope-config
+ # config file
+ insinto /etc
+ doins ${FILESDIR}/${PV}/zope-config.conf
+ # ensure this directory exists
+ keepdir /var/log/zope
+}
+
+pkg_postinst() {
+ source ${FILESDIR}/${PV}/zope-config.conf
+ einfo "Please note that new instances now log into ${EVENTLOGDIR}"
+ einfo "Please see the configuration file /etc/zope-config.conf"
+}