summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-06-22 06:05:31 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-06-22 06:05:31 +0000
commit02e65971258d9ef718aceab957218177face60b9 (patch)
tree2fea24d9f67325d705e231717441d673cbd25112 /app-admin
parentnew version (diff)
downloadgentoo-2-02e65971258d9ef718aceab957218177face60b9.tar.gz
gentoo-2-02e65971258d9ef718aceab957218177face60b9.tar.bz2
gentoo-2-02e65971258d9ef718aceab957218177face60b9.zip
new ebuild - hddtemp: HDD temperature reporting utility
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/hddtemp/ChangeLog18
-rw-r--r--app-admin/hddtemp/files/digest-hddtemp-0.21
-rw-r--r--app-admin/hddtemp/files/hddtemp-0.2-db_location.patch15
-rw-r--r--app-admin/hddtemp/files/hddtemp.db175
-rw-r--r--app-admin/hddtemp/hddtemp-0.2.ebuild49
5 files changed, 258 insertions, 0 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
new file mode 100644
index 000000000000..d0116fc2b163
--- /dev/null
+++ b/app-admin/hddtemp/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-admin/hddtemp
+# Copyright 2002 Imran Rafique; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.1 2002/06/22 06:05:31 george Exp $
+
+*hddtemp-0.2 (10 Jun 2002)
+
+ 21 June 2002; George Shapovalov <george@gentoo.org> hddtemp-0.2.ebuild :
+
+ cleaned up ebuild (removed non-standard USE flag and recommended better solution
+ of an issue) and committed the package
+
+ ebuild submitted by Imran Rafique:
+
+ 10 Jun 2002; Imran Rafique <imran@rafique.org> ChangeLog :
+
+ Initial release.
+ I patched the source so that the support file (*.db) installs neatly under /usr/share/hddtemp/.
+ Enforced my own USE flag ('gkrellm'). If enabled, this flag will cause the hddtemp binary to be installed 'setuid'. This is required for use by the gkrellm-hddtemp plugin.
diff --git a/app-admin/hddtemp/files/digest-hddtemp-0.2 b/app-admin/hddtemp/files/digest-hddtemp-0.2
new file mode 100644
index 000000000000..bce5a79c6aa6
--- /dev/null
+++ b/app-admin/hddtemp/files/digest-hddtemp-0.2
@@ -0,0 +1 @@
+MD5 d703f6488850df6a6aeb21beee8a3895 hddtemp-0.2.tar.gz 11632
diff --git a/app-admin/hddtemp/files/hddtemp-0.2-db_location.patch b/app-admin/hddtemp/files/hddtemp-0.2-db_location.patch
new file mode 100644
index 000000000000..59fba313c68e
--- /dev/null
+++ b/app-admin/hddtemp/files/hddtemp-0.2-db_location.patch
@@ -0,0 +1,15 @@
+--- hddtemp.c Wed Jan 16 11:13:45 2002
++++ hddtemp.c.new Mon Jun 10 16:25:06 2002
+@@ -44,11 +44,11 @@
+ #define F_to_C(val) (int)(((double)(val)-32.0)/1.8)
+ #define C_to_F(val) (int)(((double)(val)*1.8)+32)
+
+ #define HDDTEMP_VERSION "0.2"
+ #define DEFAULT_ATTRIBUTE_ID 194
+-#define DEFAULT_DATABASE_PATH "/usr/share/hddtemp.db"
++#define DEFAULT_DATABASE_PATH "/usr/share/hddtemp/hddtemp.db"
+ #define MAX_LINE_LEN 1024
+
+ struct harddrive_entry *supported_drives = NULL;
+ struct harddrive_entry **last_entry = &supported_drives;
+ struct harddrive_entry *drive_entry;
diff --git a/app-admin/hddtemp/files/hddtemp.db b/app-admin/hddtemp/files/hddtemp.db
new file mode 100644
index 000000000000..fbc41818d0a9
--- /dev/null
+++ b/app-admin/hddtemp/files/hddtemp.db
@@ -0,0 +1,175 @@
+#
+# DATABASE VERSION 013 (06/06/2002)
+#
+# Insert a regular expression for support of the model or the serie of your hard drive.
+# If you don't know what to put in the second field, put the number
+# that appears most often for your brand :o)
+# A value of zero meens that we know that the drive doesn't have
+# a temperature sensor (you can set the unit to C or F).
+#
+# The following list was found at (http://www.almico.com/sfhardware.php)
+# If your drive is in the list send me a mail.
+#
+# Manufacturer Model Size Notes
+# FUJITSU FUJITSU MHN2300AT 29.3GB
+# FUJITSU FUJITSU MPF3102AH 10.0GB
+# FUJITSU FUJITSU MPG3204AH 20.0GB
+# FUJITSU FUJITSU MPG3204AH E 20.0GB
+# FUJITSU FUJITSU MPG3307AT 30.0GB
+# FUJITSU FUJITSU MPG3409AH 40.0GB
+# FUJITSU FUJITSU MPG3409AH E 40.0GB
+# FUJITSU FUJITSU MPG3409AH EF 40.0GB
+# HITACHI HITACHI_DK23CA-10 9.8GB
+# HITACHI HITACHI_DK23CA-15 14.7GB
+# HITACHI HITACHI_DK23CA-30 29.3GB
+# IBM IC25N015ATDA04-0 14.7GB
+# IBM IC25N030ATDA04-0 29.3GB
+# MAXTOR MAXTOR 4D080H4 80.0GB
+# MAXTOR MAXTOR 4K020H1 19.9GB
+# MAXTOR MAXTOR 6L020J1 20.1GB
+# MAXTOR MAXTOR 6L040J2 39.1GB
+# MAXTOR MAXTOR 6L040L2 39.1GB
+# MAXTOR MAXTOR 6L060J3 58.6GB
+# MAXTOR MAXTOR 6L060L3 58.6GB
+# MAXTOR MAXTOR 6L080J4 78.2GB
+# SAMSUNG SAMSUNG SV3012H 29.4GB
+# SEAGATE ST310210A 10.0GB
+# SEAGATE ST310211A 9.8GB
+# SEAGATE ST310215A 10.0GB
+# SEAGATE ST315320A 14.9GB
+# SEAGATE ST320011A 19.6GB
+# SEAGATE ST320410A 19.6GB
+# SEAGATE ST320413A 19.6GB
+# SEAGATE ST320420A 19.9GB
+# SEAGATE ST330610A 29.3GB
+# SEAGATE ST330620A 29.3GB
+# SEAGATE ST330621A 29.3GB
+# SEAGATE ST330630A 29.9GB
+# SEAGATE ST340016A 39.1GB
+# SEAGATE ST340810ACE 39.1GB
+# SEAGATE ST340823A 39.1GB
+# SEAGATE ST380020ACE 78.2GB
+# SEAGATE ST380020A 78.2GB
+# SEAGATE ST380021A 78.2GB
+# WESTERN DIGITAL WDC AC210200D 10.0GB
+# WESTERN DIGITAL WDC AC29100D 8.9GB
+# WESTERN DIGITAL WDC AC418000D 17.6GB
+# WESTERN DIGITAL WDC AC420400D 19.9GB
+# WESTERN DIGITAL WDC WD102AA 10.0GB
+#
+#################################################
+
+
+########################################
+############# Fujitsu drives
+########################################
+
+"FUJITSU MHN2200AT" 194 C "Fujitsu MHN2200AT"
+"FUJITSU MPF3204AH" 194 C "Fujitsu MPF3204AH"
+"FUJITSU MPG3204AT.*" 194 C "Fujitsu MPG3204AT"
+"FUJITSU MPG3307AT" 194 C "Fujitsu MPG3307AT"
+"FUJITSU MPG3409AT.*" 194 C "Fujitsu MPG3409AT E"
+
+
+
+########################################
+############# Hitachi drives
+########################################
+
+"HITACHI_DK228A-65" 0 C "Hitachi DK228A-65"
+"HITACHI_DK23DA-40" 194 C "Hitachi DK23DA-40"
+"HITACHI_DK23CA-20" 194 C "Hitachi DK23CA-20"
+"HITACHI_DK23CA-75" 194 C "Hitachi DK23CA-75"
+
+
+
+########################################
+############# IBM drives
+########################################
+
+# DJSA serie is using F0h command to report temperature and also have
+# SMART capabilties but it was reported not to work.
+# "DJSA-2(30|32|10|20|05)" 0 C "IBM Travelstar 20GN, 32GH, 30GT series"
+
+"IBM-DJNA-35.*" 231 C "IBM Deskstar 25 GP serie"
+"IBM-DJNA-37.*" 231 C "IBM Deskstar 22 GXP serie"
+"IBM-DHEA-(34330|36480)" 0 C "IBM Deskstar 5 serie"
+"IBM-DHEA-(34331|36481|38451)" 0 C "IBM Deskstar 8 serie"
+"IBM-DPTA-37.*" 231 C "IBM Deskstar 34GXP serie"
+"IBM-DPTA-35.*" 231 C "IBM Deskstar 37GP serie"
+"IBM-DTLA-30[57]0[123467][05]" 194 C "IBM Deskstar 40GV & 75GXP series"
+"IC25N020ATDA04-0" 194 C "IBM Travelstar 30GN/20GB IDE"
+"IC25N030ATCS04-0" 194 C "IBM Travelstar 40GN"
+"IC35L0[12346]0AVER07" 194 C "IBM Deskstar 60GXP serie"
+"IC35L[01][02468]0AVVA07*" 194 C "IBM Deskstar 120GXP serie"
+
+
+########################################
+############# Maxtor drives
+########################################
+
+"MAXTOR 4K0[468]0H[234]" 194 C "Maxtor DiamondMax D540X serie"
+"MAXTOR 6L0[2468]0[LJ][1234]" 194 C "Maxtor DiamondMax Plus D740X family"
+
+
+
+########################################
+############# Quantum drives
+########################################
+
+"QUANTUM FIREBALLP AS40.0" 0 C "Quantum Fireball AS40"
+
+
+
+########################################
+############# Samsung drives
+########################################
+
+"SAMSUNG SP(2001|4002|6003|8004)H" 194 C "Samsung SpinPoint P40 serie"
+"SAMSUNG SV0432A" 0 C "Samsung SV0432A"
+"SAMSUNG SV(2001|4002|6003|8004)H" 194 C "Samsung SpinPoint V40 serie"
+
+
+
+########################################
+############# Seagate drives
+########################################
+
+"Seagate Technology 1275MB - ST31276A" 0 C "Seagate ST31276A"
+"ST3412A" 0 C "Seagate ST3412A"
+"ST310210A" 0 C "Seagate ST310210A"
+"ST310211A" 194 C "Seagate ST310211A"
+"ST310220A" 0 C "Seagate ST310220A"
+"ST315320A" 194 C "Seagate ST315320A"
+"ST320011A" 194 C "Seagate ST320011A"
+"ST320410A" 194 C "Seagate ST320410A"
+"ST320413A" 194 C "Seagate ST320413A"
+"ST320414A" 194 C "Seagate ST320414A"
+"ST320420A" 194 C "Seagate Barracuda II ST320420A"
+"ST330621A" 194 C "Seagate ST330621A"
+"ST330630A" 194 C "Seagate Barracuda ST330630A"
+"ST340016A" 194 C "Seagate ST340016A"
+"ST340810A" 194 C "Seagate ST340810A"
+"ST340824A" 194 C "Seagate ST340824A"
+"ST360020A" 194 C "Seagate ST360020A"
+"ST360021A" 194 C "Seagate ST360021A"
+"ST380021A" 194 C "Seagate ST380021A"
+
+########################################
+############# TOSHIBA Laptop
+########################################
+
+"MK4313MAT" 220 C "TOSHIBA MK4313MAT"
+
+
+
+########################################
+############# Western Digital drives
+########################################
+
+# WDC AC310100B and WDC AC2850F are reported not working
+# no more informations were given
+"WDC WD100EB-00BHF0" 0 C "Western Digital 100EB-00BHF0"
+"WDC WD600BB-32BSA0" 0 C "Western Digital 600BB-32BSA0"
+"WDC AC420400D" 231 C "Western Digital Caviar AC420400D"
+
diff --git a/app-admin/hddtemp/hddtemp-0.2.ebuild b/app-admin/hddtemp/hddtemp-0.2.ebuild
new file mode 100644
index 000000000000..faa2486a867c
--- /dev/null
+++ b/app-admin/hddtemp/hddtemp-0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.2.ebuild,v 1.1 2002/06/22 06:05:31 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A simple utility, to read the temperature of SMART IDE hard drives."
+
+SRC_URI="http://coredump.free.fr/linux/${P}.tar.gz"
+HOMEPAGE="http://coredump.free.fr/linux/harddrive.html"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # patch hddtemp.c
+ patch -p0 < ${FILESDIR}/hddtemp-0.2-db_location.patch
+
+ # patch Makefile
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=${CFLAGS} -DARCH_I386:" \
+ -e "s:^CC.*:CC=gcc:" \
+ Makefile.orig > Makefile
+
+ # copy over hddtemp database file
+ cp ${FILESDIR}/hddtemp.db ./
+}
+
+src_compile() {
+
+ make || die
+
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe hddtemp
+ dodir /usr/share/hddtemp
+ insinto /usr/share/hddtemp
+ doins hddtemp.db
+
+ #docs
+ dodoc README COPYING
+
+}