summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-04-02 22:50:49 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-04-02 22:50:49 +0000
commit080e5ba79778cddff9c9600278b015e6382fe888 (patch)
treef0aa0aa254ee02d47daa00392442d9a8578098f0 /app-admin
parentversion bump (diff)
downloadgentoo-2-080e5ba79778cddff9c9600278b015e6382fe888.tar.gz
gentoo-2-080e5ba79778cddff9c9600278b015e6382fe888.tar.bz2
gentoo-2-080e5ba79778cddff9c9600278b015e6382fe888.zip
Removal of left behind license file, listed those licenses in the LICENSE variable. Clarified die calls.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ec2-ami-tools/ChangeLog7
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild10
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild51
3 files changed, 13 insertions, 55 deletions
diff --git a/app-admin/ec2-ami-tools/ChangeLog b/app-admin/ec2-ami-tools/ChangeLog
index 4dfdd907b423..64eca4069ca6 100644
--- a/app-admin/ec2-ami-tools/ChangeLog
+++ b/app-admin/ec2-ami-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/ec2-ami-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ChangeLog,v 1.13 2013/04/02 22:37:43 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ChangeLog,v 1.14 2013/04/02 22:50:49 tomwij Exp $
+
+ 02 Apr 2013; Tom Wijsman <TomWij@gentoo.org> -ec2-ami-tools-1.4.0.5.ebuild,
+ ec2-ami-tools-1.4.0.5-r1.ebuild:
+ Removal of left behind license file, listed those licenses in the LICENSE
+ variable. Clarified die calls.
*ec2-ami-tools-1.4.0.5-r1 (02 Apr 2013)
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild
index 202d9caf601c..8b58d66d55d0 100644
--- a/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild,v 1.1 2013/04/02 22:37:43 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5-r1.ebuild,v 1.2 2013/04/02 22:50:49 tomwij Exp $
EAPI="5"
@@ -10,7 +10,8 @@ DESCRIPTION="These command-line tools serve as the client interface to the Amazo
HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
-LICENSE="Amazon"
+LICENSE="Amazon
+ || ( Ruby GPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -26,7 +27,10 @@ src_prepare() {
# be what upstream has been using; since Gentoo supports alternative
# implementations as well it is not guaranteed that ruby is ruby18.
# There are forks which patch this, but Amazon hasn't patched this yet.
- sed -i -e '$s:^ruby:exec ruby18:' bin/* || die
+ sed -i -e '$s:^ruby:exec ruby18:' bin/* || die 'Sed failed.'
+
+ # Remove a left behind license file.
+ rm lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
}
src_install() {
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild
deleted file mode 100644
index 722c2ff42c6f..000000000000
--- a/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild,v 1.1 2013/03/13 21:01:48 tomwij Exp $
-
-EAPI="5"
-
-inherit versionator
-
-DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
-HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
-SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
-
-LICENSE="Amazon"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="app-arch/unzip"
-RDEPEND="dev-lang/ruby:1.8[ssl]
- net-misc/rsync
- net-misc/curl"
-
-S="${WORKDIR}/${P}"
-
-src_prepare() {
- find . -name '*.cmd' -delete || die
-
- # simplify the scripts to always run ruby18, since that seems to
- # be what upstream has been using, and we support alternative
- # implementations as well.
- sed -i -e '$s:^ruby:exec ruby18:' bin/* || die
-}
-
-src_install() {
- insinto /opt/${PN}
- doins -r lib bin etc
-
- chmod 0755 "${D}/opt/${PN}/bin/"*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-EC2_AMITOOL_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
- doenvd "${T}"/99${PN}
-}
-
-pkg_postinst() {
- ewarn "Remember to run: env-update && source /etc/profile if you plan"
- ewarn "to use these tools in a shell before logging out (or restarting"
- ewarn "your login manager)"
-}