summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2015-08-05 14:50:47 +0000
committerJosé María Alonso <nimiux@gentoo.org>2015-08-05 14:50:47 +0000
commit1562bab50dfd57238a320115009432968b27f85d (patch)
tree0dc1a37288b76759781153462a7162ef027bdd3f /app-admin
parentia64 stable wrt bug #535458 (diff)
downloadgentoo-2-1562bab50dfd57238a320115009432968b27f85d.tar.gz
gentoo-2-1562bab50dfd57238a320115009432968b27f85d.tar.bz2
gentoo-2-1562bab50dfd57238a320115009432968b27f85d.zip
Drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key F253DB15)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/tripwire/ChangeLog7
-rw-r--r--app-admin/tripwire/files/tripwire.cron8
-rw-r--r--app-admin/tripwire/files/twinstall.sh316
-rw-r--r--app-admin/tripwire/tripwire-2.4.2.2-r1.ebuild82
-rw-r--r--app-admin/tripwire/tripwire-2.4.2.2-r2.ebuild80
-rw-r--r--app-admin/tripwire/tripwire-2.4.2.2.ebuild81
6 files changed, 6 insertions, 568 deletions
diff --git a/app-admin/tripwire/ChangeLog b/app-admin/tripwire/ChangeLog
index e30850681a7c..01dde547db59 100644
--- a/app-admin/tripwire/ChangeLog
+++ b/app-admin/tripwire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/tripwire
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/ChangeLog,v 1.61 2015/06/09 08:46:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/ChangeLog,v 1.62 2015/08/05 14:50:47 nimiux Exp $
+
+ 05 Aug 2015; Chema Alonso <nimiux@gentoo.org> -tripwire-2.4.2.2.ebuild,
+ -tripwire-2.4.2.2-r1.ebuild, -tripwire-2.4.2.2-r2.ebuild,
+ -files/tripwire.cron, -files/twinstall.sh:
+ Drop old
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-admin/tripwire/files/tripwire.cron b/app-admin/tripwire/files/tripwire.cron
deleted file mode 100644
index 2035508d751d..000000000000
--- a/app-admin/tripwire/files/tripwire.cron
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-HOST_NAME=`uname -n`
-if [ ! -e /var/lib/tripwire/${HOST_NAME}.twd ] ; then
- echo "**** Error: Tripwire database for ${HOST_NAME} not found. ****"
- echo "**** Run "/etc/tripwire/twinstall.sh" and/or "tripwire --init". ****"
-else
- test -f /etc/tripwire/tw.cfg && /usr/sbin/tripwire --check
-fi
diff --git a/app-admin/tripwire/files/twinstall.sh b/app-admin/tripwire/files/twinstall.sh
deleted file mode 100644
index 7e114fb3d1e3..000000000000
--- a/app-admin/tripwire/files/twinstall.sh
+++ /dev/null
@@ -1,316 +0,0 @@
-#!/bin/sh
-
-########################################################################
-########################################################################
-##
-## Tripwire(R) 2.3 for LINUX(R) Post-RPM installation script
-##
-## Copyleft information contained in footer
-##
-########################################################################
-########################################################################
-
-##=======================================================
-## Setup
-##=======================================================
-
-# We can assume all the correct tools are in place because the
-# RPM installed, didn't it?
-
-##-------------------------------------------------------
-## Set HOST_NAME variable
-##-------------------------------------------------------
-HOST_NAME='localhost'
-if uname -n > /dev/null 2> /dev/null ; then
- HOST_NAME=`uname -n`
-fi
-
-##-------------------------------------------------------
-## Program variables - edited by RPM during initial install
-##-------------------------------------------------------
-
-# Site Passphrase variable
-TW_SITE_PASS=""
-
-# Complete path to site key
-SITE_KEY="/etc/tripwire/site.key"
-
-# Local Passphrase variable
-TW_LOCAL_PASS=""
-
-# Complete path to local key
-LOCAL_KEY="/etc/tripwire/${HOST_NAME}-local.key"
-
-# If clobber==true, overwrite files; if false, do not overwrite files.
-CLOBBER="false"
-
-# If prompt==true, ask for confirmation before continuing with install.
-PROMPT="true"
-
-# Name of twadmin executeable
-TWADMIN="twadmin"
-
-# Path to twadmin executeable
-TWADMPATH=/usr/sbin
-
-# Path to configuration directory
-CONF_PATH="/etc/tripwire"
-
-# Name of clear text policy file
-TXT_POL=$CONF_PATH/twpol.txt
-
-# Name of clear text configuration file
-TXT_CFG=$CONF_PATH/twcfg.txt
-
-# Name of encrypted configuration file
-CONFIG_FILE=$CONF_PATH/tw.cfg
-
-# Path of the final Tripwire policy file (signed)
-SIGNED_POL=`grep POLFILE $TXT_CFG | sed -e 's/^.*=\(.*\)/\1/'`
-
-
-##=======================================================
-## Create Key Files
-##=======================================================
-
-##-------------------------------------------------------
-## If user has to enter a passphrase, give some
-## advice about what is appropriate.
-##-------------------------------------------------------
-
-if [ -z "$TW_SITE_PASS" ] || [ -z "$TW_LOCAL_PASS" ]; then
-cat << END_OF_TEXT
-
-----------------------------------------------
-The Tripwire site and local passphrases are used to
-sign a variety of files, such as the configuration,
-policy, and database files.
-
-Passphrases should be at least 8 characters in length
-and contain both letters and numbers.
-
-See the Tripwire manual for more information.
-END_OF_TEXT
-fi
-
-##=======================================================
-## Generate keys.
-##=======================================================
-
-echo
-echo "----------------------------------------------"
-echo "Creating key files..."
-
-##-------------------------------------------------------
-## Site key file.
-##-------------------------------------------------------
-
-# If clobber is true, and prompting is off (unattended operation)
-# and the key file already exists, remove it. Otherwise twadmin
-# will prompt with an "are you sure?" message.
-
-if [ "$CLOBBER" = "true" ] && [ "$PROMPT" = "false" ] && [ -f "$SITE_KEY" ] ; then
- rm -f "$SITE_KEY"
-fi
-
-if [ -f "$SITE_KEY" ] && [ "$CLOBBER" = "false" ] ; then
- echo "The site key file \"$SITE_KEY\""
- echo 'exists and will not be overwritten.'
-else
- cmdargs="--generate-keys --site-keyfile \"$SITE_KEY\""
- if [ -n "$TW_SITE_PASS" ] ; then
- cmdargs="$cmdargs --site-passphrase \"$TW_SITE_PASS\""
- fi
- eval "\"$TWADMPATH/$TWADMIN\" $cmdargs"
- if [ $? -ne 0 ] ; then
- echo "Error: site key generation failed"
- exit 1
- else chmod 640 "$SITE_KEY"
- fi
-fi
-
-##-------------------------------------------------------
-## Local key file.
-##-------------------------------------------------------
-
-# If clobber is true, and prompting is off (unattended operation)
-# and the key file already exists, remove it. Otherwise twadmin
-# will prompt with an "are you sure?" message.
-
-if [ "$CLOBBER" = "true" ] && [ "$PROMPT" = "false" ] && [ -f "$LOCAL_KEY" ] ; then
- rm -f "$LOCAL_KEY"
-fi
-
-if [ -f "$LOCAL_KEY" ] && [ "$CLOBBER" = "false" ] ; then
- echo "The site key file \"$LOCAL_KEY\""
- echo 'exists and will not be overwritten.'
-else
- cmdargs="--generate-keys --local-keyfile \"$LOCAL_KEY\""
- if [ -n "$TW_LOCAL_PASS" ] ; then
- cmdargs="$cmdargs --local-passphrase \"$TW_LOCAL_PASS\""
- fi
- eval "\"$TWADMPATH/$TWADMIN\" $cmdargs"
- if [ $? -ne 0 ] ; then
- echo "Error: local key generation failed"
- exit 1
- else chmod 640 "$LOCAL_KEY"
- fi
-fi
-
-##=======================================================
-## Sign the Configuration File
-##=======================================================
-
-echo
-echo "----------------------------------------------"
-echo "Signing configuration file..."
-
-##-------------------------------------------------------
-## If noclobber, then backup any existing config file.
-##-------------------------------------------------------
-
-if [ "$CLOBBER" = "false" ] && [ -s "$CONFIG_FILE" ] ; then
- backup="${CONFIG_FILE}.$$.bak"
- echo "Backing up $CONFIG_FILE"
- echo " to $backup"
- `mv "$CONFIG_FILE" "$backup"`
- if [ $? -ne 0 ] ; then
- echo "Error: backup of configuration file failed."
- exit 1
- fi
-fi
-
-##-------------------------------------------------------
-## Build command line.
-##-------------------------------------------------------
-
-cmdargs="--create-cfgfile"
-cmdargs="$cmdargs --cfgfile \"$CONFIG_FILE\""
-cmdargs="$cmdargs --site-keyfile \"$SITE_KEY\""
-if [ -n "$TW_SITE_PASS" ] ; then
- cmdargs="$cmdargs --site-passphrase \"$TW_SITE_PASS\""
-fi
-
-##-------------------------------------------------------
-## Sign the file.
-##-------------------------------------------------------
-
-eval "\"$TWADMPATH/$TWADMIN\" $cmdargs \"$TXT_CFG\""
-if [ $? -ne 0 ] ; then
- echo "Error: signing of configuration file failed."
- exit 1
-fi
-
-# Set the rights properly
-chmod 640 "$CONFIG_FILE"
-
-##-------------------------------------------------------
-## We keep the cleartext version around.
-##-------------------------------------------------------
-
-cat << END_OF_TEXT
-
-A clear-text version of the Tripwire configuration file
-$TXT_CFG
-has been preserved for your inspection. It is recommended
-that you delete this file manually after you have examined it.
-
-END_OF_TEXT
-
-##=======================================================
-## Sign tripwire policy file.
-##=======================================================
-
-echo
-echo "----------------------------------------------"
-echo "Signing policy file..."
-
-##-------------------------------------------------------
-## If noclobber, then backup any existing policy file.
-##-------------------------------------------------------
-
-if [ "$CLOBBER" = "false" ] && [ -s "$POLICY_FILE" ] ; then
- backup="${POLICY_FILE}.$$.bak"
- echo "Backing up $POLICY_FILE"
- echo " to $backup"
- mv "$POLICY_FILE" "$backup"
- if [ $? -ne 0 ] ; then
- echo "Error: backup of policy file failed."
- exit 1
- fi
-fi
-
-##-------------------------------------------------------
-## Build command line.
-##-------------------------------------------------------
-
-cmdargs="--create-polfile"
-cmdargs="$cmdargs --cfgfile \"$CONFIG_FILE\""
-cmdargs="$cmdargs --site-keyfile \"$SITE_KEY\""
-if [ -n "$TW_SITE_PASS" ] ; then
- cmdargs="$cmdargs --site-passphrase \"$TW_SITE_PASS\""
-fi
-
-##-------------------------------------------------------
-## Sign the file.
-##-------------------------------------------------------
-
-eval "\"$TWADMPATH/$TWADMIN\" $cmdargs \"$TXT_POL\""
-if [ $? -ne 0 ] ; then
- echo "Error: signing of policy file failed."
- exit 1
-fi
-
-# Set the proper rights on the newly signed policy file.
-chmod 0640 "$SIGNED_POL"
-
-##-------------------------------------------------------
-## We keep the cleartext version around.
-##-------------------------------------------------------
-
-cat << END_OF_TEXT
-
-A clear-text version of the Tripwire policy file
-$TXT_POL
-has been preserved for your inspection. This implements
-a minimal policy, intended only to test essential
-Tripwire functionality. You should edit the policy file
-to describe your system, and then use twadmin to generate
-a new signed copy of the Tripwire policy.
-
-END_OF_TEXT
-
-########################################################################
-########################################################################
-#
-# TRIPWIRE GPL NOTICES
-#
-# The developer of the original code and/or files is Tripwire, Inc.
-# Portions created by Tripwire, Inc. are copyright 2000 Tripwire, Inc.
-# Tripwire is a registered trademark of Tripwire, Inc. All rights reserved.
-#
-# This program is free software. The contents of this file are subject to
-# the terms of the GNU General Public License as published by the Free
-# Software Foundation; either version 2 of the License, or (at your option)
-# any later version. You may redistribute it and/or modify it only in
-# compliance with the GNU General Public License.
-#
-# This program is distributed in the hope that it will be useful. However,
-# this program is distributed "AS-IS" WITHOUT ANY WARRANTY; INCLUDING THE
-# IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
-# Please see the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-#
-# Nothing in the GNU General Public License or any other license to use the
-# code or files shall permit you to use Tripwire's trademarks,
-# service marks, or other intellectual property without Tripwire's
-# prior written consent.
-#
-# If you have any questions, please contact Tripwire, Inc. at either
-# info@tripwire.org or www.tripwire.org.
-#
-########################################################################
-########################################################################
diff --git a/app-admin/tripwire/tripwire-2.4.2.2-r1.ebuild b/app-admin/tripwire/tripwire-2.4.2.2-r1.ebuild
deleted file mode 100644
index 0e2246d3c5e0..000000000000
--- a/app-admin/tripwire/tripwire-2.4.2.2-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/tripwire-2.4.2.2-r1.ebuild,v 1.6 2013/09/03 15:01:35 nimiux Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Open Source File Integrity Checker and IDS"
-HOMEPAGE="http://www.tripwire.org/"
-SRC_URI="mirror://sourceforge/tripwire/tripwire-${PV}-src.tar.bz2
- mirror://gentoo/twpol.txt.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="ssl static"
-
-DEPEND="sys-devel/automake
- sys-devel/autoconf
- ssl? ( dev-libs/openssl )"
-RDEPEND="virtual/cron
- virtual/mta
- ssl? ( dev-libs/openssl )"
-
-S="${WORKDIR}"/tripwire-"${PV}"-src
-
-src_prepare() {
- epatch "${FILESDIR}"/"${P}"-fix-configure.patch
- epatch "${FILESDIR}"/"${P}"-buildnum.patch
- epatch "${FILESDIR}"/"${P}"-gcc-4.7.patch
-
- eautoreconf
-}
-
-src_configure() {
- # tripwire can be sensitive to compiler optimisation.
- # see #32613, #45823, and others.
- # -taviso@gentoo.org
- strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- chmod +x configure || die
- econf $(use_enable ssl openssl) $(use_enable static)
-}
-
-src_install() {
- dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
- doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
- dodir /etc/tripwire /var/lib/tripwire{,/report}
- keepdir /var/lib/tripwire{,/report}
-
- exeinto /etc/cron.daily
- doexe "${FILESDIR}"/tripwire.cron
-
- dodoc ChangeLog policy/policyguide.txt TRADEMARK \
- "${FILESDIR}"/tripwire.txt
-
- insinto /etc/tripwire
- doins "${WORKDIR}"/twpol.txt "${FILESDIR}"/twcfg.txt
-
- exeinto /etc/tripwire
- doexe "${FILESDIR}"/twinstall.sh
-
- fperms 755 /etc/tripwire/twinstall.sh /etc/cron.daily/tripwire.cron
-}
-
-pkg_postinst() {
- elog "After installing this package, you should check the policy"
- elog "file (twpol.txt) shipped with the package to see if it"
- elog "suits your needs, and modify it accordingly."
- elog
- elog "Check bug #34662 to find a bash script which generates a"
- elog "policy file from the Gentoo packages installed in your system."
- elog
- elog "Once the policy file is ready, you can run the"
- elog "\"/etc/tripwire/twinstall.sh\" script to generate the "
- elog "cryptographic keys, and \"tripwire --init\" to initialize"
- elog "the Tripwire's database."
- elog
- elog "A quickstart guide is included with the documentation."
- elog
-}
diff --git a/app-admin/tripwire/tripwire-2.4.2.2-r2.ebuild b/app-admin/tripwire/tripwire-2.4.2.2-r2.ebuild
deleted file mode 100644
index b8aa6b7e2376..000000000000
--- a/app-admin/tripwire/tripwire-2.4.2.2-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/tripwire-2.4.2.2-r2.ebuild,v 1.5 2014/08/03 18:34:45 ago Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Open Source File Integrity Checker and IDS"
-HOMEPAGE="http://www.tripwire.org/"
-SRC_URI="mirror://sourceforge/tripwire/tripwire-${PV}-src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="ssl static +tools"
-
-DEPEND="sys-devel/automake
- sys-devel/autoconf
- ssl? ( dev-libs/openssl )"
-RDEPEND="virtual/cron
- virtual/mta
- ssl? ( dev-libs/openssl )"
-PDEPEND="tools? ( app-admin/mktwpol )"
-
-S="${WORKDIR}"/tripwire-"${PV}"-src
-
-src_prepare() {
- epatch "${FILESDIR}"/"${P}"-fix-configure.patch
- epatch "${FILESDIR}"/"${P}"-buildnum.patch
- epatch "${FILESDIR}"/"${P}"-gcc-4.7.patch
- epatch "${FILESDIR}"/"${PN}"-twpol-GENERIC.patch
-
- eautoreconf
-}
-
-src_configure() {
- # tripwire can be sensitive to compiler optimisation.
- # see #32613, #45823, and others.
- # -taviso@gentoo.org
- strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- econf $(use_enable ssl openssl) $(use_enable static)
-}
-
-src_install() {
- dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
- doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
- dodir /etc/tripwire /var/lib/tripwire{,/report}
- keepdir /var/lib/tripwire{,/report}
-
- exeinto /etc/cron.daily
- doexe "${FILESDIR}"/tripwire
-
- dodoc ChangeLog policy/policyguide.txt TRADEMARK \
- "${FILESDIR}"/tripwire.txt
-
- insinto /etc/tripwire
- doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt
-
- fperms 750 /etc/cron.daily/tripwire
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "Tripwire needs to be configured before its first run. You can"
- elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
- elog "the package to suit your needs. A quickstart guide is provided"
- elog "in tripwire.txt file to help you with this."
- elog "To configure tripwire automatically, you can use the twsetup.sh"
- elog "script provided by the app-admin/mktwpol package. This package is"
- elog "installed for you by the \"tools\" USE flag (which is enabled by"
- elog "default."
-else
- elog "Maintenance of tripwire policy files as packages are added"
- elog "and deleted from your system can be automated by the mktwpol.sh"
- elog "script provided by the app-admin/mktwpol package. This package"
- elog "is installed for you if you append \"tools\" to your USE flags"
- fi
-}
diff --git a/app-admin/tripwire/tripwire-2.4.2.2.ebuild b/app-admin/tripwire/tripwire-2.4.2.2.ebuild
deleted file mode 100644
index de1340489e42..000000000000
--- a/app-admin/tripwire/tripwire-2.4.2.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tripwire/tripwire-2.4.2.2.ebuild,v 1.7 2013/09/03 15:01:36 nimiux Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Open Source File Integrity Checker and IDS"
-HOMEPAGE="http://www.tripwire.org/"
-SRC_URI="mirror://sourceforge/tripwire/tripwire-${PV}-src.tar.bz2
- mirror://gentoo/twpol.txt.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="ssl static"
-
-DEPEND="sys-devel/automake
- sys-devel/autoconf
- ssl? ( dev-libs/openssl )"
-RDEPEND="virtual/cron
- virtual/mta
- ssl? ( dev-libs/openssl )"
-
-S="${WORKDIR}"/tripwire-"${PV}"-src
-
-src_prepare() {
- epatch "${FILESDIR}"/"${P}"-fix-configure.patch
- epatch "${FILESDIR}"/"${P}"-buildnum.patch
-
- eautoreconf
-}
-
-src_configure() {
- # tripwire can be sensitive to compiler optimisation.
- # see #32613, #45823, and others.
- # -taviso@gentoo.org
- strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- chmod +x configure || die
- econf $(use_enable ssl openssl) $(use_enable static)
-}
-
-src_install() {
- dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
- doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
- dodir /etc/tripwire /var/lib/tripwire{,/report}
- keepdir /var/lib/tripwire{,/report}
-
- exeinto /etc/cron.daily
- doexe "${FILESDIR}"/tripwire.cron
-
- dodoc ChangeLog policy/policyguide.txt TRADEMARK \
- "${FILESDIR}"/tripwire.txt
-
- insinto /etc/tripwire
- doins "${WORKDIR}"/twpol.txt "${FILESDIR}"/twcfg.txt
-
- exeinto /etc/tripwire
- doexe "${FILESDIR}"/twinstall.sh
-
- fperms 755 /etc/tripwire/twinstall.sh /etc/cron.daily/tripwire.cron
-}
-
-pkg_postinst() {
- elog "After installing this package, you should check the policy"
- elog "file (twpol.txt) shipped with the package to see if it"
- elog "suits your needs, and modify it accordingly."
- elog
- elog "Check bug #34662 to find a bash script which generates a"
- elog "policy file from the Gentoo packages installed in your system."
- elog
- elog "Once the policy file is ready, you can run the"
- elog "\"/etc/tripwire/twinstall.sh\" script to generate the "
- elog "cryptographic keys, and \"tripwire --init\" to initialize"
- elog "the Tripwire's database."
- elog
- elog "A quickstart guide is included with the documentation."
- elog
-}