summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-15 10:04:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-15 10:04:11 +0000
commit1d395c95eaf685bab4c3c221c2e6e8942203f459 (patch)
tree0223330f3a9c2f0c6abe9ce41c8f2bdb01986425 /app-admin
parentFix mulitilib issues per bug #284929. (diff)
downloadgentoo-2-1d395c95eaf685bab4c3c221c2e6e8942203f459.tar.gz
gentoo-2-1d395c95eaf685bab4c3c221c2e6e8942203f459.tar.bz2
gentoo-2-1d395c95eaf685bab4c3c221c2e6e8942203f459.zip
Version bump. Fix bugs #281452 and #280212.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-opengl/ChangeLog8
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.0.8.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index d9aeda9c7532..6aca98f4137b 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.47 2009/07/28 15:16:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.48 2009/09/15 10:04:11 scarabeus Exp $
+
+*eselect-opengl-1.0.8 (15 Sep 2009)
+
+ 15 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +eselect-opengl-1.0.8.ebuild:
+ Version bump. Fix bugs #281452 and #280212.
28 Jul 2009; Jeroen Roovers <jer@gentoo.org> metadata.xml:
x11-drivers -> x11.
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.0.8.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.0.8.ebuild
new file mode 100644
index 000000000000..1068ad0a9bde
--- /dev/null
+++ b/app-admin/eselect-opengl/eselect-opengl-1.0.8.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.8.ebuild,v 1.1 2009/09/15 10:04:11 scarabeus Exp $
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenGL interface being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.opengl.org/registry/api/glext.h
+# http://www.opengl.org/registry/api/glxext.h
+
+GLEXT="55"
+GLXEXT="24"
+
+#MIRROR="mirror://gentoo/"
+MIRROR="http://dev.gentooexperimental.org/~scarabeus/"
+SRC_URI="${MIRROR}/glext.h.${GLEXT}.bz2
+ ${MIRROR}/glxext.h.${GLXEXT}.bz2
+ ${MIRROR}/opengl.eselect-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# -* to give time for headers to hit mirrors...
+#KEYWORDS="-*"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+EMULTILIB_PKG="true"
+
+DEPEND="app-arch/bzip2"
+RDEPEND=">=app-admin/eselect-1.2"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+
+ mv opengl.eselect-${PV} opengl.eselect
+}
+
+pkg_preinst() {
+ # It needs to be before 04multilib
+ [[ -f "${ROOT}/etc/env.d/09opengl" ]] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
+
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ if [[ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]]
+ then
+ einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
+ rm -f "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so"
+ fi
+ if [[ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]]
+ then
+ einfo "Removing libMesaGL.so from /usr/$(get_libdir). See bug #47598."
+ rm -f "${ROOT}/usr/$(get_libdir)/libMesaGL.so"
+ fi
+
+ for f in "${ROOT}/usr/$(get_libdir)"/libGL.so.* "${ROOT}/usr/$(get_libdir)"/libGLcore.so.* "${ROOT}/usr/$(get_libdir)"/libnvidia-tls* "${ROOT}/usr/$(get_libdir)"/tls/libnvidia-tls* ; do
+ [[ -e ${f} ]] && rm -f "${f}"
+ done
+ done
+ ABI="${OABI}"
+ unset OABI
+}
+
+pkg_postinst() {
+ local impl="$(eselect opengl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opengl set "${impl}"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins opengl.eselect
+
+ # Install default glext.h
+ insinto "/usr/$(get_libdir)/opengl/global/include"
+ cd "${WORKDIR}"
+ newins glext.h.${GLEXT} glext.h || die
+ newins glxext.h.${GLXEXT} glxext.h || die
+}