summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-06-26 15:41:46 +0000
committerChuck Short <zul@gentoo.org>2004-06-26 15:41:46 +0000
commit2c62b28f09224e886081ccac1309e7ed2ef42ccb (patch)
treea1584d48a75aab761695bb4486b9f1ce0ab285b8 /app-admin
parentfix HOMEPAGE (#52381) (Manifest recommit) (diff)
downloadgentoo-2-2c62b28f09224e886081ccac1309e7ed2ef42ccb.tar.gz
gentoo-2-2c62b28f09224e886081ccac1309e7ed2ef42ccb.tar.bz2
gentoo-2-2c62b28f09224e886081ccac1309e7ed2ef42ccb.zip
Version bump.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/bacula/ChangeLog7
-rw-r--r--app-admin/bacula/Manifest4
-rw-r--r--app-admin/bacula/bacula-1.34.5.ebuild164
-rw-r--r--app-admin/bacula/files/digest-bacula-1.34.51
4 files changed, 174 insertions, 2 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
index 0efb76842a04..5b9119399292 100644
--- a/app-admin/bacula/ChangeLog
+++ b/app-admin/bacula/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/bacula
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.32 2004/06/26 15:36:41 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.33 2004/06/26 15:41:46 zul Exp $
+
+*bacula-1.34.5 (26 Jun 2004)
+
+ 26 Jun 2004; Chuck Short <zul@gentoo.org> bacula-1.34.5.ebuild:
+ Version bump, closes #54766.
26 Jun 2004; Chuck Short <zul@gentoo.org> bacula-1.29.ebuild,
bacula-1.31.ebuild:
diff --git a/app-admin/bacula/Manifest b/app-admin/bacula/Manifest
index 05137b6515d3..47bf229bf880 100644
--- a/app-admin/bacula/Manifest
+++ b/app-admin/bacula/Manifest
@@ -1,7 +1,8 @@
MD5 ef2b369979c794a2074129de4bef4440 bacula-1.34.1.ebuild 3643
+MD5 18dfafe3682effd730d78725cddc8b12 bacula-1.34.5.ebuild 4197
MD5 fd0bf5b5bd19bee5d5c5ce07aa71ab63 bacula-1.32f.ebuild 3895
MD5 aa3d61f0c3c5c1a76183f38cafb364d9 bacula-1.32f-r5.ebuild 3877
-MD5 58d222a5a2a3b2114602c3f789327ad7 ChangeLog 4103
+MD5 2a1f0a92ab046aeadc2f6b50cdb928b4 ChangeLog 4231
MD5 760cdede7c247ae42cc4bc3c104402ca bacula-1.34.4.ebuild 4196
MD5 7e285f080272b311b0eb8b0028928e07 metadata.xml 219
MD5 c453d7375a93ff187e5bc03ede9417b8 files/digest-bacula-1.32f-r5 67
@@ -9,5 +10,6 @@ MD5 68cdbb97c1064de4654b8db6160442ca files/digest-bacula-1.32f 268
MD5 31149a128e2534c0ca998c9f1b851b96 files/bacula-init 1924
MD5 f444bcaac48e16af2fd6fb2e247bf8b6 files/digest-bacula-1.34.1 66
MD5 0b9309406bd6631e14ba47c132ef3b33 files/digest-bacula-1.34.4 66
+MD5 8e55a5f04a3cd9e096e9a5dfb46f1de7 files/digest-bacula-1.34.5 66
MD5 13dd37747df7f32ec471e6bdf7eadec2 files/1.32f/1.32f-2-eom-nextvol.patch 9992
MD5 aba3c0108a7b301c99c8aa4f59a04081 files/1.32f/1.32f-1-weekofmonth.patch 1879
diff --git a/app-admin/bacula/bacula-1.34.5.ebuild b/app-admin/bacula/bacula-1.34.5.ebuild
new file mode 100644
index 000000000000..3f3e24a73623
--- /dev/null
+++ b/app-admin/bacula/bacula-1.34.5.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+SRC_URI="mirror://sourceforge/bacula/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="readline tcpd gnome mysql sqlite X static postgres wxwindows"
+
+#theres a local sqlite use flag. use it -OR- mysql, not both.
+#mysql is the reccomended choice ...
+#may need sys-libs/libtermcap-compat but try without first
+DEPEND=">=sys-libs/zlib-1.1.4
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ gnome? ( gnome-base/gnome-libs )
+ sqlite? ( >=dev-db/sqlite-2.7 )
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.4.0 )
+ X? ( virtual/x11 )
+ virtual/mta
+ dev-libs/gmp"
+RDEPEND="${DEPEND}
+ sys-apps/mtx
+ app-arch/mt-st"
+
+src_compile() {
+ local myconf=""
+
+ #define this to skip building the other daemons ...
+ [ -n "$BUILD_CLIENT_ONLY" ] \
+ && myconf="${myconf} --enable-client-only"
+
+ myconf="
+ `use_enable readline`
+ `use_enable gnome`
+ `use_enable tcpd tcp-wrappers`
+ `use_enable X x`
+ `use_enable wxwindows wx-console`
+ "
+ #not ./configure'able
+ #`use_enable ssl`
+
+ # mysql is the reccomended choice ...
+ if use mysql
+ then
+ myconf="${myconf} --with-mysql=/usr"
+ elif use postgres
+ then
+ myconf="${myconf} --with-postgresql=/usr"
+ elif use sqlite
+ then
+ myconf="${myconf} --with-sqlite=/usr/include"
+ elif use sqlite && use mysql
+ then
+ myconf="${myconf/--with-sqlite/}"
+ fi
+
+ ./configure \
+ --enable-smartalloc \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lib/bacula \
+ --with-working-dir=/var/lib/bacula \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+
+ if use static
+ then
+ cd ${S}/src/filed
+ make static-baula-fd
+ cd ${S}/src/console
+ make static-console
+ cd ${S}/src/dird
+ make static-bacula-dir
+ if use gnome
+ then
+ cd ${S}/src/gnome-console
+ make static-gnome-console
+ fi
+ if use wxwindows
+ then
+ cd ${S}/src/wx-console
+ make static-wx-console
+ fi
+ cd ${S}/src/stored
+ make static-bacula-sd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use static
+ then
+ cd ${S}/src/filed
+ cp static-bacula-fd ${D}/usr/sbin/bacula-fd
+ cd ${S}/src/console
+ cp static-console ${D}/usr/sbin/console
+ cd ${S}/src/dird
+ cp static-bacula-dir ${D}/usr/sbin/bacula-dir
+ if use gnome
+ then
+ cd ${S}/src/gnome-console
+ cp static-gnome-console ${D}/usr/sbin/gnome-console
+ fi
+ if use wxwindows
+ then
+ cd ${S}/src/wx-console
+ cp static-wx-console ${D}/usr/sbin/wx-console
+ fi
+ cd ${S}/src/storge
+ cp static-bacula-sd ${D}/usr/sbin/bacula-sd
+ fi
+
+ rm -rf ${D}/var #empty dir
+
+ for a in ${S}/{Changelog,CheckList,INSTALL \
+ README,ReleaseNotes,kernstodo,doc/bacula.pdf}
+ do
+ dodoc $a
+ done
+
+ cp -a ${S}/examples ${D}/usr/share/doc/${PF}
+ chown -R root:root ${D}/usr/share/doc/${PF} #hrmph :\
+ dohtml -r ${S}/doc/html-manual doc/home-page
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bacula-init bacula
+}
+
+pkg_postinst() {
+ # empty dir ...
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/bacula
+ einfo
+ einfo "Please note either/or nature of database USE flags for"
+ einfo "Bacula. If mysql is set, it will be used, else postgresql"
+ einfo "else finally SQLite. If you wish to have multiple DBs on"
+ einfo "one system, you may wish to unset auxillary DBs for this"
+ einfo "build."
+ einfo
+ einfo "If this is a new install and you plan to use mysql for your"
+ einfo "catalog database, then you should now create it by doing"
+ einfo "these commands:"
+ einfo " sh /etc/bacula/grant_mysql_privileges"
+ einfo " sh /etc/bacula/create_mysql_database"
+ einfo " sh /etc/bacula/make_mysql_tables"
+ einfo
+ einfo "Then setup your configuration files in /etc/bacula and"
+ einfo "start the daemons:"
+ einfo " /etc/init.d/bacula start"
+ einfo
+ einfo "If upgrading from version 1.30 or below, please note that"
+ einfo "the database format has changed. Please read the"
+ einfo "release notes for how to upgrade your database!!!"
+ einfo
+}
diff --git a/app-admin/bacula/files/digest-bacula-1.34.5 b/app-admin/bacula/files/digest-bacula-1.34.5
new file mode 100644
index 000000000000..50642fab004c
--- /dev/null
+++ b/app-admin/bacula/files/digest-bacula-1.34.5
@@ -0,0 +1 @@
+MD5 3bdccf8c9ee7e794c0035afbc529a33a bacula-1.34.5.tar.gz 4628068