summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-12 12:18:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-12 12:18:13 +0000
commit5794a2c69eb0be4d09a755ea9b48c63085c554db (patch)
tree1366f8e69d47db9070bfb720ffedd537c37b64d4 /app-admin
parentRevert wrongly removed ebuild (diff)
downloadgentoo-2-5794a2c69eb0be4d09a755ea9b48c63085c554db.tar.gz
gentoo-2-5794a2c69eb0be4d09a755ea9b48c63085c554db.tar.bz2
gentoo-2-5794a2c69eb0be4d09a755ea9b48c63085c554db.zip
Fixup fmtutil-sys call and maintainer in the eselect file
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-pdftex/ChangeLog8
-rw-r--r--app-admin/eselect-pdftex/eselect-pdftex-0.3.ebuild29
-rw-r--r--app-admin/eselect-pdftex/files/pdftex.eselect-0.3148
3 files changed, 184 insertions, 1 deletions
diff --git a/app-admin/eselect-pdftex/ChangeLog b/app-admin/eselect-pdftex/ChangeLog
index e560ef5ea44e..3b2dac8fefe2 100644
--- a/app-admin/eselect-pdftex/ChangeLog
+++ b/app-admin/eselect-pdftex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-pdftex
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pdftex/ChangeLog,v 1.14 2009/11/06 21:37:39 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pdftex/ChangeLog,v 1.15 2009/12/12 12:18:13 aballier Exp $
+
+*eselect-pdftex-0.3 (12 Dec 2009)
+
+ 12 Dec 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/pdftex.eselect-0.3, +eselect-pdftex-0.3.ebuild:
+ Fixup fmtutil-sys call and maintainer in the eselect file
*eselect-pdftex-0.2 (06 Nov 2009)
diff --git a/app-admin/eselect-pdftex/eselect-pdftex-0.3.ebuild b/app-admin/eselect-pdftex/eselect-pdftex-0.3.ebuild
new file mode 100644
index 000000000000..6ed93edd74f9
--- /dev/null
+++ b/app-admin/eselect-pdftex/eselect-pdftex-0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pdftex/eselect-pdftex-0.3.ebuild,v 1.1 2009/12/12 12:18:13 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="pdftex module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+# Depend on texlive-core-2008 that allows usage of this module, otherwise it
+# will not work so nicely.
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=app-text/texlive-core-2008"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="pdftex"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-admin/eselect-pdftex/files/pdftex.eselect-0.3 b/app-admin/eselect-pdftex/files/pdftex.eselect-0.3
new file mode 100644
index 000000000000..a7d8bc19437f
--- /dev/null
+++ b/app-admin/eselect-pdftex/files/pdftex.eselect-0.3
@@ -0,0 +1,148 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: pdftex.eselect-0.3,v 1.1 2009/12/12 12:18:13 aballier Exp $
+
+DESCRIPTION="Manage /usr/bin/pdftex implementations"
+MAINTAINER="tex@gentoo.org"
+SVN_DATE='$Date: 2009/12/12 12:18:13 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# find a list of pdftex symlink targets, best first
+find_targets() {
+ local f
+ for f in "${ROOT}"/usr/bin/pdftex-*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/pdftex-}"
+ fi
+ done | sort
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${ROOT}"/usr/bin/pdftex)"
+ echo "${f##*/pdftex-}"
+}
+
+# try to remove the pdftex symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/pdftex &>/dev/null
+}
+
+# set the pdftex symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/pdftex-${target}" ]] ; then
+ remove_symlinks
+ ln -s "pdftex-${target}" "${ROOT}/usr/bin/pdftex" || \
+ die "Could not set ${target} /usr/bin/pdftex symlink"
+ echo "Updating TeX formats"
+ "${ROOT}"/usr/bin/fmtutil-sys --all &>/dev/null || write_warning_msg "Could not update TeX formats for some reason, pdftex may not work properly."
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current pdftex version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current pdftex verson:"
+ if [[ -L "${ROOT}/usr/bin/pdftex" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${ROOT}/usr/bin/pdftex" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available pdftex versions"
+}
+
+do_list() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available pdftex versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new pdftex version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/pdftex" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/pdftex" ]] ; then
+ die -q "${ROOT}/usr/bin/pdftex seems to be from an old ebuild, please remove manually"
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the pdftex version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/pdftex" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${ROOT}/usr/bin/pdftex" ]] ; then
+ die -q "${ROOT}/usr/bin/pdftex seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}