summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-09 22:30:10 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-09 22:30:10 +0000
commit5a404088cfe0e1ffcec5830cee5f0ef3691dd3aa (patch)
tree8cfda571a565ed52060b4f11cb253536f939b85b /app-admin
parentversion bump (diff)
downloadgentoo-2-5a404088cfe0e1ffcec5830cee5f0ef3691dd3aa.tar.gz
gentoo-2-5a404088cfe0e1ffcec5830cee5f0ef3691dd3aa.tar.bz2
gentoo-2-5a404088cfe0e1ffcec5830cee5f0ef3691dd3aa.zip
EAPI bump, install Perl modules into correct directory, bug 431232
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/bastille/ChangeLog10
-rw-r--r--app-admin/bastille/bastille-3.0.9-r1.ebuild70
-rw-r--r--app-admin/bastille/files/bastille-3.0.9-perl.patch25
3 files changed, 103 insertions, 2 deletions
diff --git a/app-admin/bastille/ChangeLog b/app-admin/bastille/ChangeLog
index 9bd31ba6797d..efb62bed016b 100644
--- a/app-admin/bastille/ChangeLog
+++ b/app-admin/bastille/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/bastille
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.23 2011/07/20 15:39:23 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.24 2014/12/09 22:30:09 dilfridge Exp $
+
+*bastille-3.0.9-r1 (09 Dec 2014)
+
+ 09 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +bastille-3.0.9-r1.ebuild, +files/bastille-3.0.9-perl.patch:
+ EAPI bump, install Perl modules into correct directory, bug 431232
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34864
diff --git a/app-admin/bastille/bastille-3.0.9-r1.ebuild b/app-admin/bastille/bastille-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..335b7a9b9eeb
--- /dev/null
+++ b/app-admin/bastille/bastille-3.0.9-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-3.0.9-r1.ebuild,v 1.1 2014/12/09 22:30:09 dilfridge Exp $
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils perl-module
+
+PATCHVER=0.2
+MY_PN=${PN/b/B}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Bastille-Linux is a security hardening tool"
+HOMEPAGE="http://bastille-linux.org/"
+SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="X"
+
+RDEPEND="
+ net-firewall/iptables
+ app-admin/logrotate
+ dev-perl/Curses
+ net-firewall/psad
+ X? ( dev-perl/perl-tk )
+ virtual/logger
+"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-gentoo-${PATCHVER}.patch
+
+ # make sure the Perl modules go into vendor dir
+ epatch "${FILESDIR}/${P}-perl.patch"
+ perl_set_version
+
+ cd "${S}"
+ chmod a+x Install.sh bastille-ipchains bastille-netfilter
+}
+
+src_install() {
+ perl_set_version
+ export VENDOR_LIB
+
+ cd "${S}"
+ DESTDIR="${D}" ./Install.sh
+
+ # Example configs
+ cd "${S}"
+ insinto /usr/share/Bastille
+ doins *.config
+
+ newinitd ${PN}-firewall.gentoo-init ${PN}-firewall
+
+ # Documentation
+ cd "${S}"
+ dodoc *.txt BUGS Change* README*
+ cd "${S}"/docs
+ doman *.1m
+}
+
+pkg_postinst() {
+ elog "Please be aware that when using the Server Lax, Server Moderate, or"
+ elog "Server Paranoia configurations, you may need to use InteractiveBastille"
+ elog "to set any advanced network information, such as masquerading and"
+ elog "internal interfaces, if you plan to use them."
+}
diff --git a/app-admin/bastille/files/bastille-3.0.9-perl.patch b/app-admin/bastille/files/bastille-3.0.9-perl.patch
new file mode 100644
index 000000000000..ab109093bc14
--- /dev/null
+++ b/app-admin/bastille/files/bastille-3.0.9-perl.patch
@@ -0,0 +1,25 @@
+diff -ruN Bastille-gentoo-2/Install.sh Bastille/Install.sh
+--- Bastille-gentoo-2/Install.sh 2014-12-09 23:05:55.674808824 +0100
++++ Bastille/Install.sh 2014-12-09 23:17:25.907847419 +0100
+@@ -3,7 +3,7 @@
+ umask 077
+
+ mkdir -p ${DESTDIR}/usr/sbin
+-mkdir -p ${DESTDIR}/usr/lib/perl5/site_perl/Curses
++mkdir -p ${DESTDIR}/${VENDOR_LIB}/Curses
+ mkdir -p ${DESTDIR}/usr/lib/Bastille
+ mkdir -p ${DESTDIR}/usr/share/Bastille
+ mkdir -p ${DESTDIR}/usr/share/Bastille/OSMap
+@@ -13,9 +13,9 @@
+
+ cp AutomatedBastille ${DESTDIR}/usr/sbin/
+ cp BastilleBackEnd ${DESTDIR}/usr/sbin
+-cp Bastille_Curses.pm ${DESTDIR}/usr/lib/perl5/site_perl
+-cp Bastille_Tk.pm ${DESTDIR}/usr/lib/perl5/site_perl
+-cp Curses/Widgets.pm ${DESTDIR}/usr/lib/perl5/site_perl/Curses
++cp Bastille_Curses.pm ${DESTDIR}/${VENDOR_LIB}
++cp Bastille_Tk.pm ${DESTDIR}/${VENDOR_LIB}
++cp Curses/Widgets.pm ${DESTDIR}/${VENDOR_LIB}/Curses
+ cp InteractiveBastille ${DESTDIR}/usr/sbin
+ # Questions.txt has been replaced by Modules.txt and Questions/
+ #cp Questions.txt ${DESTDIR}/usr/share/Bastille