summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-16 13:37:31 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-16 13:37:31 +0000
commit6dcc2e67db86c1fa60a4848b6c6c564f60a284de (patch)
tree2e6dea19029a582994f3bdf40fbc465549ca7b23 /app-admin
parentVersion bump. (diff)
downloadgentoo-2-6dcc2e67db86c1fa60a4848b6c6c564f60a284de.tar.gz
gentoo-2-6dcc2e67db86c1fa60a4848b6c6c564f60a284de.tar.bz2
gentoo-2-6dcc2e67db86c1fa60a4848b6c6c564f60a284de.zip
Stabilise latest on amd64 and x86. Drop overshadowed. Per bug #332417.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/ChangeLog8
-rw-r--r--app-admin/testdisk/files/testdisk-6.11-exif_bound_checking-v2.patch131
-rw-r--r--app-admin/testdisk/files/testdisk-6.8-jpeg.patch29
-rw-r--r--app-admin/testdisk/testdisk-6.10.ebuild59
-rw-r--r--app-admin/testdisk/testdisk-6.11-r1.ebuild62
-rw-r--r--app-admin/testdisk/testdisk-6.11.3.ebuild63
-rw-r--r--app-admin/testdisk/testdisk-6.12.ebuild45
-rw-r--r--app-admin/testdisk/testdisk-6.8-r1.ebuild63
8 files changed, 27 insertions, 433 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index ec8b78772b33..98b77b244601 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/testdisk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.43 2011/07/21 18:12:26 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.44 2011/10/16 13:37:31 scarabeus Exp $
+
+ 16 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> -testdisk-6.8-r1.ebuild,
+ -files/testdisk-6.8-jpeg.patch, -testdisk-6.10.ebuild,
+ -testdisk-6.11-r1.ebuild, -testdisk-6.11.3.ebuild,
+ -files/testdisk-6.11-exif_bound_checking-v2.patch, testdisk-6.12.ebuild:
+ Stabilise latest on amd64 and x86. Drop overshadowed. Per bug #332417.
21 Jul 2011; Dane Smith <c1pher@gentoo.org> testdisk-6.12.ebuild:
QA: Fix configure sanity checks wrt bug 374009. Thanks Ian Abbott
diff --git a/app-admin/testdisk/files/testdisk-6.11-exif_bound_checking-v2.patch b/app-admin/testdisk/files/testdisk-6.11-exif_bound_checking-v2.patch
deleted file mode 100644
index b0f5020999c3..000000000000
--- a/app-admin/testdisk/files/testdisk-6.11-exif_bound_checking-v2.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-diff -ru testdisk-6.11/src/file_jpg.c testdisk-6.11.1/src/file_jpg.c
---- testdisk-6.11/src/file_jpg.c 2009-04-08 12:24:02.000000000 +0200
-+++ testdisk-6.11.1/src/file_jpg.c 2009-04-23 12:19:27.000000000 +0200
-@@ -100,14 +100,10 @@
- if(buffer[i]!=0xff)
- return 0;
- /* 0xe0 APP0 */
-+ /* 0xef APP15 */
- /* 0xfe COM */
- /* 0xdb DQT */
-- if(buffer[i+1]==0xe0 ||
-- buffer[i+1]==0xfe ||
-- buffer[i+1]==0xdb)
-- {
-- }
-- else if(buffer[i+1]==0xe1)
-+ if(buffer[i+1]==0xe1)
- { /* APP1 Exif information */
- if(i+0x0A < buffer_size && 2+(buffer[i+2]<<8)+buffer[i+3] > 0x0A)
- {
-@@ -117,12 +113,17 @@
- file_recovery_new->time=get_date_from_tiff_header((const TIFFHeader*)&buffer[i+0x0A], tiff_size);
- }
- }
-+ else if((buffer[i+1]>=0xe0 && buffer[i+1]<=0xef) ||
-+ buffer[i+1]==0xfe ||
-+ buffer[i+1]==0xdb)
-+ {
-+ }
- else
- {
- reset_file_recovery(file_recovery_new);
- file_recovery_new->extension=file_hint_jpg.extension;
- file_recovery_new->file_check=&file_check_jpg;
-- file_recovery_new->min_filesize=288;
-+ file_recovery_new->min_filesize=(i>288?i:288);
- file_recovery_new->data_check=&data_check_jpg;
- file_recovery_new->calculated_file_size=2;
- return 1;
-@@ -511,7 +512,7 @@
- const unsigned int thumb_offset=thumb_data-(const char*)buffer;
- const unsigned int thumb_size=ifbytecount-(const char*)tiff;
- unsigned int j_old;
-- if(thumb_offset+thumb_size < sizeof(buffer))
-+ if(thumb_offset < sizeof(buffer) && thumb_offset+thumb_size < sizeof(buffer))
- {
- unsigned int j=thumb_offset+2;
- unsigned int thumb_sos_found=0;
-diff -ru testdisk-6.11/src/file_tiff.c testdisk-6.11.1/src/file_tiff.c
---- testdisk-6.11/src/file_tiff.c 2009-04-13 12:00:24.000000000 +0200
-+++ testdisk-6.11.1/src/file_tiff.c 2009-04-23 12:12:21.000000000 +0200
-@@ -65,6 +65,10 @@
- const uint32_t *tiff_next_diroff;
- const TIFFDirEntry *ifd;
- unsigned int j;
-+ /* Bound checking */
-+ if((const char*)ifd0 < (const char*)tiff ||
-+ (const char*)(ifd0+1) > (const char*)tiff + tiff_size)
-+ return NULL;
- for(j=0, ifd=&ifd0->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<be16(ifd0->nbr_fields);
- j++, ifd++)
-@@ -75,7 +79,9 @@
- exififd=(const struct ifd_header *)((const char*)tiff + be32(ifd->tdir_offset));
- }
- tiff_next_diroff=(const uint32_t *)ifd;
-- if(exififd!=NULL)
-+ if(exififd!=NULL &&
-+ (const char*)exififd > (const char*)tiff &&
-+ (const char*)(exififd+1) <= (const char*)tiff + tiff_size)
- { /* Exif */
- for(j=0, ifd=&exififd->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<be16(exififd->nbr_fields);
-@@ -89,6 +95,9 @@
- if(be32(*tiff_next_diroff)>0)
- {
- const const struct ifd_header *ifd1=(const struct ifd_header*)((const char *)tiff+be32(*tiff_next_diroff));
-+ if((const char*)ifd1 <= (const char*)tiff ||
-+ (const char*)(ifd1+1) > (const char*)tiff+tiff_size)
-+ return NULL;
- for(j=0, ifd=&ifd1->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<be16(ifd1->nbr_fields);
- j++, ifd++)
-@@ -107,6 +116,10 @@
- const uint32_t *tiff_next_diroff;
- const TIFFDirEntry *ifd;
- unsigned int j;
-+ /* Bound checking */
-+ if((const char*)ifd0 < (const char*)tiff ||
-+ (const char*)(ifd0+1) > (const char*)tiff + tiff_size)
-+ return NULL;
- for(j=0, ifd=&ifd0->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<le16(ifd0->nbr_fields);
- j++, ifd++)
-@@ -117,7 +130,9 @@
- exififd=(const struct ifd_header *)((const char*)tiff + le32(ifd->tdir_offset));
- }
- tiff_next_diroff=(const uint32_t *)ifd;
-- if(exififd!=NULL)
-+ if(exififd!=NULL &&
-+ (const char*)exififd > (const char*)tiff &&
-+ (const char*)(exififd+1) <= (const char*)tiff + tiff_size)
- { /* Exif */
- for(j=0, ifd=&exififd->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<le16(exififd->nbr_fields);
-@@ -131,6 +146,10 @@
- if(le32(*tiff_next_diroff)>0)
- {
- const const struct ifd_header *ifd1=(const struct ifd_header*)((const char *)tiff+le32(*tiff_next_diroff));
-+ /* Bound checking */
-+ if((const char*)(ifd1) <= (const char*)tiff ||
-+ (const char*)(ifd1+1) > (const char*)tiff+tiff_size)
-+ return NULL;
- for(j=0, ifd=&ifd1->ifd;
- (const char*)(ifd+1) <= (const char*)tiff+tiff_size && j<le16(ifd1->nbr_fields);
- j++, ifd++)
-@@ -168,11 +187,11 @@
- /* DateTimeOriginal */
- date_asc=find_tag_from_tiff_header(tiff, tiff_size, 0x9003);
- /* DateTimeDigitalized*/
-- if(date_asc==NULL || &date_asc[18] >= (const char *)tiff + tiff_size)
-+ if(date_asc==NULL || date_asc < (const char *)tiff || &date_asc[18] >= (const char *)tiff + tiff_size)
- date_asc=find_tag_from_tiff_header(tiff, tiff_size, 0x9004);
-- if(date_asc==NULL || &date_asc[18] >= (const char *)tiff + tiff_size)
-+ if(date_asc==NULL || date_asc < (const char *)tiff || &date_asc[18] >= (const char *)tiff + tiff_size)
- date_asc=find_tag_from_tiff_header(tiff, tiff_size, 0x132);
-- if(date_asc==NULL || &date_asc[18] >= (const char *)tiff + tiff_size)
-+ if(date_asc==NULL || date_asc < (const char *)tiff || &date_asc[18] >= (const char *)tiff + tiff_size)
- return (time_t)0;
- memset(&tm_time, 0, sizeof(tm_time));
- tm_time.tm_sec=(date_asc[17]-'0')*10+(date_asc[18]-'0'); /* seconds 0-59 */
diff --git a/app-admin/testdisk/files/testdisk-6.8-jpeg.patch b/app-admin/testdisk/files/testdisk-6.8-jpeg.patch
deleted file mode 100644
index b2dab00de138..000000000000
--- a/app-admin/testdisk/files/testdisk-6.8-jpeg.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- testdisk-6.8/src/file_jpg.c 2007-07-17 23:44:07.000000000 +0200
-+++ testdisk-6.8.new/src/file_jpg.c 2007-12-23 13:39:56.000000000 +0100
-
-@@ -394,18 +393,18 @@
- (void) jpeg_read_scanlines(&cinfo, buffer, 1);
- }
- (void) jpeg_finish_decompress(&cinfo);
-- jpeg_destroy_decompress(&cinfo);
-- }
--#endif
-- /* Not accurate */
--// jpeg_size=ftell(infile);
--// log_error("JPG offset %llu\n", (long long unsigned)jpeg_size);
- {
- my_source_mgr * src;
- src = (my_source_mgr *) cinfo.src;
- jpeg_size=src->file_size - src->pub.bytes_in_buffer;
--// log_error("JPG size: %llu\n", (long long unsigned)jpeg_size);
- }
-+ jpeg_destroy_decompress(&cinfo);
-+ }
-+#else
-+ /* Not accurate */
-+ jpeg_size=ftell(infile);
-+#endif
-+// log_error("JPG size: %llu\n", (long long unsigned)jpeg_size);
- if(jpeg_size<=0)
- return;
- #if defined(HAVE_LIBJPEG) && defined(HAVE_JPEGLIB_H)
diff --git a/app-admin/testdisk/testdisk-6.10.ebuild b/app-admin/testdisk/testdisk-6.10.ebuild
deleted file mode 100644
index 0ec620677345..000000000000
--- a/app-admin/testdisk/testdisk-6.10.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.10.ebuild,v 1.3 2011/07/08 10:16:50 ssuominen Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static reiserfs ntfs jpeg"
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND=">=sys-libs/ncurses-5.2
- jpeg? ( virtual/jpeg )
- ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
- reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
- >=sys-fs/e2fsprogs-1.35
- sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-#S=${WORKDIR}/${P}-WIP
-
-src_compile() {
- local myconf="--without-ewf --enable-sudo"
- # --with-foo are broken, any use of --with/--without disable the
- # functionality.
- # The following variation must be used.
- use reiserfs || myconf="${myconf} --without-reiserfs"
- use ntfs || myconf="${myconf} --without-ntfs"
- use jpeg || myconf="${myconf} --without-jpeg"
-
- # this is static method is the same used by upstream for their 'static' make
- # target, but better, as it doesn't break.
- use static && append-ldflags -static
-
- econf ${myconf} || die
-
- # perform safety checks for NTFS and REISERFS
- if use ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
- die "Failed to find NTFS library."
- fi
- if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
- die "Failed to find reiserfs library."
- fi
- if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
- die "Failed to find jpeg library."
- fi
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
-}
diff --git a/app-admin/testdisk/testdisk-6.11-r1.ebuild b/app-admin/testdisk/testdisk-6.11-r1.ebuild
deleted file mode 100644
index 2851d9ffd437..000000000000
--- a/app-admin/testdisk/testdisk-6.11-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.11-r1.ebuild,v 1.4 2011/07/08 10:16:50 ssuominen Exp $
-
-EAPI=2
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static reiserfs ntfs jpeg"
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND=">=sys-libs/ncurses-5.2
- jpeg? ( virtual/jpeg )
- ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
- reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
- >=sys-fs/e2fsprogs-1.35
- sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-#S=${WORKDIR}/${P}-WIP
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-exif_bound_checking-v2.patch
-}
-
-src_configure() {
- local myconf="--without-ewf --enable-sudo"
- # --with-foo are broken, any use of --with/--without disable the
- # functionality.
- # The following variation must be used.
- use reiserfs || myconf="${myconf} --without-reiserfs"
- use ntfs || myconf="${myconf} --without-ntfs"
- use jpeg || myconf="${myconf} --without-jpeg"
-
- # this is static method is the same used by upstream for their 'static' make
- # target, but better, as it doesn't break.
- use static && append-ldflags -static
-
- econf ${myconf} || die
-
- # perform safety checks for NTFS and REISERFS
- if use ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
- die "Failed to find NTFS library."
- fi
- if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
- die "Failed to find reiserfs library."
- fi
- if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
- die "Failed to find jpeg library."
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
-}
diff --git a/app-admin/testdisk/testdisk-6.11.3.ebuild b/app-admin/testdisk/testdisk-6.11.3.ebuild
deleted file mode 100644
index 8cf639a15930..000000000000
--- a/app-admin/testdisk/testdisk-6.11.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.11.3.ebuild,v 1.3 2011/07/08 10:16:50 ssuominen Exp $
-
-EAPI=2
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static reiserfs ntfs jpeg"
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND=">=sys-libs/ncurses-5.2
- jpeg? ( virtual/jpeg )
- ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
- reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
- >=sys-fs/e2fsprogs-1.35
- sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-#S=${WORKDIR}/${P}-WIP
-
-# merged upstream
-#src_prepare() {
-# epatch "${FILESDIR}"/${P}-exif_bound_checking-v2.patch
-#}
-
-src_configure() {
- local myconf="--without-ewf --enable-sudo"
- # --with-foo are broken, any use of --with/--without disable the
- # functionality.
- # The following variation must be used.
- use reiserfs || myconf="${myconf} --without-reiserfs"
- use ntfs || myconf="${myconf} --without-ntfs"
- use jpeg || myconf="${myconf} --without-jpeg"
-
- # this is static method is the same used by upstream for their 'static' make
- # target, but better, as it doesn't break.
- use static && append-ldflags -static
-
- econf ${myconf} || die
-
- # perform safety checks for NTFS and REISERFS
- if use ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
- die "Failed to find NTFS library."
- fi
- if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
- die "Failed to find reiserfs library."
- fi
- if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
- die "Failed to find jpeg library."
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
-}
diff --git a/app-admin/testdisk/testdisk-6.12.ebuild b/app-admin/testdisk/testdisk-6.12.ebuild
index 6f5f74ae9783..65a5217d35e0 100644
--- a/app-admin/testdisk/testdisk-6.12.ebuild
+++ b/app-admin/testdisk/testdisk-6.12.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.12.ebuild,v 1.3 2011/07/21 18:12:26 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.12.ebuild,v 1.4 2011/10/16 13:37:31 scarabeus Exp $
+
+EAPI=4
-EAPI=2
inherit eutils flag-o-matic
DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="static reiserfs ntfs jpeg"
+
# WARNING: reiserfs support does NOT work with reiserfsprogs
# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
DEPEND=">=sys-libs/ncurses-5.2
@@ -23,29 +25,27 @@ DEPEND=">=sys-libs/ncurses-5.2
sys-libs/zlib"
RDEPEND="!static? ( ${DEPEND} )"
-#S=${WORKDIR}/${P}-WIP
-
-# merged upstream
-#src_prepare() {
-# epatch "${FILESDIR}"/${P}-exif_bound_checking-v2.patch
-#}
-
src_configure() {
- local myconf="--without-ewf --enable-sudo"
- # --with-foo are broken, any use of --with/--without disable the
- # functionality.
- # The following variation must be used.
- use reiserfs || myconf="${myconf} --without-reiserfs"
- use ntfs || myconf="${myconf} --without-ntfs"
- use jpeg || myconf="${myconf} --without-jpeg"
+ local myconf
# this is static method is the same used by upstream for their 'static' make
# target, but better, as it doesn't break.
use static && append-ldflags -static
- econf ${myconf} || die
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf+=" --without-reiserfs"
+ use ntfs || myconf+=" --without-ntfs"
+ use jpeg || myconf+=" --without-jpeg"
- # perform safety checks for NTFS and REISERFS
+ econf \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --without-ewf \
+ --enable-sudo \
+ ${myconf}
+
+ # perform safety checks for NTFS, REISERFS and JPEG
if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
die "Failed to find either NTFS or NTFS-3G library."
fi
@@ -56,8 +56,3 @@ src_configure() {
die "Failed to find jpeg library."
fi
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
-}
diff --git a/app-admin/testdisk/testdisk-6.8-r1.ebuild b/app-admin/testdisk/testdisk-6.8-r1.ebuild
deleted file mode 100644
index fcce14192167..000000000000
--- a/app-admin/testdisk/testdisk-6.8-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.8-r1.ebuild,v 1.7 2011/07/08 10:16:50 ssuominen Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2
- mirror://gentoo/${P}-ntfsprogs2.patch.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="static reiserfs ntfs jpeg"
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND=">=sys-libs/ncurses-5.2
- jpeg? ( virtual/jpeg )
- ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
- reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
- >=sys-fs/e2fsprogs-1.35"
-RDEPEND="!static? ( ${DEPEND} )"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${DISTDIR}"/${P}-ntfsprogs2.patch.bz2
- epatch "${FILESDIR}"/${P}-jpeg.patch
-}
-
-src_compile() {
- local myconf="--without-ewf"
- # --with-foo are broken, any use of --with/--without disable the
- # functionality.
- # The following variation must be used.
- use reiserfs || myconf="${myconf} --without-reiserfs"
- use ntfs || myconf="${myconf} --without-ntfs"
- use jpeg || myconf="${myconf} --without-jpeg"
-
- # this is static method is the same used by upstream for their 'static' make
- # target, but better, as it doesn't break.
- use static && append-ldflags -static
-
- econf ${myconf} || die
-
- # perform safety checks for NTFS and REISERFS
- if use ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
- die "Failed to find NTFS library."
- fi
- if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
- die "Failed to find reiserfs library."
- fi
- if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
- die "Failed to find jpeg library."
- fi
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
-}