summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-12-09 14:55:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-12-09 14:55:25 +0000
commit78cfb984a3a5a709ba05b28ac69d13bf189b341e (patch)
treee781de3abdc0eba32d60bf37475a2ae554cbf4c6 /app-admin
parentMarking mpd-0.15.5 ppc64 for bug 293975 (diff)
downloadgentoo-2-78cfb984a3a5a709ba05b28ac69d13bf189b341e.tar.gz
gentoo-2-78cfb984a3a5a709ba05b28ac69d13bf189b341e.tar.bz2
gentoo-2-78cfb984a3a5a709ba05b28ac69d13bf189b341e.zip
Bump
(Portage version: 2.2_rc56/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/usermin/ChangeLog7
-rw-r--r--app-admin/usermin/usermin-1.430.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index b02ddc2454fc..49473363fe0a 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/usermin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.149 2009/09/24 20:41:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.150 2009/12/09 14:55:25 patrick Exp $
+
+*usermin-1.430 (09 Dec 2009)
+
+ 09 Dec 2009; Patrick Lauer <patrick@gentoo.org> +usermin-1.430.ebuild:
+ Bump
*usermin-1.420 (24 Sep 2009)
diff --git a/app-admin/usermin/usermin-1.430.ebuild b/app-admin/usermin/usermin-1.430.ebuild
new file mode 100644
index 000000000000..2ec80246e8b5
--- /dev/null
+++ b/app-admin/usermin/usermin-1.430.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.430.ebuild,v 1.1 2009/12/09 14:55:25 patrick Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ sys-process/lsof
+ ssl? ( dev-perl/Net-SSLeay )"
+
+# pam? ( dev-perl/Authen-PAM )
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ epatch "${FILESDIR}"/${PN}-1.080-safestop.patch
+ epatch "${FILESDIR}"/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ dodir /usr/libexec/usermin
+ cp -pR * "${D}"/usr/libexec/usermin
+
+ newinitd "${FILESDIR}"/init.d.usermin usermin
+
+ newpamd "${FILESDIR}"/${PN}.pam-include.1 ${PN}
+
+ # Fix ownership
+ chown -R root:0 "${D}"
+
+ dodir /etc/usermin
+ dodir /var/log/usermin
+
+ config_dir=${D}/etc/usermin
+ var_dir=${D}/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/usermin/setup.sh > "${T}"/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/usermin.pid:" "${D}"/etc/usermin/miniserv.conf
+ find "${D}"/etc/usermin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/usermin
+ keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+ elog "To make usermin start at boot time, run: 'rc-update add usermin default'."
+ elog "Point your web browser to https://localhost:20000 to use usermin."
+}