summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-10-30 00:48:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-10-30 00:48:08 +0000
commit86bc07adfea9819b08767136cf1114f02c654cb4 (patch)
tree46a3e9bddf73a3f538125ea1a9132ca416ec5c06 /app-admin
parentAdd mini colourblind balls #153287 by Rickard Närström. (diff)
downloadgentoo-2-86bc07adfea9819b08767136cf1114f02c654cb4.tar.gz
gentoo-2-86bc07adfea9819b08767136cf1114f02c654cb4.tar.bz2
gentoo-2-86bc07adfea9819b08767136cf1114f02c654cb4.zip
Bug #152380, version bump, thanks to upstream for filing it to remind us. 6.5 is a candidate for stable in 30 days.
(Portage version: 2.1.2_rc1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/ChangeLog9
-rw-r--r--app-admin/testdisk/files/digest-testdisk-6.53
-rw-r--r--app-admin/testdisk/metadata.xml3
-rw-r--r--app-admin/testdisk/testdisk-6.5.ebuild55
4 files changed, 68 insertions, 2 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index f930121f892c..b3fb3862b462 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/testdisk
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.19 2006/06/28 09:19:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.20 2006/10/30 00:48:08 robbat2 Exp $
+
+*testdisk-6.5 (30 Oct 2006)
+
+ 30 Oct 2006; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
+ +testdisk-6.5.ebuild:
+ Bug #152380, version bump, thanks to upstream for filing it to remind us.
+ 6.5 is a candidate for stable in 30 days.
*testdisk-6.4 (28 Jun 2006)
diff --git a/app-admin/testdisk/files/digest-testdisk-6.5 b/app-admin/testdisk/files/digest-testdisk-6.5
new file mode 100644
index 000000000000..84dbd0331dd2
--- /dev/null
+++ b/app-admin/testdisk/files/digest-testdisk-6.5
@@ -0,0 +1,3 @@
+MD5 58cb6ebd95d524775720646a7bb79354 testdisk-6.5.tar.bz2 628884
+RMD160 df1778147b8b19719b90240b74674c3f438a9cac testdisk-6.5.tar.bz2 628884
+SHA256 dc898056087de5f453fadcba9770af76a1b0f0acff87b13adbb7c2d71b21c2ef testdisk-6.5.tar.bz2 628884
diff --git a/app-admin/testdisk/metadata.xml b/app-admin/testdisk/metadata.xml
index fca2e32c6a5f..358d6026356f 100644
--- a/app-admin/testdisk/metadata.xml
+++ b/app-admin/testdisk/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<maintainer>
<email>robbat2@gentoo.org</email>
- <name>Robin H. Johnson</name>
+ <name>Robin H. Johnson</name>
+ <description>Primary maintainer</description>
</maintainer>
</pkgmetadata>
diff --git a/app-admin/testdisk/testdisk-6.5.ebuild b/app-admin/testdisk/testdisk-6.5.ebuild
new file mode 100644
index 000000000000..fcd9215dc9d2
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.5.ebuild,v 1.1 2006/10/30 00:48:08 robbat2 Exp $
+
+
+DESCRIPTION="Multi-platform tool to check and undelete partition, supports reiserfs, ntfs, fat32, ext2/3 and many others. Also includes PhotoRec to recover pictures from digital camera memory."
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg )
+ ntfs? ( >=sys-fs/ntfsprogs-1.9.4 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_compile() {
+ local myconf
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' ${S}/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' ${S}/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' ${S}/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+