summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-01-30 20:43:02 +0000
committerMark Guertin <gerk@gentoo.org>2003-01-30 20:43:02 +0000
commit8e75fc80b2e31b9c3fc7668711b1f9d2c7e18bab (patch)
treef746308db6fff62c111105da7ed380f59f2170a0 /app-admin
parentmake ebuilds use kde_src_unpack not base_src_unpack - see note on -core (diff)
downloadgentoo-2-8e75fc80b2e31b9c3fc7668711b1f9d2c7e18bab.tar.gz
gentoo-2-8e75fc80b2e31b9c3fc7668711b1f9d2c7e18bab.tar.bz2
gentoo-2-8e75fc80b2e31b9c3fc7668711b1f9d2c7e18bab.zip
initial build, set for testing on all arches (simple sh script)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mirrorselect/ChangeLog9
-rw-r--r--app-admin/mirrorselect/files/digest-mirrorselect-0.10
-rw-r--r--app-admin/mirrorselect/files/mirrorselect62
-rw-r--r--app-admin/mirrorselect/mirrorselect-0.1.ebuild20
4 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/mirrorselect/ChangeLog b/app-admin/mirrorselect/ChangeLog
new file mode 100644
index 000000000000..0d8855f23557
--- /dev/null
+++ b/app-admin/mirrorselect/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/mirrorselect
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mirrorselect/ChangeLog,v 1.1 2003/01/30 20:42:58 gerk Exp $
+
+*mirrorselect-0.1 (30 Jan 2003)
+ 30 jan 2003; Mark Guertin <gerk@gentoo.org> mirrorselect-0.1.ebuild :
+ Initial release, quick and ditry little dialog based script to pick
+ your distfile mirror. For now mirrors are hardcoded into script, but
+ this will move of to something more dynamic when possible
diff --git a/app-admin/mirrorselect/files/digest-mirrorselect-0.1 b/app-admin/mirrorselect/files/digest-mirrorselect-0.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-admin/mirrorselect/files/digest-mirrorselect-0.1
diff --git a/app-admin/mirrorselect/files/mirrorselect b/app-admin/mirrorselect/files/mirrorselect
new file mode 100644
index 000000000000..199c93e211ad
--- /dev/null
+++ b/app-admin/mirrorselect/files/mirrorselect
@@ -0,0 +1,62 @@
+#!/bin/sh
+# Gentoo Mirror Selection tool
+# Copyright 2003 Mark Guertin <gerk@gentoo.org>
+# Distributed under the GPL v2
+# Jan 30, 2003
+
+# for now it has a static list of mirrors, but will move to a more
+# dynamic setup once the lists are in place to pull from
+
+MIRROR_LIST='
+http://distro.ibiblio.org/gentoo (USA) ""
+ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo (USA) ""
+http://gentoo.oregonstate.edu (USA) ""
+ftp://ftp.oregonstate.edu/pub/gentoo (USA/ftp) ""
+http://mirrors.sunsite.dk/gentoo/ (Denmark) ""
+ftp://sunsite.dk/mirrors/gentoo/ (Denmark/ftp) ""
+http://gentoo.linux.no/ (Norway) ""
+ftp://gentoo.linux.no/pub/gentoo/ (Norway/ftp) ""
+http://ftp.tu-clausthal.de/pub/linux/gentoo/ (Germany) ""
+ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ (Germany/ftp) ""
+http://ftp.gentoo.or.kr/ (South_Korea) ""
+http://gentoo.gnukorea.org/ (South_Korea) ""
+ftp://ftp.dale.ro/pub/mirrors/ftp.ibiblio.org/pub/Linux/distributions/gentoo/ (Romania/ftp) ""
+http://ftp.snt.utwente.nl/pub/os/linux/gentoo/ (Netherlands) ""
+ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/ (Netherlands/ftp) ""
+ftp://ftp.rez-gif.supelec.fr/pub/Linux/distrib/gentoo/ (France/ftp) ""
+'
+
+MIRRORS=`dialog --title "GENTOO MIRRORS LIST" \
+ --checklist "Please select your desired mirror(s):" 20 80 12 \
+$MIRROR_LIST 2>&1 | sed "s:\"::g"`
+
+
+if [ ! "`echo $MIRRORS`" ] ; then
+ echo "no mirrors selected, exiting"
+ exit 1
+fi
+
+echo "Selected: $MIRRORS"
+
+# adjust settings in make.conf, all in one command to avoid complaints of make.conf being moved
+mv /etc/make.conf /etc/make.conf.old && cat /etc/make.conf.old | grep -v "GENTOO_MIRRORS" > /etc/make.conf && \
+
+echo "GENTOO_MIRRORS=\"$MIRRORS\"" >> /etc/make.conf
+
+# triple check, it make.conf doesn't exist and make.conf.old doesn, replace it and warn user that
+# something didn't work
+
+if [ ! -s /etc/make.conf ] ; then
+ echo "make.conf didn't get remade, something is wrong, reverting to old one"
+ mv /etc/make.conf.old /etc/make.conf
+else
+ # all is well, rm the make.conf.old
+ if [ "`grep GENTOO_MIRRORS /etc/make.conf`" ] ; then
+ echo "Mirrors set successfully"
+ rm /etc/make.conf.old
+ else
+ echo "no mirrors set!"
+ fi
+
+fi
+
diff --git a/app-admin/mirrorselect/mirrorselect-0.1.ebuild b/app-admin/mirrorselect/mirrorselect-0.1.ebuild
new file mode 100644
index 000000000000..45a73a18d7e9
--- /dev/null
+++ b/app-admin/mirrorselect/mirrorselect-0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mirrorselect/mirrorselect-0.1.ebuild,v 1.1 2003/01/30 20:43:01 gerk Exp $
+
+DESCRIPTION="Tool to help select distfiles mirrors for Gentoo"
+SRC_URI=""
+HOMEPAGE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+
+DEPEND=">=dev-util/dialog-0.7
+ sys-apps/grep
+ sys-apps/sed"
+
+src_install() {
+ dosbin ${FILESDIR}/mirrorselect
+}
+