summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-08-17 17:10:32 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-08-17 17:10:32 +0000
commit914f99ba50fc77795d2676e6e172b782ac7f8109 (patch)
tree5ce37bf113c85bedbbdd43ffe7d3aec7148fb983 /app-admin
parentVersion bump. (diff)
downloadgentoo-2-914f99ba50fc77795d2676e6e172b782ac7f8109.tar.gz
gentoo-2-914f99ba50fc77795d2676e6e172b782ac7f8109.tar.bz2
gentoo-2-914f99ba50fc77795d2676e6e172b782ac7f8109.zip
Migrate to EAPI 4.
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sxid/ChangeLog5
-rw-r--r--app-admin/sxid/sxid-4.2.ebuild18
2 files changed, 12 insertions, 11 deletions
diff --git a/app-admin/sxid/ChangeLog b/app-admin/sxid/ChangeLog
index b832acc23934..a08b0d585494 100644
--- a/app-admin/sxid/ChangeLog
+++ b/app-admin/sxid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/sxid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.26 2012/05/09 20:07:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.27 2012/08/17 17:10:32 kensington Exp $
+
+ 17 Aug 2012; Michael Palimaka <kensington@gentoo.org> sxid-4.2.ebuild:
+ Migrate to EAPI 4.
09 May 2012; Agostino Sarubbo <ago@gentoo.org> -sxid-4.0.4-r2.ebuild:
Remove old
diff --git a/app-admin/sxid/sxid-4.2.ebuild b/app-admin/sxid/sxid-4.2.ebuild
index 26b92206cc27..b24f1f700773 100644
--- a/app-admin/sxid/sxid-4.2.ebuild
+++ b/app-admin/sxid/sxid-4.2.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.2.ebuild,v 1.1 2011/07/26 21:29:28 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.2.ebuild,v 1.2 2012/08/17 17:10:32 kensington Exp $
-EAPI=3
+EAPI=4
-inherit base toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="suid, sgid file and directory checking"
-SRC_URI="http://linukz.org/download/${P}.tar.gz"
HOMEPAGE="http://freshmeat.net/projects/sxid"
+SRC_URI="http://linukz.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,18 +20,16 @@ DEPEND="sys-apps/sed
sys-devel/gcc
sys-devel/autoconf"
-PATCHES=( "${FILESDIR}/${PN}-64bit-clean.patch" )
-
src_prepare() {
# this is an admin application and really requires root to run correctly
# we need to move the binary to the sbin directory
- sed -i s/bindir/sbindir/g source/Makefile.in
+ sed -i s/bindir/sbindir/g source/Makefile.in || die
tc-export CC
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc docs/{sxid.{conf,cron}.example,TODO} || die
+ emake DESTDIR="${D}" install
+ dodoc docs/sxid.{conf,cron}.example
}
pkg_postinst() {