summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-20 14:36:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-20 14:36:03 +0000
commitc50f8dfb1032f41e4b7128361604ff73f9d5d77f (patch)
tree2c103d09bfc411111c578c0b09744513fcc945ff /app-admin
parentStable on sparc (diff)
downloadgentoo-2-c50f8dfb1032f41e4b7128361604ff73f9d5d77f.tar.gz
gentoo-2-c50f8dfb1032f41e4b7128361604ff73f9d5d77f.tar.bz2
gentoo-2-c50f8dfb1032f41e4b7128361604ff73f9d5d77f.zip
New revision, with patches to work on OpenPAM (Gentoo/FreeBSD) and to compile cleanly on Linux. Also fixed setXid lazy bindings. Depends on virtual/pam, and is get_libdir friendly.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pam_dotfile/ChangeLog10
-rw-r--r--app-admin/pam_dotfile/Manifest13
-rw-r--r--app-admin/pam_dotfile/files/digest-pam_dotfile-0.7-r12
-rw-r--r--app-admin/pam_dotfile/pam_dotfile-0.7-r1.ebuild53
4 files changed, 66 insertions, 12 deletions
diff --git a/app-admin/pam_dotfile/ChangeLog b/app-admin/pam_dotfile/ChangeLog
index e8594d74e3ae..9ae457be3292 100644
--- a/app-admin/pam_dotfile/ChangeLog
+++ b/app-admin/pam_dotfile/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/pam_dotfile
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.8 2005/03/15 14:29:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.9 2005/05/20 14:36:03 flameeyes Exp $
+
+*pam_dotfile-0.7-r1 (20 May 2005)
+
+ 20 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +pam_dotfile-0.7-r1.ebuild:
+ New revision, with patches to work on OpenPAM (Gentoo/FreeBSD) and to
+ compile cleanly on Linux. Also fixed setXid lazy bindings. Depends on
+ virtual/pam, and is get_libdir friendly.
15 Mar 2005; Seemant Kulleen <seemant@gentoo.org> pam_dotfile-0.7.ebuild:
Dependency update: net-www/lynx -> www-client/lynx.
diff --git a/app-admin/pam_dotfile/Manifest b/app-admin/pam_dotfile/Manifest
index d369c2bbdd8b..3e7865966fad 100644
--- a/app-admin/pam_dotfile/Manifest
+++ b/app-admin/pam_dotfile/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a0914e27c84552c4f387e3e9c79dc226 pam_dotfile-0.7.ebuild 983
MD5 f535c0602b2188b6114f2bd334cb4463 ChangeLog 959
MD5 1d05f0436f1c273d7862099f309afe4d metadata.xml 156
+MD5 592fa32ae3f4064916ca4a967c213bf6 pam_dotfile-0.7-r1.ebuild 1316
MD5 30fbae2d4d9759fde9c1ff733dac16b2 files/digest-pam_dotfile-0.7 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCNwooI1lqEGTUzyQRAqEPAJ986HVgPdP38rZUD1AVhbIuaC3JlgCgjDT6
-yCseEqVP5B8OHteV0rNnyHs=
-=4CMH
------END PGP SIGNATURE-----
+MD5 2b5aec0eeb00f8fddd73816f0a7699c6 files/digest-pam_dotfile-0.7-r1 139
diff --git a/app-admin/pam_dotfile/files/digest-pam_dotfile-0.7-r1 b/app-admin/pam_dotfile/files/digest-pam_dotfile-0.7-r1
new file mode 100644
index 000000000000..6f4cd9813f69
--- /dev/null
+++ b/app-admin/pam_dotfile/files/digest-pam_dotfile-0.7-r1
@@ -0,0 +1,2 @@
+MD5 3c7249f4e6d8a9bd756bb4e09f2ed907 pam_dotfile-0.7.tar.gz 229009
+MD5 b2c8631cb8b58f37c282b4bcf16db6ae pam_dotfile-patches-1.tar.bz2 2172
diff --git a/app-admin/pam_dotfile/pam_dotfile-0.7-r1.ebuild b/app-admin/pam_dotfile/pam_dotfile-0.7-r1.ebuild
new file mode 100644
index 000000000000..a42b4df6b22f
--- /dev/null
+++ b/app-admin/pam_dotfile/pam_dotfile-0.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.1 2005/05/20 14:36:03 flameeyes Exp $
+
+inherit eutils pam
+
+MY_P="${P/_beta/beta}"
+S="${WORKDIR}/${MY_P}"
+
+PATCHLEVEL="1"
+DESCRIPTION="pam module to allow password-storing in \$HOME/dotfiles"
+HOMEPAGE="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/"
+SRC_URI="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/${MY_P}.tar.gz
+ http://digilander.libero.it/dgp85/gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+DEPEND="doc? ( www-client/lynx )
+ virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/${PV}
+ sed -i -e 's:./configure:#./configure:' ${S}/bootstrap.sh
+ sed -i -e "s:aclocal:aclocal -I ${WORKDIR}/${PV}/m4:" ${S}/bootstrap.sh
+
+ sh bootstrap.sh
+}
+
+src_compile() {
+ local myconf
+
+ econf \
+ $(use_enable doc lynx) \
+ "--with-pammoddir=$(getpam_mod_dir)" \
+ || die
+ emake || die
+}
+
+src_install() {
+ make -C src DESTDIR=${D} install
+ make -C man DESTDIR=${D} install
+
+ rm -f ${D}/$(getpam_mod_dir)/pam_dotfile.la
+ fperms 4111 /usr/sbin/pam-dotfile-helper
+
+ dodoc README
+ dohtml doc/*
+}