summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-12-18 05:03:33 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-12-18 05:03:33 +0000
commitcda18f3b7f5fab6bb24791a65155a78b1c8f8d7d (patch)
treecc3ddb7254ab99fa8dc0a8b9f4c8c3b52840bdb4 /app-admin
parentversion bump (diff)
downloadgentoo-2-cda18f3b7f5fab6bb24791a65155a78b1c8f8d7d.tar.gz
gentoo-2-cda18f3b7f5fab6bb24791a65155a78b1c8f8d7d.tar.bz2
gentoo-2-cda18f3b7f5fab6bb24791a65155a78b1c8f8d7d.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-254.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index b229758a4cda..8ac2db90f74a 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.30 2013/08/22 14:54:55 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.31 2013/12/18 05:03:33 lxnay Exp $
+
+*equo-254 (18 Dec 2013)
+
+ 18 Dec 2013; Fabio Erculiani <lxnay@gentoo.org> +equo-254.ebuild:
+ version bump
22 Aug 2013; Fabio Erculiani <lxnay@gentoo.org> -equo-189.ebuild:
drop older version 189
diff --git a/app-admin/equo/equo-254.ebuild b/app-admin/equo/equo-254.ebuild
new file mode 100644
index 000000000000..5a0764ca9660
--- /dev/null
+++ b/app-admin/equo/equo-254.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-254.ebuild,v 1.1 2013/12/18 05:03:33 lxnay Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="${PYTHON_DEPS}
+ ~sys-apps/entropy-${PV}[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_compile() {
+ cd "${S}"/client || die
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/client || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+
+ python_optimize "${D}/usr/lib/entropy/client"
+}
+