summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-11-09 02:06:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-11-09 02:06:04 +0000
commitd38c89eedc5662ba299937a0095237e1a277c639 (patch)
treea5e40f91f1cdff815fc88da219ff0c30d9f22fdf /app-admin
parentstable ppc ppc64, bug #442216 (diff)
downloadgentoo-2-d38c89eedc5662ba299937a0095237e1a277c639.tar.gz
gentoo-2-d38c89eedc5662ba299937a0095237e1a277c639.tar.bz2
gentoo-2-d38c89eedc5662ba299937a0095237e1a277c639.zip
Minor bump to hide some stderr output in certain configurations, as found by Denis M. (Phr33d0m) <god@politeia.in>.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/diradm/ChangeLog8
-rw-r--r--app-admin/diradm/diradm-2.9.7.1.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/app-admin/diradm/ChangeLog b/app-admin/diradm/ChangeLog
index a0e16dc297be..bc487bffc4c8 100644
--- a/app-admin/diradm/ChangeLog
+++ b/app-admin/diradm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/diradm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.40 2012/11/09 01:07:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.41 2012/11/09 02:06:04 robbat2 Exp $
+
+*diradm-2.9.7.1 (09 Nov 2012)
+
+ 09 Nov 2012; Robin H. Johnson <robbat2@gentoo.org> +diradm-2.9.7.1.ebuild:
+ Minor bump to hide some stderr output in certain configurations, as found by
+ Denis M. (Phr33d0m) <god@politeia.in>.
09 Nov 2012; Robin H. Johnson <robbat2@gentoo.org> diradm-2.9.7.ebuild:
EAPI2 doins die.
diff --git a/app-admin/diradm/diradm-2.9.7.1.ebuild b/app-admin/diradm/diradm-2.9.7.1.ebuild
new file mode 100644
index 000000000000..2c6f18d87f26
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.7.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.7.1.ebuild,v 1.1 2012/11/09 02:06:04 robbat2 Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="samba irixpasswd automount test"
+RDEPEND=">=net-nds/openldap-2.3
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ dev-util/dejagnu
+ net-nds/openldap[-minimal]
+ )"
+
+pkg_setup() {
+ use test && elog "Warning, for test usage, diradm is built with all optional features!"
+}
+
+src_configure() {
+ local myconf
+ if use test; then
+ myconf="--enable-samba --enable-automount --enable-irixpasswd"
+ else
+ myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
+ fi
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork \
+ THANKS TODO KNOWN-BUGS || die
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema || die "Failed irixpassword.schema"
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+ elog "This package is primarily intended for use with nss_ldap & pam_ldap"
+ elog "and populates many default settings from the /etc/ldap.conf used by"
+ elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
+ elog "for server connection settings only."
+}
+
+src_test() {
+ emake -j1 check
+}