summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-20 01:13:36 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-20 01:13:36 +0000
commitfca559b73902f67a85119479e81f8958bf7b05ec (patch)
treeca8e6f0eb32ad7858c150b244e6037fc9ad50cf8 /app-admin
parent*** empty log message *** (diff)
downloadgentoo-2-fca559b73902f67a85119479e81f8958bf7b05ec.tar.gz
gentoo-2-fca559b73902f67a85119479e81f8958bf7b05ec.tar.bz2
gentoo-2-fca559b73902f67a85119479e81f8958bf7b05ec.zip
*** empty log message ***
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mon/mon-0.38.20.ebuild22
-rw-r--r--app-admin/webalizer/files/httpd.webalizer13
-rw-r--r--app-admin/webalizer/files/webalizer.conf408
-rw-r--r--app-admin/webalizer/webalizer-1.30.04-r1.ebuild10
4 files changed, 442 insertions, 11 deletions
diff --git a/app-admin/mon/mon-0.38.20.ebuild b/app-admin/mon/mon-0.38.20.ebuild
index c18afc435861..db04a9e5aa9b 100644
--- a/app-admin/mon/mon-0.38.20.ebuild
+++ b/app-admin/mon/mon-0.38.20.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mon/mon-0.38.20.ebuild,v 1.1 2000/12/25 16:26:17 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mon/mon-0.38.20.ebuild,v 1.2 2001/01/20 01:13:36 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Highly configurable service monitoring daemon"
SRC_URI="ftp://ftp.kernel.org/pub/software/admin/mon/mon-0.38.20.tar.bz2"
HOMEPAGE="http://www.kernel.org/software/mon/"
+DEPEND=">=dev-perl/Mon-0.9"
src_compile() {
@@ -23,18 +24,25 @@ src_install () {
dosbin mon clients/mon*
insinto /etc/mon
- doins etc/*
+ doins etc/*.cf etc/example.monshowrc
insinto /usr/lib/mon/utils
doins utils/*
- insinto /usr/lib/mon/alert.d
- doins alert.d/*
+
+ exeinto /usr/lib/mon/alert.d
+ doexe alert.d/*
- insinto /usr/lib/mon/mon.d
- doins mon.d/*.monitor
- insopts -g uucp -m 02555 mon.d/*.wrap
+ exeinto /usr/lib/mon/mon.d
+ doexe mon.d/*.monitor
+ insopts -g uucp -m 02555
+ doins mon.d/*.wrap
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/mon
+
+ dodir /var/log/mon.d
+ dodir /var/lib/mon.d
dodoc CHANGES COPYING CREDITS KNOWN-PROBLEMS
dodoc mon.lsm README TODO VERSION
doman doc/*.1
diff --git a/app-admin/webalizer/files/httpd.webalizer b/app-admin/webalizer/files/httpd.webalizer
new file mode 100644
index 000000000000..da8e0ccd68ae
--- /dev/null
+++ b/app-admin/webalizer/files/httpd.webalizer
@@ -0,0 +1,13 @@
+#
+# This is the config file for modlogan-statistics
+#
+<Directory "/usr/local/httpd/webalizer">
+ Options None
+ AllowOverride None
+
+ Order allow,deny
+ Allow from all
+</Directory>
+
+Alias /webalizer "/usr/local/httpd/webalizer"
+
diff --git a/app-admin/webalizer/files/webalizer.conf b/app-admin/webalizer/files/webalizer.conf
new file mode 100644
index 000000000000..752f879b9c79
--- /dev/null
+++ b/app-admin/webalizer/files/webalizer.conf
@@ -0,0 +1,408 @@
+#
+# Sample Webalizer configuration file
+# Copyright 1997-1999 by Bradford L. Barrett (brad@mrunix.net)
+#
+# Distributed under the GNU General Public License. See the
+# files "Copyright" and "COPYING" provided with the webalizer
+# distribution for additional information.
+#
+# This is a sample configuration file for the Webalizer (ver 1.30)
+# Lines starting with pound signs '#' are comment lines and are
+# ignored. Blank lines are skipped as well. Other lines are considered
+# as configuration lines, and have the form "ConfigOption Value" where
+# ConfigOption is a valid configuration keyword, and Value is the value
+# to assign that configuration option. Invalid keyword/values are
+# ignored, with appropriate warnings being displayed. There must be
+# at least one space or tab between the keyword and its value.
+#
+# As of version 0.98, The Webalizer will look for a 'default' configuration
+# file named "webalizer.conf" in the current directory, and if not found
+# there, will look for "/etc/webalizer.conf".
+
+
+# LogFile defines the web server log file to use. If not specified
+# here or on on the command line, input will default to STDIN.
+
+LogFile /var/log/apache/access_log
+
+# LogType defines the log type being processed. Normally, the Webalizer
+# expects a CLF or Combined web server log as input. Using this option,
+# you can process ftp logs as well (xferlog as produced by wu-ftp and
+# others). Values can be 'web' or 'ftp', with 'web' the default.
+
+#LogType web
+
+# OutputDir is where you want to put the output files. This should
+# should be a full path name, however relative ones might work as well.
+# If no output directory is specified, the current directory will be used.
+
+OutputDir /usr/local/httpd/webalizer
+
+# HistoryName allows you to specify the name of the history file produced
+# by the Webalizer. The history file keeps the data for up to 12 months
+# worth of logs, used for generating the main HTML page (index.html).
+# The default is a file named "webalizer.hist", stored in the specified
+# output directory. If you specify just the filename (without a path),
+# it will be kept in the specified output directory. Otherwise, the path
+# is relative to the output directory, unless absolute (leading /).
+
+#HistoryName webalizer.hist
+
+# Incremental processing allows multiple partial log files to be used
+# instead of one huge one. Useful for large sites that have to rotate
+# their log files more than once a month. The Webalizer will save its
+# internal state before exiting, and restore it the next time run, in
+# order to continue processing where it left off. This mode also causes
+# The Webalizer to scan for and ignore duplicate records (records already
+# processed by a previous run). See the README file for additional
+# information. The value may be 'yes' or 'no', with a default of 'no'.
+# The file 'webalizer.current' is used to store the current state data,
+# and is located in the output directory of the program (unless changed
+# with the IncrementalName option below). Please read at least the section
+# on Incremental processing in the README file before you enable this option.
+
+#Incremental no
+
+# IncrementalName allows you to specify the filename for saving the
+# incremental data in. It is similar to the HistoryName option where the
+# name is relative to the specified output directory, unless an absolute
+# filename is specified. The default is a file named "webalizer.current"
+# kept in the normal output directory. If you don't specify "Incremental"
+# as 'yes' then this option has no meaning.
+
+#IncrementalName webalizer.current
+
+# ReportTitle is the text to display as the title. The hostname
+# (unless blank) is appended to the end of this string (seperated with
+# a space) to generate the final full title string.
+# Default is (for english) "Usage Statistics for".
+
+#ReportTitle Usage Statistics for
+
+# HostName defines the hostname for the report. This is used in
+# the title, and is prepended to the URL table items. This allows
+# clicking on URL's in the report to go to the proper location in
+# the event you are running the report on a 'virtual' web server,
+# or for a server different than the one the report resides on.
+# If not specified here, or on the command line, webalizer will
+# try to get the hostname via a uname system call. If that fails,
+# it will default to "localhost".
+
+#HostName localhost
+
+# HTMLExtension allows you to specify the filename extension to use
+# for generated HTML pages. Normally, this defaults to "html", but
+# can be changed for sites who need it (like for PHP embeded pages).
+
+#HTMLExtension html
+
+# PageType lets you tell the Webalizer what types of URL's you
+# consider a 'page'. Most people consider html and cgi documents
+# as pages, while not images and audio files. If no types are
+# specified, defaults will be used ('htm*', 'cgi' and HTMLExtension
+# if different).
+
+PageType htm*
+PageType cgi
+#PageType phtml
+#PageType php3
+#PageType pl
+
+# UseHTTPS should be used if the analysis is being run on a
+# secure server, and links to urls should use 'https://' instead
+# of the default 'http://'. If you need this, set it to 'yes'.
+# Default is 'no'. This only changes the behaviour of the 'Top
+# URL's' table.
+
+#UseHTTPS no
+
+# HTMLPre defines HTML code to insert at the very beginning of the
+# file. Default is the DOCTYPE line shown below. Max line length
+# is 80 characters, so use multiple HTMLPre lines if you need more.
+
+#HTMLPre <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
+
+# HTMLHead defines HTML code to insert within the <HEAD></HEAD>
+# block, immediately after the <TITLE> line. Maximum line length
+# is 80 characters, so use multiple lines if needed.
+
+#HTMLHead <META NAME="author" CONTENT="The Webalizer">
+
+# HTMLBody defined the HTML code to be inserted, starting with the
+# <BODY> tag. If not specified, the default is shown below. If
+# used, you MUST include your own <BODY> tag as the first line.
+# Maximum line length is 80 char, use multiple lines if needed.
+
+#HTMLBody <BODY BGCOLOR="#E8E8E8" TEXT="#000000" LINK="#0000FF" VLINK="#FF0000">
+
+# HTMLPost defines the HTML code to insert immediately before the
+# first <HR> on the document, which is just after the title and
+# "summary period"-"Generated on:" lines. If anything, this should
+# be used to clean up in case an image was inserted with HTMLBody.
+# As with HTMLHead, you can define as many of these as you want and
+# they will be inserted in the output stream in order of apperance.
+# Max string size is 80 characters. Use multiple lines if you need to.
+
+#HTMLPost <BR CLEAR="all">
+
+# HTMLTail defines the HTML code to insert at the bottom of each
+# HTML document, usually to include a link back to your home
+# page or insert a small graphic. It is inserted as a table
+# data element (ie: <TD> your code here </TD>) and is right
+# alligned with the page. Max string size is 80 characters.
+
+#HTMLTail <IMG SRC="msfree.gif" ALT="100% Micro$oft free!">
+
+# HTMLEnd defines the HTML code to add at the very end of the
+# generated files. It defaults to what is shown below. If
+# used, you MUST specify the </BODY> and </HTML> closing tags
+# as the last lines. Max string length is 80 characters.
+
+#HTMLEnd </BODY></HTML>
+
+# The Quiet option suppresses output messages... Useful when run
+# as a cron job to prevent bogus e-mails. Values can be either
+# "yes" or "no". Default is "no". Note: this does not suppress
+# warnings and errors (which are printed to stderr).
+
+#Quiet no
+
+# ReallyQuiet will supress all messages including errors and
+# warnings. Values can be 'yes' or 'no' with 'no' being the
+# default. If 'yes' is used here, it cannot be overriden from
+# the command line, so use with caution. A value of 'no' has
+# no effect.
+
+#ReallyQuiet no
+
+# TimeMe allows you to force the display of timing information
+# at the end of processing. A value of 'yes' will force the
+# timing information to be displayed. A value of 'no' has no
+# effect.
+
+#TimeMe no
+
+# GMTTime allows reports to show GMT (UTC) time instead of local
+# time. Default is to display the time the report was generated
+# in the timezone of the local machine, such as EDT or PST. This
+# keyword allows you to have times displayed in UTC instead. Use
+# only if you really have a good reason, since it will probably
+# screw up the reporting periods by however many hours your local
+# time zone is off of GMT.
+
+#GMTTime no
+
+# Debug prints additional information for error messages. This
+# will cause webalizer to dump bad records/fields instead of just
+# telling you it found a bad one. As usual, the value can be
+# either "yes" or "no". The default is "no". It shouldn't be
+# needed unless you start getting a lot of Warning or Error
+# messages and want to see why. (Note: warning and error messages
+# are printed to stderr, not stdout like normal messages).
+
+#Debug no
+
+# VisitTimeout allows you to set the default timeout for a visit
+# (sometimes called a 'session'). The default is 30 minutes,
+# which should be fine for most sites. The value is formatted
+# as HHMMSS where HH=hours MM=minutes and SS=seconds (use '00').
+# Visits are determined by looking at the time of the current
+# request, and the time of the last request from the site. If
+# the time difference is greater than the VisitTimeout value, it
+# is considered a new visit, and visit totals are incremented.
+
+#VisitTimeout 3000
+
+# IgnoreHist shouldn't be used in a config file, but it is here
+# just because it might be usefull in certain situations. If the
+# history file is ignored, the main "index.html" file will only
+# report on the current log files contents. Usefull only when you
+# want to reproduce the reports from scratch. USE WITH CAUTION!
+# Valid values are "yes" or "no". Default is "no".
+
+#IgnoreHist no
+
+# Country Graph allows the usage by country graph to be disabled.
+# Values can be 'yes' or 'no', default is 'yes'.
+
+#CountryGraph yes
+
+# HourlyGraph and HourlyStats allows the hourly statistics graph
+# and statistics table to be disabled (not displayed). Values
+# may be "yes" or "no". Default is "yes".
+
+#HourlyGraph yes
+#HourlyStats yes
+
+# GraphLegend allows the color coded legends to be turned on or off
+# in the graphs. The default is for them to be displayed. This only
+# toggles the color coded legends, the other legends are not changed.
+# If you think they are hideous and ugly, say 'no' here :)
+
+#GraphLegend yes
+
+# GraphLines allows you to have index lines drawn behind the graphs.
+# I personally am not crazy about them, but a lot of people requested
+# them and they weren't a big deal to add. The number represents the
+# number of lines you want displayed. Default is 2, you can disable
+# the lines by using a value of zero ('0'). [max is 20]
+# Note, due to rounding errors, some values don't work quite right.
+# The lower the better, with 1,2,3,4,6 and 10 producing nice results.
+
+#GraphLines 2
+
+# The "Top" options below define the number of entries for each table.
+# Defaults are Sites=30, URL's=30, Referrers=30 and Agents=15, and
+# Countries=50. TopKSites and TopKURLs (by KByte tables) both default
+# to 10, as do the top entry/exit tables (TopEntry/TopExit). The top
+# search strings default to 20. Tables may be disabled by using
+# zero (0) for the value.
+
+#TopSites 30
+#TopKSites 10
+#TopURLs 30
+#TopKURLs 10
+#TopReferrers 30
+#TopAgents 15
+#TopCountries 50
+#TopEntry 10
+#TopExit 10
+#TopSearch 20
+
+# The Webalizer normally strips the string 'index.' off the end of
+# URL's in order to consolidate URL totals. For example, the URL
+# /somedir/index.html is turned into /somedir/ which is really the
+# same URL. This option allows you to specify additional strings
+# to treat in the same way. You don't need to specify 'index.' as
+# it is always scanned for by The Webalizer, this option is just to
+# specify _additional_ strings if needed. If you don't need any,
+# don't specify any as each string will be scanned for in EVERY
+# log record... A bunch of them will degrade performance. Also,
+# the string is scanned for anywhere in the URL, so a string of
+# 'home' would turn the URL /somedir/homepages/brad/home.html into
+# just /somedir/ which is probably not what was intended.
+
+#IndexAlias home.htm
+#IndexAlias homepage.htm
+
+# The Hide*, Group* and Ignore* and Include* keywords allow you to change
+# the way Sites, URL's, Referrers and User Agents are manipulated. The
+# Ignore* keywords will cause The Webalizer to completely ignore
+# records as if they didn't exist (and thus not counted in the main
+# site totals). The Hide* keywords will prevent things from being
+# displayed in the 'Top' tables, but will still be counted in the
+# main totals. The Group* keywords allow grouping similar objects
+# as if they were one. Grouped records are displayed in the 'Top'
+# tables and can optionally be displayed in BOLD and/or shaded.
+# Groups cannot be hidden, and are not counted in the main totals.
+# The Group* options do not, by default, hide all the items that
+# it matches. If you want to hide the records that match (so just
+# the grouping record is displayed), follow with an identical Hide*
+# keyword with the same value. (see example below) In addition,
+# Group* keywords may have an optional label which will be displayed
+# instead of the keywords value. The label should be seperated from
+# the value by at least one 'white-space' character, such as a space
+# or tab.
+#
+# The value can have either a leading or trailing '*' wildcard
+# character. If no wildcard is found, a match can occur anywhere
+# in the string. Given a string "www.yourmama.com", the values "your",
+# "*mama.com" and "www.your*" will all match.
+
+# Your own site should be hidden
+#HideSite *mrunix.net
+#HideSite localhost
+
+# Your own site gives most referrals
+#HideReferrer mrunix.net/
+
+# This one hides non-referrers ("-" Direct requests)
+#HideReferrer Direct Request
+
+# Usually you want to hide these
+HideURL *.gif
+HideURL *.GIF
+HideURL *.jpg
+HideURL *.JPG
+HideURL *.ra
+
+# Hiding agents is kind of futile
+#HideAgent RealPlayer
+
+# Grouping options
+#GroupURL /cgi-bin/* CGI Scripts
+#GroupURL /images/* Images
+
+#GroupSite *.aol.com
+#GroupSite *.compuserve.com
+
+#GroupReferrer yahoo.com/ Yahoo!
+#GroupReferrer excite.com/ Excite
+#GroupReferrer infoseek.com/ InfoSeek
+#GroupReferrer webcrawler.com/ WebCrawler
+
+# The following is a great way to get an overall total
+# for browsers, and not display all the detail records.
+# (You should use MangleAgent to refine further...)
+
+#GroupAgent MSIE Micro$oft Internet Exploder
+#HideAgent MSIE
+#GroupAgent Mozilla Netscape
+#HideAgent Mozilla
+#GroupAgent Lynx* Lynx
+#HideAgent Lynx*
+
+# The GroupShading allows grouped rows to be shaded in the report.
+# Useful if you have lots of groups and individual records that
+# intermingle in the report, and you want to diferentiate the group
+# records a little more. Value can be 'yes' or 'no', with 'yes'
+# being the default.
+
+#GroupShading yes
+
+# GroupHighlight allows the group record to be displayed in BOLD.
+# Can be either 'yes' or 'no' with the default 'yes'.
+
+#GroupHighlight yes
+
+# The Ignore* keywords allow you to completely ignore log records based
+# on hostname, URL, user agent or referrer. I hessitated in adding these,
+# since the Webalizer was designed to generate _accurate_ statistics
+# about a web servers performance. By choosing to ignore records, the
+# accuracy of reports become skewed, negating why I wrote this program
+# in the first place. However, due to popular demand, here they are.
+# Use the same as the Hide*/Group* keywords, where the value can have a
+# leading or trailing wildcard '*'.
+
+#IgnoreSite bad.site.net
+#IgnoreURL /test*
+#IgnoreReferrer file:/*
+#IgnoreAgent RealPlayer
+
+# The Include* keywords allow you to force the inclusion of log records
+# based on hostname, URL, user agent or referrer. They take precidence
+# over the Ignore* keywords. Note: Using Ignore/Include combinations to
+# selectivly process parts of a web site is _extremely inefficent_!!!
+# Avoid doing so if possible (ie: grep the records to a seperate file).
+
+# Example: Only show stats on Joe User's pages...
+#IgnoreURL *
+#IncludeURL ~joeuser*
+
+# The MangleAgents allows you to specify how much, if any, The Webalizer
+# should mangle user agent names. This allows several levels of detail
+# to be produced when reporting user agent statistics. There are six
+# levels that can be specified, which define different levels of detail
+# supression. Level 5 shows only the browser name (MSIE or Mozilla)
+# and the major version number. Level 4 adds the minor version number
+# (single decimal place). Level 3 displays the minor version to two
+# decimal places. Level 2 will add any sub-level designation (such
+# as Mozilla/3.01Gold or MSIE 3.0b). Level 1 will attempt to also add
+# the system type if it is specified. The default Level 0 displays the
+# full user agent field without modification and produces the greatest
+# amount of detail. User agent names that can't be mangled will be
+# left unmodified.
+
+#MangleAgents 0
+
+# End of configuration file... Have a nice day!
diff --git a/app-admin/webalizer/webalizer-1.30.04-r1.ebuild b/app-admin/webalizer/webalizer-1.30.04-r1.ebuild
index c81b972a38fb..a93755051b9a 100644
--- a/app-admin/webalizer/webalizer-1.30.04-r1.ebuild
+++ b/app-admin/webalizer/webalizer-1.30.04-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-1.30.04-r1.ebuild,v 1.4 2000/11/27 22:48:58 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-1.30.04-r1.ebuild,v 1.5 2001/01/20 01:13:36 achim Exp $
P=webalizer-1.30-04
A=${P}-src.tar.bz2
@@ -17,6 +17,7 @@ DEPEND=">=sys-libs/glibc-2.1.3
src_unpack() {
unpack ${A}
cd ${S}
+ # libgd does not support gifs any longer so we use png's for webalizer
cp graphs.c graphs.c.orig
sed -e "s/gdImageGif.*/gdImagePng(im,out);/g" graphs.c.orig >graphs.c
cp webalizer.c webalizer.c.orig
@@ -26,7 +27,8 @@ src_unpack() {
src_compile() {
cd ${S}
- LDFLAGS="-lpng" try ./configure --host=${CHOST} --prefix=/usr
+ LDFLAGS="-lpng" try ./configure --host=${CHOST} --prefix=/usr \
+ --sysconfdir=/etc/httpd
try make
}
@@ -36,8 +38,8 @@ src_install() {
dobin webalizer
doman webalizer.1
insinto /etc/httpd
- cp sample.conf webalizer.conf
- doins webalizer.conf
+ doins ${FILESDIR}/webalizer.conf
+ doins ${FILESDIR}/httpd.webalizer
dodoc README* CHANGES COPYING Copyright
}