summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-11-20 15:41:44 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-11-20 15:41:44 +0000
commit3fb431c0d8cc15c27185685f36a5dccb9e9a05fc (patch)
treec54ae659b7c7cdce0df84d9998abdbd08c668d93 /app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild
parentVersion bump; updates binfmt_elf patch (bug #70681) and adds the smbfs securi... (diff)
downloadgentoo-2-3fb431c0d8cc15c27185685f36a5dccb9e9a05fc.tar.gz
gentoo-2-3fb431c0d8cc15c27185685f36a5dccb9e9a05fc.tar.bz2
gentoo-2-3fb431c0d8cc15c27185685f36a5dccb9e9a05fc.zip
Initial import.
Diffstat (limited to 'app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild')
-rw-r--r--app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild b/app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild
new file mode 100644
index 000000000000..857e56d8c801
--- /dev/null
+++ b/app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/bitdefender-console/bitdefender-console-7.0.1.ebuild,v 1.1 2004/11/20 15:41:44 ticho Exp $
+
+inherit rpm
+
+DESCRIPTION="Complete virus defense solution designed for easy virus prevention on Linux systems."
+HOMEPAGE="http://www.bitdefender.com/bd/site/products.php?p_id=16"
+SRC_URI="ftp://ftp.bitdefender.com/pub/linux/free/bitdefender-console/en/BitDefender-Console-Antivirus-${PV}-3.linux-gcc3x.i586.rpm"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/rpm2targz"
+
+src_unpack() {
+ rpm_src_unpack ${DISTDIR}/${A} || die "Could not unpack RPM package"
+}
+
+src_install() {
+ dodir /opt/bdc
+ cp -Rf ${WORKDIR}/opt/* ${D}/opt
+
+ # Create a symlink for bdc executable
+ dodir /usr/bin
+ dosym /opt/bdc/bdc /usr/bin/bdc
+
+ # Install manpage correctly and remove it from /opt, where it's
+ # useless
+ doman ${WORKDIR}/opt/bdc/man/bdc.1
+ rm -rf ${D}/opt/bdc/man
+}
+