summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-02-14 14:49:33 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-02-14 14:49:33 +0000
commit5dbaea227c3ab5b279c94ddd46ff473ff411a5b9 (patch)
treef63a605db91f445566b307ffaf42f53adb3c5837 /app-antivirus
parentreadded this old version as it can become handy over a SSH connection with X;... (diff)
downloadgentoo-2-5dbaea227c3ab5b279c94ddd46ff473ff411a5b9.tar.gz
gentoo-2-5dbaea227c3ab5b279c94ddd46ff473ff411a5b9.tar.bz2
gentoo-2-5dbaea227c3ab5b279c94ddd46ff473ff411a5b9.zip
Version bump. Add bzip2, curl, gmp USE flags to control dependencies some more. Remove the rc3 ebuild.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog9
-rw-r--r--app-antivirus/clamav/clamav-0.90.ebuild (renamed from app-antivirus/clamav/clamav-0.90_rc3.ebuild)49
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.903
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.90_rc33
4 files changed, 46 insertions, 18 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 49ee5bbd5bdc..20bd26ad5949 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.197 2007/02/04 18:07:56 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.198 2007/02/14 14:49:33 ticho Exp $
+
+*clamav-0.90 (14 Feb 2007)
+
+ 14 Feb 2007; Andrej Kacian <ticho@gentoo.org> -clamav-0.90_rc3.ebuild,
+ +clamav-0.90.ebuild:
+ Version bump. Add bzip2, curl, gmp USE flags to control dependencies some
+ more. Remove the rc3 ebuild.
04 Feb 2007; Andrej Kacian <ticho@gentoo.org> -clamav-0.90_rc1.ebuild,
-clamav-0.90_rc2.ebuild:
diff --git a/app-antivirus/clamav/clamav-0.90_rc3.ebuild b/app-antivirus/clamav/clamav-0.90.ebuild
index 05006b802577..b04e347579d2 100644
--- a/app-antivirus/clamav/clamav-0.90_rc3.ebuild
+++ b/app-antivirus/clamav/clamav-0.90.ebuild
@@ -1,32 +1,33 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.90_rc3.ebuild,v 1.1 2007/02/01 18:08:25 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.90.ebuild,v 1.1 2007/02/14 14:49:33 ticho Exp $
inherit eutils flag-o-matic fixheadtails
-MY_P="${P/_/}"
DESCRIPTION="Clam Anti-Virus Scanner"
HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="crypt milter selinux mailwrapper"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 crypt curl gmp logrotate mailwrapper milter onaccess selinux"
DEPEND="virtual/libc
+ bzip2? ( app-arch/bzip2 )
crypt? ( >=dev-libs/gmp-4.1.2 )
+ curl? ( >=net-misc/curl-7.10.0 )
+ gmp? ( dev-libs/gmp )
milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ onaccess? ( sys-fs/dazuko )
>=sys-libs/zlib-1.2.1-r3
- >=net-misc/curl-7.10.0
>=sys-apps/sed-4"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-clamav )
+ logrotate? ( app-admin/logrotate )
sys-apps/grep"
PROVIDE="virtual/antivirus"
-S="${WORKDIR}/${MY_P}"
-
pkg_setup() {
if use milter; then
if [ ! -e /usr/lib/libmilter.a ] ; then
@@ -36,6 +37,11 @@ pkg_setup() {
die "need milter-enabled sendmail"
fi
fi
+ if use onaccess ; then
+ echo
+ ewarn "Warning: On access scan support is experimental, use at your own risk!"
+ echo
+ fi
enewgroup clamav
enewuser clamav -1 -1 /dev/null clamav
}
@@ -58,7 +64,11 @@ src_compile() {
ht_fix_file configure
econf ${myconf} \
- --enable-experimental \
+ $(use_enable bzip2) \
+ $(use_with curl libcurl) \
+ $(use_enable gmp dsig) \
+ $(use_enable onaccess clamuko) \
+ --disable-experimental \
--with-dbdir=/var/lib/clamav || die
emake || die
}
@@ -91,6 +101,7 @@ src_install() {
-e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
-e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-e "s:^\#\(UpdateLogFile\) .*:\1 /var/log/clamav/freshclam.log:" \
+ -e "s:^\#\(NotifyClamd\).*:\1 /etc/clamd.conf:" \
${D}/etc/freshclam.conf
if use milter ; then
@@ -101,20 +112,30 @@ src_install() {
echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
>>${D}/etc/conf.d/clamd
fi
+
+ if use onaccess ; then
+ dodir /etc/udev/rules.d
+ echo "KERNEL==\"dazuko\", NAME=\"%k\", GROUP=\"clamav\", MODE=\"0660\"" \
+ >${D}/etc/udev/rules.d/60-dazuko.rules
+ fi
+
+ if use logrotate ; then
+ diropts ""
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/${PN}.logrotate ${PN}
+ fi
}
pkg_postinst() {
echo
ewarn "Warning: clamd and/or freshclam have not been restarted."
- ewarn "You should restart them with: /etc/init.d/clamd restart"
+ ewarn "You should restart them to start using new version: /etc/init.d/clamd restart"
echo
if use milter ; then
elog "For simple instructions how to setup the clamav-milter"
elog "read /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
echo
fi
- ewarn "This is a RELEASE CANDIDATE version, with EXPERIMENTAL code ENABLED."
- ewarn "USE AT YOUR OWN RISK. Report bugs at http://bugs.clamav.net"
- echo
- ebeep 3
}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.90 b/app-antivirus/clamav/files/digest-clamav-0.90
new file mode 100644
index 000000000000..e4c17f0e55f9
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.90
@@ -0,0 +1,3 @@
+MD5 f04372e49c3c5ff3bd94bbe1fef2eaca clamav-0.90.tar.gz 11575374
+RMD160 1b22144d3a41376093b73bbeb5302092a18ca685 clamav-0.90.tar.gz 11575374
+SHA256 c39005318d4a7d27d9710c3d71396b8c500e0bc5a184cb7392051c9ca9dea60d clamav-0.90.tar.gz 11575374
diff --git a/app-antivirus/clamav/files/digest-clamav-0.90_rc3 b/app-antivirus/clamav/files/digest-clamav-0.90_rc3
deleted file mode 100644
index c80b075dc78e..000000000000
--- a/app-antivirus/clamav/files/digest-clamav-0.90_rc3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5af2bdbbb255829dd590609d900c1854 clamav-0.90rc3.tar.gz 10784835
-RMD160 24e66ec3352c7e1007cddea278cba161d0fb4e3d clamav-0.90rc3.tar.gz 10784835
-SHA256 aba20f98453affeeb60427bdd432b7c5a5115f17aa2734cf1393c750f95d66ad clamav-0.90rc3.tar.gz 10784835