summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-08-07 23:45:49 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-08-07 23:45:49 +0000
commit6e754a5f4c767509162d2b6085c9fac088f93d44 (patch)
treef5e05ad272afeb41128541db50be27e13aca60a2 /app-antivirus
parentMarking stable amd64, sparc (diff)
downloadgentoo-2-6e754a5f4c767509162d2b6085c9fac088f93d44.tar.gz
gentoo-2-6e754a5f4c767509162d2b6085c9fac088f93d44.tar.bz2
gentoo-2-6e754a5f4c767509162d2b6085c9fac088f93d44.zip
Version bump. Fixes vulnerability in security bug #143093.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.88.4.ebuild112
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.88.43
3 files changed, 121 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 2b88a9827728..5ca11c5b16a5 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.156 2006/08/06 02:09:31 nigoro Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.157 2006/08/07 23:45:49 ticho Exp $
+
+*clamav-0.88.4 (07 Aug 2006)
+
+ 07 Aug 2006; Andrej Kacian <ticho@gentoo.org> +clamav-0.88.4.ebuild:
+ Version bump. Fixes vulnerability in security bug #143093.
06 Aug 2006; Yuta SATOH <nigoro@gentoo.org> clamav-0.88.3.ebuild:
Stable on ppc64, bug #141539
diff --git a/app-antivirus/clamav/clamav-0.88.4.ebuild b/app-antivirus/clamav/clamav-0.88.4.ebuild
new file mode 100644
index 000000000000..5a8e3e1190ad
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.88.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.88.4.ebuild,v 1.1 2006/08/07 23:45:49 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="http://mirror.clamav.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt milter selinux mailwrapper"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( mail-mta/sendmail )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions how to setup the clamav-milter type:"
+ echo " zless /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.88.4 b/app-antivirus/clamav/files/digest-clamav-0.88.4
new file mode 100644
index 000000000000..a5b2f0480d00
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.88.4
@@ -0,0 +1,3 @@
+MD5 7759784aa4506b314e6543e0f2a8587b clamav-0.88.4.tar.gz 7632947
+RMD160 efa419598c7d6deae53bf9c0f40a4c2912433228 clamav-0.88.4.tar.gz 7632947
+SHA256 a581f2f7c93fac9e7a4caf5c1f15f5e7722a4739aaaa3f07dd9076e1097d157f clamav-0.88.4.tar.gz 7632947