summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2008-04-15 13:55:39 +0000
committerRaphaël Marichez <falco@gentoo.org>2008-04-15 13:55:39 +0000
commitc3585c81e5ede60b8ea064b837e1e5880a2343b0 (patch)
treee03ab4a95accd28454179fcea75cc6716a372017 /app-antivirus
parentSparc stable, security Bug #217715. (diff)
downloadgentoo-2-c3585c81e5ede60b8ea064b837e1e5880a2343b0.tar.gz
gentoo-2-c3585c81e5ede60b8ea064b837e1e5880a2343b0.tar.bz2
gentoo-2-c3585c81e5ede60b8ea064b837e1e5880a2343b0.zip
Security bump, bug 213762 and add -I m4 in aclocal
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog8
-rw-r--r--app-antivirus/clamav/clamav-0.93.ebuild141
-rw-r--r--app-antivirus/clamav/files/clamav-0.93-nls.patch73
3 files changed, 221 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 9f0b29c89832..91a338750a68 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.282 2008/02/29 23:46:46 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.283 2008/04/15 13:55:39 falco Exp $
+
+*clamav-0.93 (15 Apr 2008)
+
+ 15 Apr 2008; Raphael Marichez <falco@gentoo.org>
+ +files/clamav-0.93-nls.patch, +clamav-0.93.ebuild:
+ Security bump, bug #213762 and add -I m4 in aclocal
*clamav-0.92.1-r1 (29 Feb 2008)
diff --git a/app-antivirus/clamav/clamav-0.93.ebuild b/app-antivirus/clamav/clamav-0.93.ebuild
new file mode 100644
index 000000000000..d9a8a65ecf70
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.93.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.93.ebuild,v 1.1 2008/04/15 13:55:39 falco Exp $
+
+inherit autotools eutils flag-o-matic fixheadtails multilib
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 crypt mailwrapper milter nls selinux"
+
+DEPEND="virtual/libc
+ bzip2? ( app-arch/bzip2 )
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ nls? ( sys-devel/gettext )
+ dev-libs/gmp
+ >=sys-libs/zlib-1.2.1-r3
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/$(get_libdir)/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag, or mail-filter/libmilter package."
+ fi
+ fi
+
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.93-nls.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} \
+ $(use_enable bzip2) \
+ $(use_enable nls) \
+ --disable-experimental \
+ --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ
+ newconfd "${FILESDIR}"/clamd.conf clamd
+ newinitd "${FILESDIR}"/clamd.rc clamd
+ dodoc "${FILESDIR}"/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${D}"/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(UpdateLogFile\) .*:\1 /var/log/clamav/freshclam.log:" \
+ -e "s:^\#\(NotifyClamd\).*:\1 /etc/clamd.conf:" \
+ -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${D}"/etc/freshclam.conf
+
+ if use milter ; then
+ echo "
+START_MILTER=no
+MILTER_NICELEVEL=19" \
+ >> "${D}"/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>"${D}"/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>"${D}"/etc/conf.d/clamd
+ fi
+
+ diropts ""
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ echo
+ if use milter ; then
+ elog "For simple instructions how to setup the clamav-milter"
+ elog "read /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+ ewarn "WARNING: In 0.92.1, the logic in the scanner limits have been reworked. This"
+ ewarn "results in different command line options to clamscan, different config"
+ ewarn "options to clamd and, overall, a different behaviour."
+ echo
+ ewarn "The soname for libclamav has changed in clamav-0.92."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run:"
+ ewarn "\trevdep-rebuild --library libclamav.so.2"
+ ewarn "This will fix linking errors caused by this change."
+ echo
+}
diff --git a/app-antivirus/clamav/files/clamav-0.93-nls.patch b/app-antivirus/clamav/files/clamav-0.93-nls.patch
new file mode 100644
index 000000000000..f082c636d06a
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.93-nls.patch
@@ -0,0 +1,73 @@
+diff -uNr -r clamav-0.93.orig/clamav-milter/clamav-milter.c clamav-0.93/clamav-milter/clamav-milter.c
+--- clamav-0.93.orig/clamav-milter/clamav-milter.c 2008-04-09 17:39:18.000000000 +0200
++++ clamav-0.93/clamav-milter/clamav-milter.c 2008-04-15 14:59:23.235003488 +0200
+@@ -110,6 +110,7 @@
+
+ #ifdef C_LINUX
+ #include <sys/sendfile.h> /* FIXME: use sendfile on BSD not Linux */
++#ifdef ENABLE_NLS
+ #include <libintl.h>
+ #include <locale.h>
+
+@@ -122,7 +123,8 @@
+ #define _(s) s
+ #define N_(s) s
+
+-#endif
++#endif /* ENABLE_NLS */
++#endif /* C_LINUX */
+
+ #ifdef USE_SYSLOG
+ #include <syslog.h>
+@@ -713,7 +715,7 @@
+ else
+ progname = "clamav-milter";
+
+-#ifdef C_LINUX
++#ifdef ENABLE_NLS
+ setlocale(LC_ALL, "");
+ bindtextdomain(progname, DATADIR"/clamav-milter/locale");
+ textdomain(progname);
+diff -uNr -r clamav-0.93.orig/configure.in clamav-0.93/configure.in
+--- clamav-0.93.orig/configure.in 2008-04-09 17:40:33.000000000 +0200
++++ clamav-0.93/configure.in 2008-04-15 15:03:43.391218848 +0200
+@@ -399,6 +399,15 @@
+ [ --disable-unrar don't build libclamunrar and libclamunrar_iface ],
+ want_unrar=$enableval, want_unrar="yes")
+
++AC_ARG_ENABLE(nls,
++ AC_HELP_STRING([--disable-nls], [disable nls support]),
++ [want_nls=$enableval], [want_nls=yes]
++)
++
++if test $want_nls = yes; then
++ CPPFLAGS="$CPPFLAGS -DENABLE_NLS"
++fi
++
+ AC_ARG_ENABLE([dns],
+ AC_HELP_STRING([--disable-dns], [disable support for database verification through DNS]),
+ [want_dns=$enableval], [want_dns=yes]
+diff -uNr -r clamav-0.93.orig/shared/getopt.c clamav-0.93/shared/getopt.c
+--- clamav-0.93.orig/shared/getopt.c 2008-03-06 19:41:02.000000000 +0100
++++ clamav-0.93/shared/getopt.c 2008-04-15 15:00:51.885713837 +0200
+@@ -82,7 +82,7 @@
+
+ #ifndef _
+ /* This is for other GNU distributions with internationalized messages. */
+-# if defined HAVE_LIBINTL_H || defined _LIBC
++# if (defined(HAVE_LIBINTL_H) || defined(_LIBC)) && defined(ENABLE_NLS)
+ # include <libintl.h>
+ # ifndef _
+ # define _(msgid) gettext (msgid)
+diff -uNr -r clamav-0.93.orig/shared/output.c clamav-0.93/shared/output.c
+--- clamav-0.93.orig/shared/output.c 2008-03-06 19:41:02.000000000 +0100
++++ clamav-0.93/shared/output.c 2008-04-15 15:00:51.885713837 +0200
+@@ -61,7 +61,7 @@
+ pthread_mutex_t logg_mutex = PTHREAD_MUTEX_INITIALIZER;
+ #endif
+
+-#ifdef C_LINUX
++#if defined(C_LINUX) && defined(ENABLE_NLS)
+ #include <libintl.h>
+ #include <locale.h>
+