summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-17 06:50:49 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-17 06:50:49 +0000
commit991ff06b4b40b71562d439c721c28098e033c92b (patch)
tree27a12826eeae26d8e19f18acd4646ee48539ec48 /app-arch/arc
parentAdd use-deps for libsdl (diff)
downloadgentoo-2-991ff06b4b40b71562d439c721c28098e033c92b.tar.gz
gentoo-2-991ff06b4b40b71562d439c721c28098e033c92b.tar.bz2
gentoo-2-991ff06b4b40b71562d439c721c28098e033c92b.zip
Add prefix patches, keywords (from overlay)
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-arch/arc')
-rw-r--r--app-arch/arc/ChangeLog9
-rw-r--r--app-arch/arc/arc-5.21o.ebuild8
-rw-r--r--app-arch/arc/files/arc-5.21m-darwin.patch11
-rw-r--r--app-arch/arc/files/arc-5.21o-interix.patch12
4 files changed, 35 insertions, 5 deletions
diff --git a/app-arch/arc/ChangeLog b/app-arch/arc/ChangeLog
index 0b2b1eb34604..41a68200eec6 100644
--- a/app-arch/arc/ChangeLog
+++ b/app-arch/arc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/arc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/ChangeLog,v 1.34 2008/05/13 14:12:31 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/ChangeLog,v 1.35 2010/02/17 06:50:49 abcd Exp $
+
+ 17 Feb 2010; Jonathan Callen <abcd@gentoo.org>
+ +files/arc-5.21m-darwin.patch, arc-5.21o.ebuild,
+ +files/arc-5.21o-interix.patch:
+ Add prefix patches, keywords (from overlay)
13 May 2008; Jeroen Roovers <jer@gentoo.org> arc-5.21o.ebuild:
Stable for HPPA (LuckyLuke).
diff --git a/app-arch/arc/arc-5.21o.ebuild b/app-arch/arc/arc-5.21o.ebuild
index 18385a680e6a..56bf655ed964 100644
--- a/app-arch/arc/arc-5.21o.ebuild
+++ b/app-arch/arc/arc-5.21o.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/arc-5.21o.ebuild,v 1.6 2008/05/13 14:12:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/arc-5.21o.ebuild,v 1.7 2010/02/17 06:50:49 abcd Exp $
inherit eutils toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE=""
DEPEND=""
@@ -18,7 +18,9 @@ DEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P/o/m}-darwin.patch
epatch "${FILESDIR}"/${P/o/m}-gentoo-fbsd.patch
+ epatch "${FILESDIR}"/${P}-interix.patch
sed -i -e 's/CFLAGS = $(OPT) $(SYSTEM)/CFLAGS += $(SYSTEM)/' Makefile
}
diff --git a/app-arch/arc/files/arc-5.21m-darwin.patch b/app-arch/arc/files/arc-5.21m-darwin.patch
new file mode 100644
index 000000000000..fb1eb5ea2598
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21m-darwin.patch
@@ -0,0 +1,11 @@
+--- arc-5.21m/tmclock.c
++++ arc-5.21m/tmclock.c
+@@ -14,7 +14,7 @@
+ /* Julian day number of the Unix* clock's origin, 01 Jan 1970. */
+ #define JD1970 2440587L
+ #define CENTURY 19
+-#if BSD
++#if BSD || defined(__MACH_O__)
+ #include <sys/time.h>
+ #else
+ #include <time.h>
diff --git a/app-arch/arc/files/arc-5.21o-interix.patch b/app-arch/arc/files/arc-5.21o-interix.patch
new file mode 100644
index 000000000000..f95aee85e37d
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21o-interix.patch
@@ -0,0 +1,12 @@
+diff -ru arc-5.21o.orig/arcdos.c arc-5.21o/arcdos.c
+--- arc-5.21o.orig/arcdos.c 2008-03-30 15:44:53 +0200
++++ arc-5.21o/arcdos.c 2008-03-30 15:45:51 +0200
+@@ -30,7 +30,7 @@
+ #if UNIX
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#if BSD
++#if BSD || defined(__INTERIX)
+ #include <sys/time.h>
+ #else
+ #include <time.h> /* Sys V. Bleah. */