summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-15 15:17:50 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-15 15:17:50 +0000
commita9ac12bd4839db8ae9bb2adffa8f1d4a0cf5e0d7 (patch)
treed218f10041dc46d7a8b69edee54c798dddb53834 /app-arch/bsdtar
parentInitial commit. Bug #173241, by fabien Zouaoui <fabien at zouaoui.org>. (diff)
downloadgentoo-2-a9ac12bd4839db8ae9bb2adffa8f1d4a0cf5e0d7.tar.gz
gentoo-2-a9ac12bd4839db8ae9bb2adffa8f1d4a0cf5e0d7.tar.bz2
gentoo-2-a9ac12bd4839db8ae9bb2adffa8f1d4a0cf5e0d7.zip
Version bump (thx to Flameeyes for reporting on irc)
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-arch/bsdtar')
-rw-r--r--app-arch/bsdtar/ChangeLog7
-rw-r--r--app-arch/bsdtar/bsdtar-2.0.31.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.0.313
3 files changed, 91 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 7689dae53570..1c7164269785 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.61 2007/04/07 17:30:23 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.62 2007/04/15 15:17:50 drizzt Exp $
+
+*bsdtar-2.0.31 (15 Apr 2007)
+
+ 15 Apr 2007; Timothy Redaelli <drizzt@gentoo.org> +bsdtar-2.0.31.ebuild:
+ Version bump (thx to Flameeyes for reporting on irc)
*bsdtar-2.0.28 (07 Apr 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.0.31.ebuild b/app-arch/bsdtar/bsdtar-2.0.31.ebuild
new file mode 100644
index 000000000000..8a2f26666503
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-2.0.31.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.0.31.ebuild,v 1.1 2007/04/15 15:17:50 drizzt Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="libarchive-${PV/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libarchive-1.3.1-static.patch
+ epatch "${FILESDIR}"/libarchive-2.0b6-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.0.31 b/app-arch/bsdtar/files/digest-bsdtar-2.0.31
new file mode 100644
index 000000000000..c5e9a33ad776
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.0.31
@@ -0,0 +1,3 @@
+MD5 356c85b7efa53b0fefb9aec0f5855b45 libarchive-2.0.31.tar.gz 602844
+RMD160 11a67ff388a02cf2d570df1a0576ead91570e6b6 libarchive-2.0.31.tar.gz 602844
+SHA256 ee661b2c5ef7e19930834e047acd247f83d019af46ded1c7016bf747b0eeb9df libarchive-2.0.31.tar.gz 602844