summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-06 04:17:46 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-06 04:17:46 +0000
commit0012966f45342e7afb87d0ff246ef1491487f15e (patch)
tree465a95f87ff2d62d6cbaf955f32c7aefd6f422a2 /app-arch/cpio
parentVersion bump. (diff)
downloadgentoo-2-0012966f45342e7afb87d0ff246ef1491487f15e.tar.gz
gentoo-2-0012966f45342e7afb87d0ff246ef1491487f15e.tar.bz2
gentoo-2-0012966f45342e7afb87d0ff246ef1491487f15e.zip
Fix building with glibc-2.16 #424974 by Stevan Bajić.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/cpio')
-rw-r--r--app-arch/cpio/ChangeLog6
-rw-r--r--app-arch/cpio/cpio-2.11.ebuild3
-rw-r--r--app-arch/cpio/files/cpio-2.11-no-gets.patch24
3 files changed, 31 insertions, 2 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 0d66eff18d63..b8a49941fa27 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/cpio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.115 2012/04/26 12:29:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.116 2012/07/06 04:17:46 vapier Exp $
+
+ 06 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/cpio-2.11-no-gets.patch, cpio-2.11.ebuild:
+ Fix building with glibc-2.16 #424974 by Stevan Bajić.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> cpio-2.11.ebuild:
keyword ~amd64-fbsd
diff --git a/app-arch/cpio/cpio-2.11.ebuild b/app-arch/cpio/cpio-2.11.ebuild
index ed40d25fd600..7e5d9081bf9f 100644
--- a/app-arch/cpio/cpio-2.11.ebuild
+++ b/app-arch/cpio/cpio-2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.11.ebuild,v 1.9 2012/04/26 12:29:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.11.ebuild,v 1.10 2012/07/06 04:17:46 vapier Exp $
EAPI="2"
@@ -17,6 +17,7 @@ IUSE="nls"
src_prepare() {
epatch "${FILESDIR}"/${P}-stat.patch #328531
+ epatch "${FILESDIR}"/${P}-no-gets.patch #424974
}
src_configure() {
diff --git a/app-arch/cpio/files/cpio-2.11-no-gets.patch b/app-arch/cpio/files/cpio-2.11-no-gets.patch
new file mode 100644
index 000000000000..f7a9be324df4
--- /dev/null
+++ b/app-arch/cpio/files/cpio-2.11-no-gets.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/424974
+
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/gnu/stdio.in.h
++++ b/gnu/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@