summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-05-23 08:01:26 +0000
committerPeter Volkov <pva@gentoo.org>2011-05-23 08:01:26 +0000
commit1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e (patch)
tree99009ed77ae4ec7b7ed5375074d7fd8e3220ab4e /app-arch/dump/files
parentFix libutp related build issue, bug #368187 thank thomasg for this fix. Drop ... (diff)
downloadgentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.tar.gz
gentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.tar.bz2
gentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.zip
Version bump. Fixes build with USE=static. Fixes dodoc called on a directory, #367885 thank Diego Elio Pettenò for report.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/dump/files')
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch27
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch50
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch40
3 files changed, 117 insertions, 0 deletions
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch
new file mode 100644
index 000000000000..ad109189ea31
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch
@@ -0,0 +1,27 @@
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 04:40:59 +0000
++++ configure.in 2011-05-20 05:12:18 +0000
+@@ -465,11 +465,17 @@
+ dnl Check for blkid headers libraries
+ dnl
+ AC_CHECK_HEADER(blkid/blkid.h, [blkid_h=yes], [blkid_h=no], [-])
+-AC_CHECK_LIB(blkid, blkid_get_devname, [blkid_lib=yes], [blkid_lib=no], [-luuid])
+-if test "$blkid_h" = yes -a "$blkid_lib" = yes; then
+- AC_DEFINE([HAVE_BLKID],1,[Define this if you have the blkid library.])
+- BLKID="-lblkid -luuid"
+-fi
++PKG_CHECK_EXISTS([blkid],
++ [
++ if test -n $STATIC ; then
++ BLKID=`$PKG_CONFIG --libs --static blkid`
++ else
++ BLKID=`$PKG_CONFIG --libs blkid`
++ fi
++ if test "$blkid_h" = yes ; then
++ AC_DEFINE([HAVE_BLKID],1,[Define this if you have the blkid library.])
++ fi
++ ],[BLKID=""])
+ AC_SUBST(BLKID)
+
+ dnl
+
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch
new file mode 100644
index 000000000000..d126cf150039
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch
@@ -0,0 +1,50 @@
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 09:47:25 +0000
++++ configure.in 2011-05-20 09:51:37 +0000
+@@ -113,7 +113,6 @@
+ if test "$enableval" = "no"
+ then
+ ERMT=""
+- CRYPTO=""
+ echo "Not compiling ermt"
+ else
+ if test "$RMTDIR" = ""
+@@ -121,16 +120,13 @@
+ AC_MSG_ERROR(ermt requires --enable-rmt)
+ fi
+ ERMT="ermt"
+- CRYPTO="-lcrypto"
+ echo "Compiling ermt"
+ fi
+ ,
+ ERMT=""
+-CRYPTO=""
+ echo "Not compiling ermt by default"
+ )
+ AC_SUBST(ERMT)
+-AC_SUBST(CRYPTO)
+
+ dnl
+ dnl Handle --enable-kerberos
+@@ -600,10 +596,19 @@
+ if test "$ERMT" != ""; then
+ AC_CHECK_HEADER(openssl/evp.h, [evp_h=yes], [evp_h=no])
+ AC_CHECK_LIB(crypto, EVP_CIPHER_CTX_set_padding, [crypto_lib=yes], [crypto_lib=no])
+- if test "$evp_h" = no -o "$crypto_lib" = no; then
++ PKG_CHECK_EXISTS([libcrypto],
++ [
++ if test -n $STATIC ; then
++ CRYPTO=`$PKG_CONFIG --libs --static libcrypto`
++ else
++ CRYPTO=`$PKG_CONFIG --libs libcrypto`
++ fi
++ ],[CRYPTO=""])
++ if test "$evp_h" = no -o "x$CRYPTO" = "x"; then
+ AC_MSG_ERROR(You need to install the OpenSSL library (version 0.9.7a or later), or configure without --enable-ermt)
+ fi
+ fi
++AC_SUBST(CRYPTO)
+
+ dnl
+ dnl Check for types
+
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch
new file mode 100644
index 000000000000..11ccab9ca20d
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch
@@ -0,0 +1,40 @@
+=== modified file 'MCONFIG.in'
+--- MCONFIG.in 2011-05-20 04:40:59 +0000
++++ MCONFIG.in 2011-05-20 06:57:11 +0000
+@@ -32,7 +32,7 @@
+ GINC= -I$(top_builddir) -I$(top_srcdir)/compat/include
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+-#GINC+= -I/usr/src/e2fsprogs-0.5c/lib
++GINC+= @EXT2FS_CFLAGS@
+
+ #
+ # Global libraries
+@@ -40,7 +40,7 @@
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+ #GLIBDIR= -L/usr/src/e2fsprogs-0.5c/lib
+-GLIBS= $(GLIBDIR) -L../compat/lib -lcompat -lext2fs -lcom_err
++GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@
+
+ #
+ # Definitions (don't change them unless you know what you are doing)
+
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 05:16:23 +0000
++++ configure.in 2011-05-20 07:01:17 +0000
+@@ -411,8 +411,11 @@
+ dnl Check for Ext2fs headers and libraries
+ dnl
+ AC_CHECK_HEADER(ext2fs/ext2fs.h, [ext2fs_h=yes], [ext2fs_h=no], [-])
+-AC_CHECK_LIB(ext2fs, ext2fs_open, [ext2fs_lib=yes], [ext2fs_lib=no], [-lcom_err])
+-if test "$ext2fs_h" = no -o "$ext2fs_lib" = no; then
++PKG_CHECK_MODULES(EXT2FS, [ext2fs])
++if test -n "$STATIC" ; then
++ EXT2FS_LIBS=`$PKG_CONFIG --libs --static ext2fs`
++fi
++if test "$ext2fs_h" = no -o "x$EXT2FS_LIBS" = "x"; then
+ AC_MSG_ERROR(You need to install the Ext2fs libraries from the E2fsprogs distribution first - hint: make install-libs)
+ fi
+
+