summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-07 11:55:08 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-07 11:55:08 +0000
commit92f7b9e893800c4bc85ce5c9fcb63f3ff64d8286 (patch)
tree37ef7c4a83e0f546d33106fda4e0e118ad659639 /app-arch/lbzip2
parentFix compilation problems with debian patches, bug #423009. (diff)
downloadgentoo-2-92f7b9e893800c4bc85ce5c9fcb63f3ff64d8286.tar.gz
gentoo-2-92f7b9e893800c4bc85ce5c9fcb63f3ff64d8286.tar.bz2
gentoo-2-92f7b9e893800c4bc85ce5c9fcb63f3ff64d8286.zip
app-arch/lbzip2: Block other packages installing the /usr/bin/bzip2 symlink, #436354; drop old
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/ChangeLog6
-rw-r--r--app-arch/lbzip2/lbzip2-0.23-r2.ebuild60
-rw-r--r--app-arch/lbzip2/lbzip2-2.1-r2.ebuild31
-rw-r--r--app-arch/lbzip2/lbzip2-2.1.ebuild29
-rw-r--r--app-arch/lbzip2/lbzip2-2.2.ebuild5
5 files changed, 9 insertions, 122 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index 262116ce24fa..671a03b6090a 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.39 2012/09/30 16:56:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.40 2012/10/07 11:55:08 jlec Exp $
+
+ 07 Oct 2012; Justin Lecher <jlec@gentoo.org> -lbzip2-0.23-r2.ebuild,
+ -lbzip2-2.1.ebuild, -lbzip2-2.1-r2.ebuild, lbzip2-2.2.ebuild:
+ Block other packages installing the /usr/bin/bzip2 symlink, #436354; drop old
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> lbzip2-2.2.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #435228
diff --git a/app-arch/lbzip2/lbzip2-0.23-r2.ebuild b/app-arch/lbzip2/lbzip2-0.23-r2.ebuild
deleted file mode 100644
index f3802aa87e78..000000000000
--- a/app-arch/lbzip2/lbzip2-0.23-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23-r2.ebuild,v 1.10 2012/02/14 21:25:31 jer Exp $
-
-EAPI="3"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Parallel bzip2 utility"
-HOMEPAGE="http://lacos.hu/"
-SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="symlink test"
-
-RDEPEND="app-arch/bzip2"
-DEPEND="${REDEPEND}
- test? (
- app-shells/bash
- sys-devel/bc
- || ( sys-process/time sys-freebsd/freebsd-ubin )
- )"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/0.23-s_isreg.patch
- epatch "${FILESDIR}"/0.23-Makefile.patch
- epatch "${FILESDIR}"/0.23-test.sh.patch
-}
-
-src_compile() {
- append-lfs-flags
- emake CC=$(tc-getCC) || die "emake failed"
-}
-
-src_test() {
- if [ -t 0 ] || return; then
- rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
- hexdump -n 10485760 /dev/urandom > "${T}/rnd"
- emake -j1 SHELL="${EPREFIX}/bin/bash --posix" PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
- || die "make check failed"
- else
- ewarn "make check must be run attached to a terminal"
- fi
-}
-
-src_install() {
- dobin ${PN} || die "Installation of ${PN} failed"
- dodoc ChangeLog README || die "no docs"
- doman ${PN}.1 || die "no man"
- insinto /usr/share/${PN}
- doins corr-perf.sh malloc_trace.pl || die
-
- if use symlink; then
- dosym ${PN} /usr/bin/bzip2 || die
- fi
-}
diff --git a/app-arch/lbzip2/lbzip2-2.1-r2.ebuild b/app-arch/lbzip2/lbzip2-2.1-r2.ebuild
deleted file mode 100644
index 80247c9bba9c..000000000000
--- a/app-arch/lbzip2/lbzip2-2.1-r2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.1-r2.ebuild,v 1.1 2011/12/05 19:42:45 jlec Exp $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Parallel bzip2 utility"
-HOMEPAGE="https://github.com/kjn/lbzip2/"
-SRC_URI="mirror://github/kjn/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="symlink"
-
-src_prepare() {
- cd src
- epatch \
- "${FILESDIR}"/0.23-s_isreg.patch \
- "${FILESDIR}"/${PV}-crc-missmatch.patch
-}
-
-src_install() {
- default
-
- if use symlink; then
- dosym ${PN} /usr/bin/bzip2
- fi
-}
diff --git a/app-arch/lbzip2/lbzip2-2.1.ebuild b/app-arch/lbzip2/lbzip2-2.1.ebuild
deleted file mode 100644
index 94706ec91f56..000000000000
--- a/app-arch/lbzip2/lbzip2-2.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.1.ebuild,v 1.2 2011/11/28 10:25:37 jlec Exp $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Parallel bzip2 utility"
-HOMEPAGE="https://github.com/kjn/lbzip2/"
-SRC_URI="mirror://github/kjn/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="symlink"
-
-src_prepare() {
- cd src
- epatch "${FILESDIR}"/0.23-s_isreg.patch
-}
-
-src_install() {
- default
-
- if use symlink; then
- dosym ${PN} /usr/bin/bzip2
- fi
-}
diff --git a/app-arch/lbzip2/lbzip2-2.2.ebuild b/app-arch/lbzip2/lbzip2-2.2.ebuild
index dba198e8e842..3d054cc45b4d 100644
--- a/app-arch/lbzip2/lbzip2-2.2.ebuild
+++ b/app-arch/lbzip2/lbzip2-2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.2.ebuild,v 1.8 2012/09/30 16:56:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.2.ebuild,v 1.9 2012/10/07 11:55:08 jlec Exp $
EAPI=4
@@ -17,6 +17,9 @@ IUSE="debug symlink"
PATCHES=( "${FILESDIR}"/${P}-s_isreg.patch )
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
src_configure() {
local myeconfargs=(
--disable-silent-rules