summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-20 14:21:32 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-20 14:21:32 +0000
commit7bb14a559613bab6eb31b44b5a0d7fcd87689b5a (patch)
tree65b78e6d9124bbeb08db71dafeb038d8b9588686 /app-arch/libzpaq
parentFix desktop-integration.patch, thanks Balint SZENTE (bug 477490) (diff)
downloadgentoo-2-7bb14a559613bab6eb31b44b5a0d7fcd87689b5a.tar.gz
gentoo-2-7bb14a559613bab6eb31b44b5a0d7fcd87689b5a.tar.bz2
gentoo-2-7bb14a559613bab6eb31b44b5a0d7fcd87689b5a.zip
Version bump. Increase EAPI and introduce sub-slot for SONAME.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'app-arch/libzpaq')
-rw-r--r--app-arch/libzpaq/ChangeLog9
-rw-r--r--app-arch/libzpaq/libzpaq-6.38.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-arch/libzpaq/ChangeLog b/app-arch/libzpaq/ChangeLog
index 53e5c38eba26..f6f0c47fee77 100644
--- a/app-arch/libzpaq/ChangeLog
+++ b/app-arch/libzpaq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/libzpaq
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/ChangeLog,v 1.9 2012/10/14 07:59:21 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/ChangeLog,v 1.10 2013/07/20 14:21:32 mgorny Exp $
+
+*libzpaq-6.38 (20 Jul 2013)
+
+ 20 Jul 2013; Michał Górny <mgorny@gentoo.org> +libzpaq-6.38.ebuild:
+ Version bump. Increase EAPI and introduce sub-slot for SONAME.
14 Oct 2012; Michał Górny <mgorny@gentoo.org> -libzpaq-2.02a-r1.ebuild,
-libzpaq-3.00.ebuild:
diff --git a/app-arch/libzpaq/libzpaq-6.38.ebuild b/app-arch/libzpaq/libzpaq-6.38.ebuild
new file mode 100644
index 000000000000..e80288cf1082
--- /dev/null
+++ b/app-arch/libzpaq/libzpaq-6.38.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/libzpaq-6.38.ebuild,v 1.1 2013/07/20 14:21:32 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils flag-o-matic eutils
+
+MY_P=zpaq${PV/./}
+DESCRIPTION="Library to compress files in the ZPAQ format"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="zpaq"
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +jit static-libs"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/0001-Add-autotools-files.patch
+ # XXX: update the patch instead when the old version is gone
+ touch libzpaqo.cpp || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-library-version=${SLOT#*/}:0:0
+ # man-page is no longer there
+ ac_cv_prog_POD2MAN=
+ )
+
+ use debug || append-cppflags -DNDEBUG
+ use jit || append-cppflags -DNOJIT
+
+ autotools-utils_src_configure
+}