summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-13 12:22:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-13 12:22:56 +0000
commitbd29c1f30939e0fffdad7775fa65493cd18eeed7 (patch)
tree5b4e44fffdb98c8c9f9bcd1bcd59a99b26e46c96 /app-arch/lz4/lz4-0_p120.ebuild
parentStable on ppc and ppc64, bug #522426 (diff)
downloadgentoo-2-bd29c1f30939e0fffdad7775fa65493cd18eeed7.tar.gz
gentoo-2-bd29c1f30939e0fffdad7775fa65493cd18eeed7.tar.bz2
gentoo-2-bd29c1f30939e0fffdad7775fa65493cd18eeed7.zip
export CC & AR for cross-compilation
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-arch/lz4/lz4-0_p120.ebuild')
-rw-r--r--app-arch/lz4/lz4-0_p120.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-arch/lz4/lz4-0_p120.ebuild b/app-arch/lz4/lz4-0_p120.ebuild
index 3a4540d102b4..00792f8a290c 100644
--- a/app-arch/lz4/lz4-0_p120.ebuild
+++ b/app-arch/lz4/lz4-0_p120.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-0_p120.ebuild,v 1.4 2014/08/26 11:31:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-0_p120.ebuild,v 1.5 2014/10/13 12:22:56 aballier Exp $
EAPI=5
-inherit multilib multilib-minimal
+inherit multilib multilib-minimal toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -35,6 +35,7 @@ src_prepare() {
}
multilib_src_compile() {
+ tc-export CC AR
# we must not use the 'all' target since it builds test programs
# & extra -m32 executables
emake