summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:42:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:42:32 +0000
commit1f577838887bbc08dfa54f5a8eb77a85103838bf (patch)
tree78317ef7752e0f8caa2e2088f821b3aede56b9f7 /app-arch/mt-st/mt-st-0.9b.ebuild
parentamd64 stable, bug #242952 (diff)
downloadgentoo-2-1f577838887bbc08dfa54f5a8eb77a85103838bf.tar.gz
gentoo-2-1f577838887bbc08dfa54f5a8eb77a85103838bf.tar.bz2
gentoo-2-1f577838887bbc08dfa54f5a8eb77a85103838bf.zip
Respect CFLAGS, LDFLAGS and CC.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-arch/mt-st/mt-st-0.9b.ebuild')
-rw-r--r--app-arch/mt-st/mt-st-0.9b.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-arch/mt-st/mt-st-0.9b.ebuild b/app-arch/mt-st/mt-st-0.9b.ebuild
index d501520601cc..b431de035a83 100644
--- a/app-arch/mt-st/mt-st-0.9b.ebuild
+++ b/app-arch/mt-st/mt-st-0.9b.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/mt-st-0.9b.ebuild,v 1.8 2007/08/16 10:51:37 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/mt-st-0.9b.ebuild,v 1.9 2008/10/23 02:42:32 flameeyes Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Enhanced mt command for Linux, supporting Linux 2.4 ioctls"
HOMEPAGE="http://www.gnu.org/software/tar/"
@@ -25,7 +25,8 @@ src_unpack() {
}
src_compile() {
- emake || die
+ # Builds straight from .c to final binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
}
src_install() {