summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-13 18:04:44 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-13 18:04:44 +0000
commit15019b04c5fef2f9bc268a47ca4d8f50c85f725c (patch)
tree1ea32967ac986f14293da2e3c572de25b4db548c /app-arch/p7zip
parentDrop alpha keyword (diff)
downloadgentoo-2-15019b04c5fef2f9bc268a47ca4d8f50c85f725c.tar.gz
gentoo-2-15019b04c5fef2f9bc268a47ca4d8f50c85f725c.tar.bz2
gentoo-2-15019b04c5fef2f9bc268a47ca4d8f50c85f725c.zip
This sed statement for darwin cannot die because USE=-rar removes one of the two targets. bug 314429
(Portage version: 2.1.7.17/cvs/Linux armv7l)
Diffstat (limited to 'app-arch/p7zip')
-rw-r--r--app-arch/p7zip/ChangeLog6
-rw-r--r--app-arch/p7zip/p7zip-9.04.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 7e9809aec44c..6f8eac5c94e5 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.115 2010/03/08 19:13:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.116 2010/04/13 18:04:44 darkside Exp $
+
+ 13 Apr 2010; Jeremy Olexa <darkside@gentoo.org> p7zip-9.04.ebuild:
+ This sed statement for darwin cannot die because USE=-rar removes one of
+ the two targets. bug 314429
08 Mar 2010; Fabian Groffen <grobian@gentoo.org> p7zip-9.04.ebuild:
Fix issues on Darwin: use correct makefile, patch makefile for rar, bug
diff --git a/app-arch/p7zip/p7zip-9.04.ebuild b/app-arch/p7zip/p7zip-9.04.ebuild
index 76a80e1351df..a01a236001db 100644
--- a/app-arch/p7zip/p7zip-9.04.ebuild
+++ b/app-arch/p7zip/p7zip-9.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.04.ebuild,v 1.3 2010/03/08 19:13:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.04.ebuild,v 1.4 2010/04/13 18:04:44 darkside Exp $
EAPI="2"
WX_GTK_VER="2.8"
@@ -55,10 +55,11 @@ src_prepare() {
[[ ${CHOST} == *64-* ]] \
&& cp -f makefile.macosx_64bits makefile.machine \
|| cp -f makefile.macosx_32bits makefile.machine
- # bundles have extension .bundle
+ # bundles have extension .bundle but don't die because USE=-rar
+ # removes the Rar directory
sed -i -e '/^PROG=/s/\.so/.bundle/' \
CPP/7zip/Bundles/Format7zFree/makefile \
- CPP/7zip/Compress/Rar/makefile || die
+ CPP/7zip/Compress/Rar/makefile
elif use x86-fbsd; then
# FreeBSD needs this special makefile, because it hasn't -ldl
sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine