summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-07-31 20:06:52 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-07-31 20:06:52 +0000
commitc9c3d3e2250136e5eae6a855bc4ba27583f190dd (patch)
treea17b08a6661b9793d1f10f64cff90e3147ba80fd /app-arch/pbzip2/pbzip2-1.0.2.ebuild
parentStable on amd64 wrt bug #186324 (diff)
downloadgentoo-2-c9c3d3e2250136e5eae6a855bc4ba27583f190dd.tar.gz
gentoo-2-c9c3d3e2250136e5eae6a855bc4ba27583f190dd.tar.bz2
gentoo-2-c9c3d3e2250136e5eae6a855bc4ba27583f190dd.zip
Version bump to 1.0.2 and removing older versions. Closing bug #186640.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-arch/pbzip2/pbzip2-1.0.2.ebuild')
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/pbzip2/pbzip2-1.0.2.ebuild b/app-arch/pbzip2/pbzip2-1.0.2.ebuild
new file mode 100644
index 000000000000..06ac4f0a8079
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.2.ebuild,v 1.1 2007/07/31 20:06:52 wolf31o2 Exp $
+
+inherit multilib
+
+DESCRIPTION="A parallel version of BZIP2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="app-arch/bzip2"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:-O3:${CFLAGS}:g' ${P}/Makefile || die
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a ${S}
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+}