summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-22 10:18:02 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-22 10:18:02 +0000
commita3bd0977166904cf50dd307db538a8d0f69db605 (patch)
treec682a1e0e7b35477e4e8c6dc3465b129c33caa8f /app-arch/ppmd
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-a3bd0977166904cf50dd307db538a8d0f69db605.tar.gz
gentoo-2-a3bd0977166904cf50dd307db538a8d0f69db605.tar.bz2
gentoo-2-a3bd0977166904cf50dd307db538a8d0f69db605.zip
filter out -O3 flag, replace with -O2 flag. Also, replaced the head && mv statement with an inline sed. closes bug #44529 by Tobias Minich <belgabor@gmx.de>
Diffstat (limited to 'app-arch/ppmd')
-rw-r--r--app-arch/ppmd/ChangeLog7
-rw-r--r--app-arch/ppmd/ppmd-9.1.ebuild16
2 files changed, 17 insertions, 6 deletions
diff --git a/app-arch/ppmd/ChangeLog b/app-arch/ppmd/ChangeLog
index 0239861ad217..9a8fb417a787 100644
--- a/app-arch/ppmd/ChangeLog
+++ b/app-arch/ppmd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/ppmd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ChangeLog,v 1.3 2004/03/12 15:17:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ChangeLog,v 1.4 2004/03/22 10:18:02 seemant Exp $
+
+ 22 Mar 2004; Seemant Kulleen <seemant@gentoo.org> ppmd-9.1.ebuild:
+ filter out -O3 flag, replace with -O2 flag. Also, replaced the head && mv
+ statement with an inline sed. closes bug #44529 by Tobias Minich
+ <belgabor@gmx.de>
12 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> ppmd-9.1.ebuild:
amd64 unmask.
diff --git a/app-arch/ppmd/ppmd-9.1.ebuild b/app-arch/ppmd/ppmd-9.1.ebuild
index 4e920e669caf..91a488b9874c 100644
--- a/app-arch/ppmd/ppmd-9.1.ebuild
+++ b/app-arch/ppmd/ppmd-9.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ppmd-9.1.ebuild,v 1.5 2004/03/12 15:17:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ppmd-9.1.ebuild,v 1.6 2004/03/22 10:18:02 seemant Exp $
-inherit eutils
+inherit eutils flag-o-matic
IUSE=""
@@ -19,7 +19,8 @@ SLOT="0"
LICENSE="public-domain"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips amd64 ~ia64"
-DEPEND="app-arch/gzip
+DEPEND=">=sys-apps/sed-4
+ app-arch/gzip
sys-devel/patch
sys-devel/autoconf
sys-devel/automake"
@@ -29,11 +30,16 @@ src_unpack() {
cd ${S}
epatch ${WORKDIR}/${MY_P}-${PATCHV}.diff
chmod +x ${S}/configure
- head -n 3 Makefile.am > Makefile.am.new
- mv Makefile.am.new Makefile.am
+ sed -i 3q Makefile.am
autoreconf --force || die
}
+src_compile() {
+ replace-flags "-O3" "-O2"
+ econf || die
+ emake || die
+}
+
src_install() {
einstall || die
doman ${S}/PPMd.1