summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-27 05:43:29 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-27 05:43:29 +0000
commit6153059ebdb1a5a255fed6c71999793772800cf6 (patch)
tree44ea4aad846c6da4455aa8782fd5c740c0c88e24 /app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
parentRespect LDFLAGS and CFLAGS by Ross Smith (bug #334591). (diff)
downloadgentoo-2-6153059ebdb1a5a255fed6c71999793772800cf6.tar.gz
gentoo-2-6153059ebdb1a5a255fed6c71999793772800cf6.tar.bz2
gentoo-2-6153059ebdb1a5a255fed6c71999793772800cf6.zip
Respect LDFLAGS by Ross Smith (bug #334599).
(Portage version: 2.2_rc69/cvs/Linux i686)
Diffstat (limited to 'app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild')
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
new file mode 100644
index 000000000000..8c8b381c2b09
--- /dev/null
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild,v 1.1 2010/08/27 05:43:29 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility to test and create .sfv files and create .par files"
+HOMEPAGE="http://pure-sfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i Makefile -e "s:-Werror -O2 -g::"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin pure-sfv || die "dobin failed"
+ dodoc ReadMe.txt
+}