summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-25 23:27:35 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-25 23:27:35 +0000
commit9b81887ec3a93a72e0135d6eba6a62523e209932 (patch)
tree8c4cdf4d14dd3223a87d2bf5479d7a39d30cc7a9 /app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild
parentarm/s390/sh stable (diff)
downloadgentoo-2-9b81887ec3a93a72e0135d6eba6a62523e209932.tar.gz
gentoo-2-9b81887ec3a93a72e0135d6eba6a62523e209932.tar.bz2
gentoo-2-9b81887ec3a93a72e0135d6eba6a62523e209932.zip
Respect CC env var #243506.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild')
-rw-r--r--app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild
index cf7e3f37867c..2397002e9390 100644
--- a/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild
+++ b/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild,v 1.1 2008/09/17 11:25:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm2targz/rpm2targz-9.0.0.3g.ebuild,v 1.2 2008/10/25 23:27:35 vapier Exp $
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
HOMEPAGE="http://www.slackware.com/config/packages.php"
@@ -19,6 +19,10 @@ RDEPEND="app-arch/cpio"
DEPEND="${DEPEND}
app-arch/lzma-utils"
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
src_install() {
emake install DESTDIR="${D}" || die
dodoc *.README*