summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-11 18:51:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-11 18:51:35 +0000
commitbd1d17445a84d0b67cc6cf8207220074c4501304 (patch)
tree2d6075dda84c70fc396cdb1a52a0ad0b4f30f0b9 /app-arch/tar
parentVersion bumped to 3334 and closing bug #65232. (Manifest recommit) (diff)
downloadgentoo-2-bd1d17445a84d0b67cc6cf8207220074c4501304.tar.gz
gentoo-2-bd1d17445a84d0b67cc6cf8207220074c4501304.tar.bz2
gentoo-2-bd1d17445a84d0b67cc6cf8207220074c4501304.zip
add patch from gnulib cvs #67038
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog6
-rw-r--r--app-arch/tar/files/1.14.90-gnulib.patch99
-rw-r--r--app-arch/tar/tar-1.14.90.ebuild7
3 files changed, 108 insertions, 4 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index d0fc79a1a78c..92c3ad5c9373 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/tar
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.33 2004/10/11 04:28:00 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.34 2004/10/11 18:51:35 vapier Exp $
+
+ 11 Oct 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.14.90-gnulib.patch, tar-1.14.90.ebuild:
+ Add a patch from the gnulib cvs to fix #67038 by joecool.
10 Oct 2004; Seemant Kulleen <seemant@gentoo.org> :
add metadata
diff --git a/app-arch/tar/files/1.14.90-gnulib.patch b/app-arch/tar/files/1.14.90-gnulib.patch
new file mode 100644
index 000000000000..44cce2704f35
--- /dev/null
+++ b/app-arch/tar/files/1.14.90-gnulib.patch
@@ -0,0 +1,99 @@
+Index: argp.h
+===================================================================
+RCS file: /cvsroot/gnulib/gnulib/lib/argp.h,v
+retrieving revision 1.5
+retrieving revision 1.8
+diff -u -b -B -r1.5 -r1.8
+--- lib/argp.h 4 Oct 2003 12:28:07 -0000 1.5
++++ lib/argp.h 30 Sep 2004 16:41:57 -0000 1.8
+@@ -1,5 +1,5 @@
+ /* Hierarchial argument parsing, layered over getopt.
+- Copyright (C) 1995,1996,1997,1998,1999,2003 Free Software Foundation, Inc.
++ Copyright (C) 1995-1999,2003,2004 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+ Written by Miles Bader <miles@gnu.ai.mit.edu>.
+
+@@ -34,6 +34,9 @@
+ #ifndef __THROW
+ # define __THROW
+ #endif
++#ifndef __NTH
++# define __NTH(fct) fct __THROW
++#endif
+
+ #ifndef __attribute__
+ /* This feature is available in gcc versions 2.5 and later. */
+@@ -48,6 +51,18 @@
+ # endif
+ #endif
+
++/* GCC 2.95 and later have "__restrict"; C99 compilers have
++ "restrict", and "configure" may have defined "restrict". */
++#ifndef __restrict
++# if ! (2 < __GNUC__ || (2 == __GNUC__ && 95 <= __GNUC_MINOR__))
++# if defined restrict || 199901L <= __STDC_VERSION__
++# define __restrict restrict
++# else
++# define __restrict
++# endif
++# endif
++#endif
++
+ #ifndef __error_t_defined
+ typedef int error_t;
+ # define __error_t_defined
+@@ -111,11 +126,12 @@
+ should be displayed in much the same manner as the options. If this flag
+ is set, then the option NAME field is displayed unmodified (e.g., no `--'
+ prefix is added) at the left-margin (where a *short* option would normally
+- be displayed), and the documentation string in the normal place. For
+- purposes of sorting, any leading whitespace and punctuation is ignored,
+- except that if the first non-whitespace character is not `-', this entry
+- is displayed after all options (and OPTION_DOC entries with a leading `-')
+- in the same group. */
++ be displayed), and the documentation string in the normal place. The NAME
++ field will be translated using gettext, unless OPTION_NO_TRANS is set (see
++ below). For purposes of sorting, any leading whitespace and punctuation is
++ ignored, except that if the first non-whitespace character is not `-', this
++ entry is displayed after all options (and OPTION_DOC entries with a leading
++ `-') in the same group. */
+ #define OPTION_DOC 0x8
+
+ /* This option shouldn't be included in `long' usage messages (but is still
+@@ -127,6 +143,11 @@
+ OPTION_NO_USAGE. */
+ #define OPTION_NO_USAGE 0x10
+
++/* Valid only in conjunction with OPTION_DOC. This option disables translation
++ of option name. */
++#define OPTION_NO_TRANS 0x20
++
++
+ struct argp; /* fwd declare this type */
+ struct argp_state; /* " */
+ struct argp_child; /* " */
+@@ -545,13 +566,13 @@
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__NTH (__argp_usage (__const struct argp_state *__state))
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__NTH (__option_is_short (__const struct argp_option *__opt))
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -563,7 +584,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__NTH (__option_is_end (__const struct argp_option *__opt))
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/app-arch/tar/tar-1.14.90.ebuild b/app-arch/tar/tar-1.14.90.ebuild
index 5e1c3cd7393c..96b2ef9b7974 100644
--- a/app-arch/tar/tar-1.14.90.ebuild
+++ b/app-arch/tar/tar-1.14.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.90.ebuild,v 1.5 2004/10/11 04:26:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.90.ebuild,v 1.6 2004/10/11 18:51:35 vapier Exp $
inherit flag-o-matic eutils gnuconfig
@@ -25,8 +25,9 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PV}-remote-shell.patch
- epatch ${FILESDIR}/${PV}-tests.patch
+ epatch ${FILESDIR}/${PV}-remote-shell.patch #66959
+ epatch ${FILESDIR}/${PV}-tests.patch #67023
+ epatch ${FILESDIR}/${PV}-gnulib.patch #67038
gnuconfig_update
use static && append-ldflags -static
}