summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-14 18:12:39 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-14 18:12:39 +0000
commiteddc80bd90024f2d4bfba192d58d6248449f9f28 (patch)
tree7d735c6479149eebd36dd9a7610863fbf987a24c /app-arch/tar
parentEbuild cleanup. (diff)
downloadgentoo-2-eddc80bd90024f2d4bfba192d58d6248449f9f28.tar.gz
gentoo-2-eddc80bd90024f2d4bfba192d58d6248449f9f28.tar.bz2
gentoo-2-eddc80bd90024f2d4bfba192d58d6248449f9f28.zip
Revision bump, with patch to fix the stdin/stderr weirdness. Should fix bug #151239.
(Portage version: 2.1.2_pre3-r1)
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog9
-rw-r--r--app-arch/tar/files/1.15.92-stderr.patch37
-rw-r--r--app-arch/tar/files/digest-tar-1.15.92-r13
-rw-r--r--app-arch/tar/tar-1.15.92-r1.ebuild71
4 files changed, 119 insertions, 1 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index e202de1a2b5d..21f371afa28a 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/tar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.66 2006/10/13 00:41:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.67 2006/10/14 18:12:39 swegener Exp $
+
+*tar-1.15.92-r1 (14 Oct 2006)
+
+ 14 Oct 2006; Sven Wegener <swegener@gentoo.org>
+ +files/1.15.92-stderr.patch, -tar-1.15.92.ebuild, +tar-1.15.92-r1.ebuild:
+ Revision bump, with patch to fix the stdin/stderr weirdness. Should fix bug
+ #151239.
*tar-1.15.92 (13 Oct 2006)
diff --git a/app-arch/tar/files/1.15.92-stderr.patch b/app-arch/tar/files/1.15.92-stderr.patch
new file mode 100644
index 000000000000..c324b8e7e53a
--- /dev/null
+++ b/app-arch/tar/files/1.15.92-stderr.patch
@@ -0,0 +1,37 @@
+Index: src/buffer.c
+===================================================================
+RCS file: /sources/tar/tar/src/buffer.c,v
+retrieving revision 1.107
+retrieving revision 1.108
+diff --unified -B -b -r1.107 -r1.108
+--- src/buffer.c 2 Oct 2006 15:44:09 -0000 1.107
++++ src/buffer.c 14 Oct 2006 10:45:44 -0000 1.108
+@@ -474,6 +474,11 @@
+ abort (); /* Should not happen */
+ break;
+ }
++
++ if (!index_file_name
++ && wanted_access == ACCESS_WRITE
++ && strcmp (archive_name_array[0], "-") == 0)
++ stdlis = stderr;
+ }
+ else if (strcmp (archive_name_array[0], "-") == 0)
+ {
+@@ -499,12 +504,16 @@
+
+ case ACCESS_WRITE:
+ archive = STDOUT_FILENO;
++ if (!index_file_name)
++ stdlis = stderr;
+ break;
+
+ case ACCESS_UPDATE:
+ archive = STDIN_FILENO;
+ write_archive_to_stdout = true;
+ record_end = record_start; /* set up for 1st record = # 0 */
++ if (!index_file_name)
++ stdlis = stderr;
+ break;
+ }
+ }
diff --git a/app-arch/tar/files/digest-tar-1.15.92-r1 b/app-arch/tar/files/digest-tar-1.15.92-r1
new file mode 100644
index 000000000000..5ebf7e5ec7d9
--- /dev/null
+++ b/app-arch/tar/files/digest-tar-1.15.92-r1
@@ -0,0 +1,3 @@
+MD5 a3eb73178ed9e4a2eaefb62b1a65eb58 tar-1.15.92.tar.bz2 1766348
+RMD160 053d80a22f4df6b9121de8400a47d300f72b7c0b tar-1.15.92.tar.bz2 1766348
+SHA256 14e36c1140133c70e8f2a892d8b8a3a55a7639c1d54baf39b41a34586d8b09c5 tar-1.15.92.tar.bz2 1766348
diff --git a/app-arch/tar/tar-1.15.92-r1.ebuild b/app-arch/tar/tar-1.15.92-r1.ebuild
new file mode 100644
index 000000000000..1c3b0f9a6bf2
--- /dev/null
+++ b/app-arch/tar/tar-1.15.92-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.15.92-r1.ebuild,v 1.1 2006/10/14 18:12:39 swegener Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
+ ftp://alpha.gnu.org/gnu/tar/${P}.tar.bz2
+ mirror://gnu/tar/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static build bzip2"
+
+RDEPEND="app-arch/gzip
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/1.15.92-stderr.patch
+
+ if ! use userland_GNU ; then
+ sed -i \
+ -e 's:/backup\.sh:/gbackup.sh:' \
+ scripts/{backup,dump-remind,restore}.in \
+ || die "sed non-GNU"
+ fi
+}
+
+src_compile() {
+ local myconf
+ use static && append-ldflags -static
+ use userland_GNU || myconf="--program-prefix=g"
+ # Work around bug in sandbox #67051
+ gl_cv_func_chown_follows_symlink=yes \
+ econf \
+ --enable-backup-scripts \
+ --bindir=/bin \
+ --libexecdir=/usr/sbin \
+ $(use_enable nls) \
+ ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ # a nasty yet required symlink
+ local p=""
+ use userland_GNU || p=g
+ dodir /etc
+ dosym /usr/sbin/${p}rmt /etc/${p}rmt
+ if use build ; then
+ rm -r "${D}"/usr
+ else
+ dodir /usr/bin
+ dosym /bin/${p}tar /usr/bin/${p}tar
+ dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
+ newman "${FILESDIR}"/tar.1 ${p}tar.1
+ mv "${D}"/usr/sbin/${p}backup{,-tar}
+ mv "${D}"/usr/sbin/${p}restore{,-tar}
+ fi
+
+ rm -f ${D}/usr/$(get_libdir)/charset.alias
+}