summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-28 18:24:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-28 18:24:48 +0000
commitce37ae00d37b89a332ece8b3182506d597c63717 (patch)
treea34eacb80d558389f09755515ad09d9477c93dee /app-arch/xar/xar-20050423.ebuild
parentVersion Bump (diff)
downloadgentoo-2-ce37ae00d37b89a332ece8b3182506d597c63717.tar.gz
gentoo-2-ce37ae00d37b89a332ece8b3182506d597c63717.tar.bz2
gentoo-2-ce37ae00d37b89a332ece8b3182506d597c63717.zip
Added patch to compile with -fPIC the library, and unset $SYMLINK_LIB which is set by AMD64-multilib profile and conflicts with internal build one.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-arch/xar/xar-20050423.ebuild')
-rw-r--r--app-arch/xar/xar-20050423.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-arch/xar/xar-20050423.ebuild b/app-arch/xar/xar-20050423.ebuild
index 220b71ad83dc..952a39f3f407 100644
--- a/app-arch/xar/xar-20050423.ebuild
+++ b/app-arch/xar/xar-20050423.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xar/xar-20050423.ebuild,v 1.1 2005/04/24 04:57:07 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xar/xar-20050423.ebuild,v 1.2 2005/06/28 18:24:48 flameeyes Exp $
inherit eutils flag-o-matic
@@ -19,10 +19,21 @@ DEPEND="${RDEPEND}
dev-libs/libxml2
sys-libs/zlib"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
src_compile() {
use debug && myconf="${myconf} --enable-symbols"
use ppc64 && myconf="${myconf} --enable-64bit"
use sparc && myconf="${myconf} --enable-64bit-vis"
+
+ # This is a var used by AMD64-multilib, unset this
+ # or we'll have problems during econf/emake
+ unset SYMLINK_LIB
+
econf ${myconf} || die
emake || die
}