summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-07-10 02:30:54 +0000
committerYixun Lan <dlan@gentoo.org>2014-07-10 02:30:54 +0000
commit1e6a092739fb896e0655f79e68fdbcc3d73876ec (patch)
tree29eb36dcade050f99b9bcd0c803b24f528ab555c /app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
parentRemove unneeded useflag description from metadata.xml (diff)
downloadgentoo-2-1e6a092739fb896e0655f79e68fdbcc3d73876ec.tar.gz
gentoo-2-1e6a092739fb896e0655f79e68fdbcc3d73876ec.tar.bz2
gentoo-2-1e6a092739fb896e0655f79e68fdbcc3d73876ec.zip
version bump, bug 516468, proxy for Alex Xu (Hello71)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild')
-rw-r--r--app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild b/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
new file mode 100644
index 000000000000..e183980b291f
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild,v 1.1 2014/07/10 02:30:54 dlan Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Compression library programmed in C to perform very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/Hello71/zopfli/"
+SRC_URI="https://github.com/Hello71/zopfli/archive/1c07f374419ccb352412fd6403acc2b59ab6cce7.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ tc-export CC CXX
+
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" install
+ dodoc CONTRIBUTORS README README.${PN}png
+}