summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-14 07:21:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-14 07:21:00 +0000
commit191a31d3fcd3199bd59d2cca3a66007fb7761d45 (patch)
tree03ab34716672cc28340c258bd9baccfb0e7c7343 /app-arch
parentstable x86, bug 279398 (diff)
downloadgentoo-2-191a31d3fcd3199bd59d2cca3a66007fb7761d45.tar.gz
gentoo-2-191a31d3fcd3199bd59d2cca3a66007fb7761d45.tar.bz2
gentoo-2-191a31d3fcd3199bd59d2cca3a66007fb7761d45.zip
Version bump by Vladimir #280434.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/ChangeLog8
-rw-r--r--app-arch/unzip/files/unzip-6.0-no-exec-stack.patch13
-rw-r--r--app-arch/unzip/unzip-6.0.ebuild70
3 files changed, 90 insertions, 1 deletions
diff --git a/app-arch/unzip/ChangeLog b/app-arch/unzip/ChangeLog
index abfd43bb3dd4..562922d469f5 100644
--- a/app-arch/unzip/ChangeLog
+++ b/app-arch/unzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/unzip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/ChangeLog,v 1.58 2009/05/29 23:50:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/ChangeLog,v 1.59 2009/08/14 07:20:59 vapier Exp $
+
+*unzip-6.0 (14 Aug 2009)
+
+ 14 Aug 2009; Mike Frysinger <vapier@gentoo.org> +unzip-6.0.ebuild,
+ +files/unzip-6.0-no-exec-stack.patch:
+ Version bump by Vladimir #280434.
29 May 2009; Mike Frysinger <vapier@gentoo.org> -unzip-5.52-r1.ebuild:
Punt old package vuln to GLSA 200804-06 #271725 by Robert Buchholz.
diff --git a/app-arch/unzip/files/unzip-6.0-no-exec-stack.patch b/app-arch/unzip/files/unzip-6.0-no-exec-stack.patch
new file mode 100644
index 000000000000..7973378704e1
--- /dev/null
+++ b/app-arch/unzip/files/unzip-6.0-no-exec-stack.patch
@@ -0,0 +1,13 @@
+Make sure that the asm files don't incorrectly trigger an executable
+stack marking in the final shared library. That's bad, mmmkay.
+
+--- unzip/crc_i386.S
++++ unzip/crc_i386.S
+@@ -302,3 +302,7 @@
+ #endif /* i386 || _i386 || _I386 || __i386 */
+
+ #endif /* !USE_ZLIB && !CRC_TABLE_ONLY */
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/app-arch/unzip/unzip-6.0.ebuild b/app-arch/unzip/unzip-6.0.ebuild
new file mode 100644
index 000000000000..57587a096516
--- /dev/null
+++ b/app-arch/unzip/unzip-6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-6.0.ebuild,v 1.1 2009/08/14 07:20:59 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${PN}${PV/.}"
+
+DESCRIPTION="unzipper for pkzip-compressed files"
+HOMEPAGE="http://www.info-zip.org/"
+SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz"
+
+LICENSE="Info-ZIP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 unicode"
+
+DEPEND="bzip2? ( app-arch/bzip2 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-exec-stack.patch
+ sed -i \
+ -e '/^CFLAGS/d' \
+ -e '/CFLAGS/s:-O[0-9]\?:$(CFLAGS) $(CPPFLAGS):' \
+ -e '/^STRIP/s:=.*:=true:' \
+ -e "s:CC=gcc :CC=$(tc-getCC) :" \
+ -e "s:LD=gcc :LD=$(tc-getCC) :" \
+ -e "s:AS=gcc :AS=$(tc-getCC) :" \
+ -e 's:LF2 = -s:LF2 = :' \
+ -e 's:LF = :LF = $(LDFLAGS) :' \
+ -e 's:SL = :SL = $(LDFLAGS) :' \
+ -e 's:FL = :FL = $(LDFLAGS) :' \
+ -e "/^#L_BZ2/s:^$(use bzip2 && echo .)::" \
+ unix/Makefile \
+ || die "sed unix/Makefile failed"
+}
+
+src_compile() {
+ local TARGET
+ case ${CHOST} in
+ i?86*-*linux*) TARGET=linux_asm ;;
+ *linux*) TARGET=linux_noasm ;;
+ i?86*-*bsd* | \
+ i?86*-dragonfly*) TARGET=freebsd ;; # mislabelled bsd with x86 asm
+ *bsd* | *dragonfly*) TARGET=bsd ;;
+ *-darwin*) TARGET=macosx ;;
+ *) die "Unknown target, you suck" ;;
+ esac
+
+ [[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
+ use bzip2 && append-cppflags -DUSE_BZIP2
+ use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE
+ append-lfs-flags #104315
+
+ emake \
+ -f unix/Makefile \
+ ${TARGET} || die "emake failed"
+}
+
+src_install() {
+ dobin unzip funzip unzipsfx unix/zipgrep || die "dobin failed"
+ dosym unzip /usr/bin/zipinfo || die
+ doman man/*.1
+ dodoc BUGS History* README ToDo WHERE
+}