summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-08-30 10:50:04 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-08-30 10:50:04 +0000
commit5625997e0cc403b8942a195038295b5fa57f68a9 (patch)
treef5906c6a6a0d9584e653ce2be602499b82999505 /app-arch
parentversion bump (diff)
downloadgentoo-2-5625997e0cc403b8942a195038295b5fa57f68a9.tar.gz
gentoo-2-5625997e0cc403b8942a195038295b5fa57f68a9.tar.bz2
gentoo-2-5625997e0cc403b8942a195038295b5fa57f68a9.zip
Support for LZMA as written by Oschtan in bug #357703. Ported to EAPI 4.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/deb2targz/ChangeLog10
-rw-r--r--app-arch/deb2targz/deb2targz-1-r1.ebuild29
-rw-r--r--app-arch/deb2targz/files/deb2targz-lzma-support.patch18
3 files changed, 55 insertions, 2 deletions
diff --git a/app-arch/deb2targz/ChangeLog b/app-arch/deb2targz/ChangeLog
index 66ca7acf321c..6c2516c8e186 100644
--- a/app-arch/deb2targz/ChangeLog
+++ b/app-arch/deb2targz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/deb2targz
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/deb2targz/ChangeLog,v 1.12 2009/06/19 22:07:35 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/deb2targz/ChangeLog,v 1.13 2011/08/30 10:50:04 chainsaw Exp $
+
+*deb2targz-1-r1 (30 Aug 2011)
+
+ 30 Aug 2011; Tony Vroon <chainsaw@gentoo.org>
+ +files/deb2targz-lzma-support.patch, +deb2targz-1-r1.ebuild:
+ Support for LZMA as written by Oschtan in bug #357703. Ported to EAPI 4.
19 Jun 2009; Brent Baude <ranger@gentoo.org> deb2targz-1.ebuild:
keyworded ~arch for ppc64, bug 272587
diff --git a/app-arch/deb2targz/deb2targz-1-r1.ebuild b/app-arch/deb2targz/deb2targz-1-r1.ebuild
new file mode 100644
index 000000000000..6155b1c3a48d
--- /dev/null
+++ b/app-arch/deb2targz/deb2targz-1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/deb2targz/deb2targz-1-r1.ebuild,v 1.1 2011/08/30 10:50:04 chainsaw Exp $
+
+EAPI=4
+inherit base
+
+DESCRIPTION="Convert a .deb file to a .tar.gz archive"
+HOMEPAGE="http://www.miketaylor.org.uk/tech/deb/"
+SRC_URI="http://www.miketaylor.org.uk/tech/deb/${PN}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${PN}-lzma-support.patch" )
+
+src_unpack() {
+ cp "${DISTDIR}/${PN}" "${S}"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-arch/deb2targz/files/deb2targz-lzma-support.patch b/app-arch/deb2targz/files/deb2targz-lzma-support.patch
new file mode 100644
index 000000000000..3999f6c66977
--- /dev/null
+++ b/app-arch/deb2targz/files/deb2targz-lzma-support.patch
@@ -0,0 +1,18 @@
+--- deb2targz-old 2011-03-07 03:24:22.000000000 +0600
++++ deb2targz 2011-03-07 03:22:20.000000000 +0600
+@@ -59,4 +59,15 @@
+ next FILE;
+ }
++ if ($name eq "data.tar.lzma") {
++ # Found it
++ $data = substr($data, 0, $len);
++ $filename =~ s/\.deb$/.tar.gz/;
++ my $fh = new IO::File(">$filename")
++ or die "can't write '$filename': $!";
++ print $fh $data;
++ $fh->close();
++ print "$0: wrote '$filename'\n";
++ next FILE;
++ }
+
+ print "$0: skipping section '$name'\n";