summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-26 23:11:21 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-26 23:11:21 +0000
commit5b011d7f0e89b7333f4ac89f940d32dd1a5de835 (patch)
tree3c8c331338491a7e7311fb37b4e06dfe148fc893 /app-arch
parentVersion bump (diff)
downloadgentoo-2-5b011d7f0e89b7333f4ac89f940d32dd1a5de835.tar.gz
gentoo-2-5b011d7f0e89b7333f4ac89f940d32dd1a5de835.tar.bz2
gentoo-2-5b011d7f0e89b7333f4ac89f940d32dd1a5de835.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.11.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 0c8353ea5547..0e0ad091c47e 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.163 2011/04/16 16:29:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.164 2011/04/26 23:11:21 jer Exp $
+
+*dpkg-1.15.8.11 (26 Apr 2011)
+
+ 26 Apr 2011; Jeroen Roovers <jer@gentoo.org> +dpkg-1.15.8.11.ebuild:
+ Version bump.
16 Apr 2011; Jeroen Roovers <jer@gentoo.org> -dpkg-1.15.8.9.ebuild,
dpkg-1.15.8.10.ebuild, dpkg-1.16.0.ebuild, dpkg-1.16.0.1.ebuild:
diff --git a/app-arch/dpkg/dpkg-1.15.8.11.ebuild b/app-arch/dpkg/dpkg-1.15.8.11.ebuild
new file mode 100644
index 000000000000..574a780faaa3
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.15.8.11.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.11.ebuild,v 1.1 2011/04/26 23:11:21 jer Exp $
+
+EAPI=3
+
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="bzip2 dselect nls test unicode zlib"
+
+LANGS="
+ ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
+ nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
+"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( app-text/po4a )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
+
+ # don't mess with linker optimisation, respect user's flags (don't break!)
+ sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # this test depends on a Debian only gzip extension that adds --rsyncable
+ # which will therefore always fail on Gentoo. (bug #310847).
+ sed -i scripts/Makefile.am \
+ -e '/850_Dpkg_Compression.t/d' \
+ || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ if use nls; then
+ myconf="--enable-nls $(use_with dselect)"
+ else
+ if use dselect; then
+ elog "Building dselect requires USE=nls - disabling USE=dselect..."
+ fi
+ myconf="--disable-nls --without-dselect"
+ fi
+ econf \
+ ${myconf} \
+ $(use_with bzip2 bz2) \
+ $(use_enable unicode) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --without-selinux \
+ --without-start-stop-daemon
+}
+
+src_install() {
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ LINGUAS=none
+ fi
+
+ emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
+ rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}