summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-13 22:01:44 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-13 22:01:44 +0000
commita1f3b7e94a59ac768923c292b16d09beff38a899 (patch)
treeef6f835ce6eb0b3a924fd87627e40c47aabe8a9a /app-arch
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-a1f3b7e94a59ac768923c292b16d09beff38a899.tar.gz
gentoo-2-a1f3b7e94a59ac768923c292b16d09beff38a899.tar.bz2
gentoo-2-a1f3b7e94a59ac768923c292b16d09beff38a899.zip
Non-maintainer commit, version bump to 10.1.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/ppmd/ChangeLog10
-rw-r--r--app-arch/ppmd/ppmd-10.1_p5.ebuild42
2 files changed, 49 insertions, 3 deletions
diff --git a/app-arch/ppmd/ChangeLog b/app-arch/ppmd/ChangeLog
index e9b93867dd5c..e42f0fce561b 100644
--- a/app-arch/ppmd/ChangeLog
+++ b/app-arch/ppmd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/ppmd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ChangeLog,v 1.39 2012/05/10 14:43:28 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ChangeLog,v 1.40 2013/03/13 22:01:44 tomwij Exp $
+
+*ppmd-10.1_p5 (13 Mar 2013)
+
+ 13 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +ppmd-10.1_p5.ebuild:
+ Non-maintainer commit, version bump to 10.1.
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -ppmd-9.1_p10.ebuild:
Remove old
@@ -133,4 +138,3 @@
15 Nov 2003; Seemant Kulleen <seemant@gentoo.org> ppmd-9.1.ebuild:
PPM based compressor. Ebuild submitted by Brian Harring <bdharring@wisc.edu>
in bug #33066
-
diff --git a/app-arch/ppmd/ppmd-10.1_p5.ebuild b/app-arch/ppmd/ppmd-10.1_p5.ebuild
new file mode 100644
index 000000000000..792f0b30decb
--- /dev/null
+++ b/app-arch/ppmd/ppmd-10.1_p5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ppmd-10.1_p5.ebuild,v 1.1 2013/03/13 22:01:44 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+PATCHV="${P##*_p}"
+MY_P="${P%%_*}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION="PPM based compressor -- better behaved than bzip2"
+HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/ppmd/"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/${PN::1}/${PN}/${MY_P}-${PATCHV}.debian.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="-alpha -amd64 ~hppa -ia64 ~mips ~ppc ~sparc ~x86 ~x86-interix -amd64-linux -ia64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+S="${WORKDIR}/${P%%_*}"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch "${WORKDIR}"/debian/patches/
+ epatch "${FILESDIR}/${PN}-p10-makefile.patch"
+ sed b/Makefile \
+ -e 's|$(CXX)|& $(CFLAGS) $(LDFLAGS)|g' > Makefile \
+ || die "sed b/Makefile"
+}
+
+src_configure() {
+ tc-export CXX
+ replace-flags -O3 -O2
+ append-flags -fno-inline-functions -fno-exceptions -fno-rtti
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${ED}"
+ doman "${WORKDIR}/debian/ppmd.1"
+ dodoc "read_me.txt"
+}