summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-23 13:48:32 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-23 13:48:32 +0000
commitad0382ff0f230ee8da15947fedbe933de6d6a36f (patch)
tree79eec3c59556afe54d23d50789bf6f81b214e749 /app-arch
parentStable on sparc (diff)
downloadgentoo-2-ad0382ff0f230ee8da15947fedbe933de6d6a36f.tar.gz
gentoo-2-ad0382ff0f230ee8da15947fedbe933de6d6a36f.tar.bz2
gentoo-2-ad0382ff0f230ee8da15947fedbe933de6d6a36f.zip
Fix permissions, bug #182628
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/torrentzip/ChangeLog10
-rw-r--r--app-arch/torrentzip/files/digest-torrentzip-0.2-r1 (renamed from app-arch/torrentzip/files/digest-torrentzip-0.2)0
-rw-r--r--app-arch/torrentzip/files/fix-perms.patch11
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r1.ebuild (renamed from app-arch/torrentzip/torrentzip-0.2.ebuild)13
4 files changed, 29 insertions, 5 deletions
diff --git a/app-arch/torrentzip/ChangeLog b/app-arch/torrentzip/ChangeLog
index 82a1cca419ac..6798d1e48823 100644
--- a/app-arch/torrentzip/ChangeLog
+++ b/app-arch/torrentzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/torrentzip
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/torrentzip/ChangeLog,v 1.1 2006/06/18 05:14:50 squinky86 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/torrentzip/ChangeLog,v 1.2 2007/07/23 13:48:32 armin76 Exp $
+
+*torrentzip-0.2-r1 (23 Jul 2007)
+
+ 23 Jul 2007; Raúl Porcel <armin76@gentoo.org> +files/fix-perms.patch,
+ -torrentzip-0.2.ebuild, +torrentzip-0.2-r1.ebuild:
+ Fix permissions, bug #182628
*torrentzip-0.2 (18 Jun 2006)
diff --git a/app-arch/torrentzip/files/digest-torrentzip-0.2 b/app-arch/torrentzip/files/digest-torrentzip-0.2-r1
index fb1341eff888..fb1341eff888 100644
--- a/app-arch/torrentzip/files/digest-torrentzip-0.2
+++ b/app-arch/torrentzip/files/digest-torrentzip-0.2-r1
diff --git a/app-arch/torrentzip/files/fix-perms.patch b/app-arch/torrentzip/files/fix-perms.patch
new file mode 100644
index 000000000000..ea013663443f
--- /dev/null
+++ b/app-arch/torrentzip/files/fix-perms.patch
@@ -0,0 +1,11 @@
+--- src/trrntzip.c
++++ src/trrntzip.c
+@@ -782,7 +782,7 @@
+
+ if (strstr (szTmpBuf, ".zip\0") && !(istat.st_mode & S_IWUSR))
+ {
+- chmod (direntp->d_name, S_IWUSR);
++ chmod (direntp->d_name, S_IWUSR | S_IRUSR);
+ mig.cEncounteredZips++;
+
+ if (!mig.fProcessLog)
diff --git a/app-arch/torrentzip/torrentzip-0.2.ebuild b/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
index d1cce064ec65..7d40d170351e 100644
--- a/app-arch/torrentzip/torrentzip-0.2.ebuild
+++ b/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/torrentzip/torrentzip-0.2.ebuild,v 1.1 2006/06/18 05:14:50 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/torrentzip/torrentzip-0.2-r1.ebuild,v 1.1 2007/07/23 13:48:32 armin76 Exp $
-inherit versionator
+inherit versionator eutils
DESCRIPTION="archiving program that uses standard values when creating zips to create identical files over multiple systems with the ability to create a torrentzip format from a zip file"
HOMEPAGE="https://sourceforge.net/projects/trrntzip"
@@ -21,6 +21,13 @@ DEPEND="sys-libs/zlib"
S=${WORKDIR}/trrntzip
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/fix-perms.patch
+}
+
src_compile() {
./autogen.sh